locked
Notification Icon and GUI Missing for Scheduled Admin Task RRS feed

  • Question

  • hi

    i scheduled a task to run an .exe. on logon of any user. 
    It works, but not seeing the program's GUI or Notification Area icon. 
    • When run manually by a non-admin user, the desired .exe always requests an admin password. That is fine.
    • When run manually, an icon is displayed in the notification area, which is good. I want to see the same icon when the task is run by Task Scheduler.

    Here's how i created a task in Task Scheduler to execute the .exe:
    • On 'General' tab, under "use the following user account", i select the admin user.
    • I choose "Run whether user is logged in or not".
    • UNcheck "run with highest privileges".
    • "Configure for: Windows 7"
    • Trigger: logon of any user.
    • Actions: my desired .exe.
    • Conditions: nothing checked.
    • Settings: checked on: Allow task to run on demand, Run as soon as possible, and If fails, restart every 1 minute. If running: do not start a new instance.

    This works-- on login, i can see the task running in Task Manager. 

    Problem: i do not see the program's GUI or Notification Area icon. 

    Other Task Scheduler settings i've tried will not start the program. Eg, under "use the following user account", select "Users" or the specific non-admin user for whom the program should run, and pick "Run with highest privileges". Does not work-- the program does not start on logon. 

    How to show the program's GUI and Notification Area icon?

    thx
    Thursday, July 6, 2017 5:37 AM

All replies

  • Hi Johny,

    For showing program’s GUI:

    According to Microsoft Task Security Context (I pasted the key point below).

    “You can specify that a task should run even if the account under which the task is scheduled to run is not logged on when the task is triggered. To do this, select the radio button labeled Run whether user is logged on or not . If this radio button is selected, tasks will not run interactively. To make a task run interactively, select the Run only when user is logged on radio button.”

    So you need to select “Run only when user is logged on” radio button instead of “Run whether user is logged on or not”.

    For missing notification Area icon:

    I found another thread which has the same issue with you. The issue was resolved by setting a slight delay to load the task after logging in Windows. For detailed information, please refer to the Magritte’s answer.

    Best regards,

    Joy.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, July 7, 2017 8:35 AM
  • I applied settings as you recommend, but the task is still not loading interactively. 

    i've done some more experimenting with settings, and here's what i've found:

    • this program must run with admin rights. 
    • therefore, "use the following user account" must be set to the admin user. The program will not run otherwise. For this reason, your recommended settings do not work. 
    • i log into Windows as a non-admin user. 
    • therefore, "run when user is logged on or not" must be selected. The program will not run otherwise. 

    With above settings, the program will run (visible in Task Manager), but not interactive. 

    Needed solution: how Task Scheduler can run ADMIN program for NON-ADMIN LOGIN with interactivity. 

    Any way to achieve that?

    thx

    • Edited by johny w Sunday, July 9, 2017 12:51 AM
    Sunday, July 9, 2017 12:30 AM