locked
Unable to finish sequencing application using APPV 5.1.85.0 RRS feed

  • Question

  • Sequencer error:

    The virtual package could not be saved because an internal error occurred. For details, consult the sequencer event log. Typical reasons for save failures include:
    1) Package size is too large.
    2) Sharing violation - another application is blocking access to a file in the package.

    Insufficient system resources exist to complete the requested service.



    Event Viewer:

    - <Event xmlns="">
    - <System>
      <Provider Name="Microsoft-AppV-Sequencer" Guid="{0D21725F-A0BD-4D1D-AE8E-6910F1093419}" />
      <EventID>5006</EventID>
      <Version>0</Version>
      <Level>2</Level>
      <Task>0</Task>
      <Opcode>0</Opcode>
      <Keywords>0x8000000000000000</Keywords>
      <TimeCreated SystemTime="2017-04-21T02:00:21.157372600Z" />
      <EventRecordID>137</EventRecordID>
      <Correlation />
      <Execution ProcessID="2344" ThreadID="2460" />
      <Channel>Microsoft-AppV-Sequencer/Admin</Channel>
      <Computer>appv-sqr</Computer>
      <Security UserID="S-1-5-21-2090865708-385447861-3696935846-500" />
      </System>
    - <EventData>
      <Data Name="Message">Insufficient system resources exist to complete the requested service.</Data>
      </EventData>
      </Event>


    This problem appears with Oracle Primavera P6 8.3 client only, with another apps or even another versions of this app sequencing goes fine.

    For sequencing i use clean Windows Server 2012R2 on virtual machine.



    Tips from this threads didn't help (sorry cannot add links):

    App-V 5 SP2 - Error when clicking next after capturing changes in sequencer

    Sequencer Error - Unable to save package

    Unable to save sequenced application using APPV 5.0



    Any help would be appreciated.

    Thanks.
    Friday, April 21, 2017 7:34 AM

All replies

  • So you also tried hotfix8 for 5.1 sequencer (v 5.1.118.0)

    Roy Essers

    Friday, April 21, 2017 8:31 AM
  • I've sequenced Oracle Primavera P6 (R8.3.2) Professional myself 2+ years ago, had the same issue as you are having. I tried with AppV Sequencer 5.0 SP3 and 5.1. As I create a "sequencing recipe" for all my sequences, here's the solution (copy/paste from my document):

    When not customizing the package (save directly after sequencing), the error doesn't appear. 

    One little problem: Shotcuts aren’t captured, but I’m able to add them manually and saving the package works!

    For any obscure reason the original package name was ignored. The Sequence gave the name “Reserved” to this package. Fine with me, Gridmetric AVE renamed the package in no time :-)




    Friday, April 21, 2017 2:52 PM
  • FYI, What I've tried (without success) to fix this sequencer crash:

    - Different sequencing machine (same OS and architecture, but another VM)
    - Application prereqs installed locally on the sequencer before sequencing:
    -- DHTML Editing Component
    -- Java JRE 7 Update 45 x64
    - DON’T capture VC++
    - Installed VC++ 8.0.50727.6195 (x86) that the sequencer captured locally.
    - Tried Sequencer 5.0 SP3 and the latest 5.1
    - Providing more resources to the sequencer (tried with 2, 4 and 8GB RAM)
    - The Scratch-folder is located in the default directory appdata\local\temp\Scratch on the C-drive with plenty of free space (30GB).
    - Msiexec is active after installation, kill it msiexec.exe before saving the package
    - Reboot sequencer (in monitoring phase)
    - Sequence %appdata% (remove from exclusions)

    So, try to save the package directly. Without choosing "customize package".


    Friday, April 21, 2017 3:01 PM
  • Hello,

    Try looking for the file that is trying to save by looking at the sequencer log located in event viewer.  Microsoft\AppV\Sequencer\Admin log

    Delete the culprit, then save.

    Hope this helps.

    Sunday, April 23, 2017 8:29 PM
  • New version doesn't help at all, but thanks for your reply.


    Rgds, Timur.

    Monday, April 24, 2017 7:37 AM
  • Thanks for your reply

    I've already tried all these installation combinations too, but i could not sequence package without customization because of the same error.


    Rgds, Timur.

    Monday, April 24, 2017 7:53 AM
  • Thanks for your reply

    Copy of the admin log contains in this post. It just says "Insufficient system resources exist to complete the requested service".


    Rgds, Timur.

    Monday, April 24, 2017 7:59 AM
  • I know this is an old topic, but today I ran into a similar issue while packaging Alteryx R-3.4.4... also resulting in the same error message while preparing for streaming.... If anyone else runs into this issue see steps below to determine if thats causing your error:

    1) start sequencer, install, next next until step before prep for streaming
    2) Start Procmon, and monitor events for Sequencer.exe... Filer for "INSUFFICIENT RESOURCES"
    3) browse to the key which is causing this event (in my case it was HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products\0EDA5878EDA066E4BB6504B20F8D1F72\Features\F36162A63) and use powershell to determine it's length. Data for my key was 580.760 characters long, which it seems causing this issue
    4) Revert snapshot, start sequencer and add the regkey to the exclusionlist (I added REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products), and resequence.

    Because the regkeys are not needed for the app to work I could leave them out of the package.


    Roy Essers

    • Proposed as answer by dataMack Thursday, May 23, 2019 3:49 PM
    Wednesday, March 27, 2019 1:21 PM
  • Thanks Roy - this was super helpful as we were running into issues in packaging Alteryx with R 3.4.4.  Was there anything else you had to do to get it working properly?  Once packaged and then testing from withing Alteryx we get errors where the R paths are not being resolved correctly- almost like the application can't 'see' the R locations.  Works fine on a regular physical PC but in AppV form it doesn't. Appreciate any suggestions you'd have on that part.
    Tuesday, April 9, 2019 2:15 PM
  • For those having issues with Alteryx and R integration, here are my sequencing steps:
    - If you want use Oracle database connections, you'll need to install a Oracle Instant Client. I installed Alterynx, and used the Designer to download the latest version (installed to c:\Alteryx\OracleIC). Copy the install dir to a safe location, and revert your sequencer.
    - There are some regkeys / Folders you need to exclude, I used this exclusion list:
    <?xml version="1.0" encoding="utf-8"?>
    <SequencerTemplate xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <SequencerTemplateVersion>2</SequencerTemplateVersion>
      <ID>e8bf206e-1e33-4fce-8311-cd0c1215ad65</ID>
      <HashOverall>-1751440058</HashOverall>
      <HashSettings>0</HashSettings>
      <HashFileExclusions>1200397174</HashFileExclusions>
      <HashRegExclusions>-1710591880</HashRegExclusions>
      <hashTargetOSes>371857150</hashTargetOSes>
      <AllowMU>false</AllowMU>
      <AppendPackageVersionToFilename>false</AppendPackageVersionToFilename>
      <AllowLocalInteractionToCom>false</AllowLocalInteractionToCom>
      <AllowLocalInteractionToObject>false</AllowLocalInteractionToObject>
      <FullVFSWriteMode>false</FullVFSWriteMode>
      <ExcludePreExistingSxSAndVC>false</ExcludePreExistingSxSAndVC>
      <FileExclusions>
        <!-- Alteryx -->
      	<string>[{Local AppData}]\{4F616785-2372-429A-BB26-ABCFEE9F3144}</string>
      	<string>[{Local AppData}]\{E7BBE5A7-5C99-481F-8829-BD9B0AE4A990}</string>
      	<string>[{Local AppData}]\CEF</string>
        <string>[{Local AppData}]\PIP</string>
        <string>[{Local AppData}]\Microsoft</string>
        <string>[{Local AppData}]\packageAware</string>
        <string>[{AppData}]\SRC</string>
        <string>[{AppData}]\Microsoft</string>
        <string>[{Profile}]</string> 
        <string>[{Common AppData}]\SRC\FlexeraLicenseManager</string>    
        <!-- Alteryx -->    
        <string>[{AppData}]\Microsoft\AppV</string>
        <string>[{AppVPackageDrive}]\$Recycle.Bin</string>
        <string>[{AppVPackageDrive}]\System Volume Information</string>
        <string>[{Cache}]</string>
        <string>[{Common AppData}]\Microsoft\Crypto</string>
        <string>[{Common AppData}]\Microsoft\Microsoft Antimalware</string>
        <string>[{Common AppData}]\Microsoft\Microsoft Security Client</string>
        <string>[{Common AppData}]\Microsoft\Search\Data</string>
        <string>[{Common AppData}]\Microsoft\Windows Defender</string>
        <string>[{Cookies}]</string>
        <string>[{CryptoKeys}]</string>
        <string>[{History}]</string>
        <string>[{Local AppData}]\Temp</string>
        <string>[{LocalAppDataLow}]</string>
        <string>[{Personal}]</string>
        <string>[{Profile}]\Local Settings</string>
        <string>[{Profile}]\NTUSER.DAT.LOG1</string>
        <string>[{Profile}]\NTUSER.DAT.LOG2</string>
        <string>[{ProgramFilesX64}]\Windows Kits\10\Microsoft Application Virtualization\Sequencer</string>
        <string>[{ProgramFiles}]\Microsoft Security Client</string>
        <string>[{ProgramFiles}]\Windows Defender</string>
        <string>[{Recent}]</string>
        <string>[{Windows}]\Debug</string>
        <string>[{Windows}]\Logs\CBS</string>
        <string>[{Windows}]\Temp</string>
        <string>[{Windows}]\WindowsUpdate.log</string>
        <string>[{Windows}]\WinSxS\ManifestCache</string>
      </FileExclusions>
      <RegExclusions>
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft\AppV</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft\Cryptography</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft\Microsoft Antimalware</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft\Microsoft Antimalware Setup</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft\Microsoft Security Client</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Policies\Microsoft\Microsoft Antimalware</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Policies\Microsoft\Windows Defender</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Wow6432Node\Microsoft\AppV</string>
        <string>REGISTRY\MACHINE\SOFTWARE\Wow6432Node\Microsoft\Cryptography</string>
        <!-- Alteryx sequencer fix, because datakeys under following path are extreamly long which can not be handled by the sequencer -->
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft</string>
        <string>REGISTRY\MACHINE\SYSTEM</string>    
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Microsoft\Windows\CurrentVersion\Explorer</string>
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\MimarSinan</string>
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Classes\Local Settings</string>
        <!-- for machine install -->
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\S-1-5-18\Products</string>
        <!-- for user install -->
        <string>REGISTRY\MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Installer\UserData\[{AppVCurrentUserSID}]\Products</string>
        <!-- Alteryx sequencer fix, -->
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Microsoft\AppV</string>
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Microsoft\Windows\CurrentVersion\Explorer\StreamMRU</string>
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Microsoft\Windows\CurrentVersion\Explorer\Streams</string>
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Wow6432Node\Microsoft\AppV</string>
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\StreamMRU</string>
        <string>REGISTRY\USER\[{AppVCurrentUserSID}]\Software\Wow6432Node\Microsoft\Windows\CurrentVersion\Explorer\Streams</string>
      </RegExclusions>
      <TargetOSes />
    </SequencerTemplate>
    - Start sequencer, and use C:\Alteryx as PVAD
    - Install Alteryx to C:\Alteryx, R will be installed to C:\Alteryx\R-3.5.3
    - Add C:\Alteryx\bin\Miniconda3 to the PATH envirnoment variable, otherwise python.exe will not be found.
    - Copy UserSettings.xml to %AppData%\Alteryx\Engine\VERSION, content of this file:
    <?xml version="1.0"?>
    <AlteryxSettings>
      <GloablSettings>
        <SendUsageStats value="False" NoInherit="True" />
        <OracleInstantClientInstallPath NoInherit="False">C:\Alteryx\OracleIC\instantclient_12_1\</OracleInstantClientInstallPath>
      </GloablSettings>
    </AlteryxSettings>
    - Enabel VFS-write
    - R reference is saved under c:\Alteryx\Settings\RPluginSettings.ini. But this reference is not picked up correctly, you need to change it to the physical location, like C:\ProgramData\App-V\DCB88B67-505A-4447-8F6A-62BE628F2A00\342B82DB-E5F2-4C7D-A769-8F92FDE4C9B3\Root\R-3.5.3\. I created a powershell script which runs as soon as the VE starts, which changes these ini-files:
    <UserScripts>     
      <StartVirtualEnvironment  RunInVirtualEnvironment="true">
    	<Path>powershell.exe</Path>
    	<Arguments>-executionpolicy remotesigned -noprofile -command "&amp; {Get-ChildItem -Path 'C:\Alteryx\Settings' -Recurse -Filter *.ini | ForEach-Object{((Get-Content -Path $_.FullName -Raw) -replace 'C:\\Alteryx\\','[{AppVPackageRoot}]\') | Set-Content -Path $_.FullName}}"</Arguments>
    	<Wait RollbackOnError="true"/>
      </StartVirtualEnvironment>
    </UserScripts>
    - You could also consider blocking https://whitelist.alteryx.com/v1/downloads/v1/Version.xml in your filewall to prevent autoupdates warnings.

    If you follow these steps, Alteryx should work fine.

    Roy Essers

    Thursday, October 24, 2019 8:33 AM