Cannot view thumbnails or preview image files over network RRS feed

  • Question

  • Like the title says I see no thumbnails, or anything in the preview pane, for images on any network drive. It works fine on the local machine. I have exhausted all googleable solutions, so far I have tried:

    • Logging in as a different user.
    • Changed the file Explorer option to use thumbs, not icons
    • Changed the local policies for thumbs over the network (and 3 other settings regarding thumbs)
    • Checked that there is no GPO controlling this.
    • Cleared the local thumbs cache
    • Added  [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer]
      "DisableThumbnails"=- and [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\Advanced]
    • Added DisableThumbnailsOnNetworkFolders=0 in "HKEY_CURRENT_USER \ Software \ Microsoft \ Windows \ CurrentVersion \ Policies \ Explorer"
    • Checked the performance options
    • Changed the content type options for the folder to "images"
    • Manually added ShellExt to .jpg under HKEY_CLASSES_ROOT ([HKEY_CLASSES_ROOT\.jpg\ShellEx\{BB2E617C-0920-11d1-9A0B-00C04FC2D6C1}]
    • Installed a third party thumbs handler (sagethumbs), which works nicely with PSD and a few others, but not JPG, BMP, GIF etc. (Which overwrote my manually added ShellExt for .jpg)
    • Installed a third party file Explorer (Explorer++)

    I got the same problem on two machines, one Win7 and one Win10. All other clients works fine in this regard.

    I could easily have re-imaged both with the time I have spent, but I want to avoid that if possible. Any suggestion is appreciated!



    • Edited by freagr Wednesday, September 6, 2017 1:14 PM
    Wednesday, September 6, 2017 12:55 PM


All replies

  • Hi freagr,

    To simply make your pictures show in thumbnail mode simply open your pictures folder, click tools, folder options, view, then uncheck "Always show icons, never thumbnails" and hit apply!

    For no thumbnails for images on network drive issue, we always need to change the GP or check the registry. If you have added the registry, you could check the last two posts in the link below.


    If the issue still insists, I suggest that we could perform a clean boot and disable security software temporarily.


    Then try to use the command “sfc /scannow” for Windows 7 and “DISM /Online /Cleanup-Image /RestoreHealth” for Windows 10 to repair the system file.

    If these steps don’t work, you could do In-Place Upgrade to check.


    Otherwise, I'm afraid your last choice is re-image.

    Hope it will be helpful to you

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by freagr Thursday, September 7, 2017 11:41 AM
    Thursday, September 7, 2017 6:13 AM
  • Thanks Carl!

    I appreciate it. Neither scan did anything for the thumbnails, although SFC was unable to fix all problems on the Win7 machine. DISM didn't find anything to fix (only did /ScanHealth and /CheckHealth). I guess re-imaging is the only sensible option at this point, It bugs me that I won't know what this was though.


    Thursday, September 7, 2017 9:34 AM
  • I discovered that the thumbnail generation is intermittent on network shares unless the network share also happens to be associated with MS OneDrive on the share host, then the icons never show up unless you open the image.

    Win 10 - 1809 Build 17741.1000

    Wednesday, August 22, 2018 1:15 AM
  • Similar Issue.  My resolution was that a key had been created in 


    Not the HKEY_Current_USER hive

    This was set to 1, setting to 0 sorted it.

    • Proposed as answer by Ark VS Monday, February 17, 2020 5:52 AM
    Wednesday, April 10, 2019 9:29 AM
  • Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Policies\Explorer\DisableThumbsDBonNetworkFolders

    Thank you very much.  All along I'm confused whether it was some parameters around LAN connection or WD MyCloud storage.  And I've got no success from neither File Explorer's view options nor this-PC performance settings.  This is one-stop resolution.

    Monday, February 17, 2020 6:09 AM