locked
Error using stsadm -o setproperty RRS feed

  • Question

  • I'm trying to use stsadm to have peoplepicker search trusted forests after upgrading to SP2.

    The command I'm trying to run is:

    stsadm -o setproperty -url http://server:port -pn peoplepicker-searchadforests -pv "forest:contoso.corp.com, contoso\<account>, <Password>;domain:bar.contoso.corp.com, contoso\<account>, <Password>"

    The installation is single server with internal database. There are 4 different zone urls configured in the server. I've used the command successfully on 2 of them (Central administration and the default server), but when I try it on the real production sites I have this error:

    "The server administration programs and the Windows SharePoint Services Web applications on this Web server are not compatible.  Ensure that the administration program is the same version as the Web application."

    I know that this error may be due to url errors, but I'm sure that the url is correct, as I can run different stsadm commands with the same url (stsadm -o enumsites). Also the url is the one that appears with stsadm -o enumzoneurls

    I've also tried to upgrade the site with stsadm -o upgrade, the operation complete successfully, but the error is still there.

    Any advice will be appreciated. 

    Thank you!

    Thursday, March 10, 2011 2:30 PM

All replies

  • Hi,

    That's right this is related to URL

    the URL is with HTTP or HTTPS ?


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Thursday, March 10, 2011 2:53 PM
  • Both, we have a public http site and a private https site, and both of them give the same error.

    As I wrote, the strange thing is that the urls works with other stsadm commands and are taken directly from stsadm -o enumzoneurls.

    The only command that gives error is the setproperty/getproperty. 

    Bye,

    Federico

    Thursday, March 10, 2011 3:06 PM