locked
PPS SP2 installation RRS feed

  • Question

  • Hi All,

      When we try to install the PPS SP2 on the last updated PPS SP1 version , it gives an error saying that "Windows installer failed to install". This happened with PPS SP1 also. So we uninstalled the PPS and then did a fresh installation. Then it worked fine. We followed these steps

    1)Install PPS 2007
    2)Apply the service Pack
    3)Configure the Monitoring server.

     Cant we directly install the Service pack on the PPS that is already installed. Each and every time the patches are released we are uninstalling the older version.

    Please let us know if there are any solutions.

    Thanks.

    Regards,
    Ram.

    Friday, December 19, 2008 8:47 AM

Answers

  •   I have installed SP2 on an existing PPS Monitoring and Analytics server with SP1 installed on it without having any issues.  There are four files (Planning Server, Business Modeler Client, Monitoring (Scorecard) server, and Excel Add-in (for Planning)) that come with the SP2.  All I did for my install was simply run the PSCrv.msp (sorry I had a typo before with msi extension instead of msp) file.  I was on SP1 version 3.0.3916.00 prior to install (dashboard designer version).  Is it possible you had a hotfix installed?  If you look at the SP2 ReadMe file, Monitoring and Analytics SP2 Readme, it does clearly state the following:

    Issue

    Explanation/Workaround

    When you attempt to upgrade to PerformancePoint Server 2007 with SP2 from PerformancePoint Server 2007 3.0.4102.00 or later, you get an error message.

    This occurs even if you have PerformancePoint Server 2007 with SP1 or the prerelease version of PerformancePoint Server 2007 with SP2 installed.

     

    Workaround:   Download and install a PerformancePoint 2007 Planning Server database utility http://go.microsoft.com/?linkid=9640990).

    Note:   You must install this utility to install PerformancePoint Server 2007 SP2, even if you only use the Monitoring applications.


    Plus there is also a section under the System Requirements stating the following on the download page of the SP2:


    IMPORTANT: If you have applied a PerformancePoint Server 2007 hotfix that has the version number of 3.0.3999.1 or later (this includes the SP2 Beta release), the upgrade of the Application Databases may fail when you install PerformancePoint Server 2007 Service Pack 2. To work around this problem, run the AppDBpreSP2Update command script before you install PerformancePoint Server 2007 SP2. For more information and to download the script, please see Microsoft Knowledge Base article kb960815 (http://support.microsoft.com/?kbid=960815).
    Friday, December 19, 2008 12:12 PM

All replies

  •   I have installed SP2 on an existing PPS Monitoring and Analytics server with SP1 installed on it without having any issues.  There are four files (Planning Server, Business Modeler Client, Monitoring (Scorecard) server, and Excel Add-in (for Planning)) that come with the SP2.  All I did for my install was simply run the PSCrv.msp (sorry I had a typo before with msi extension instead of msp) file.  I was on SP1 version 3.0.3916.00 prior to install (dashboard designer version).  Is it possible you had a hotfix installed?  If you look at the SP2 ReadMe file, Monitoring and Analytics SP2 Readme, it does clearly state the following:

    Issue

    Explanation/Workaround

    When you attempt to upgrade to PerformancePoint Server 2007 with SP2 from PerformancePoint Server 2007 3.0.4102.00 or later, you get an error message.

    This occurs even if you have PerformancePoint Server 2007 with SP1 or the prerelease version of PerformancePoint Server 2007 with SP2 installed.

     

    Workaround:   Download and install a PerformancePoint 2007 Planning Server database utility http://go.microsoft.com/?linkid=9640990).

    Note:   You must install this utility to install PerformancePoint Server 2007 SP2, even if you only use the Monitoring applications.


    Plus there is also a section under the System Requirements stating the following on the download page of the SP2:


    IMPORTANT: If you have applied a PerformancePoint Server 2007 hotfix that has the version number of 3.0.3999.1 or later (this includes the SP2 Beta release), the upgrade of the Application Databases may fail when you install PerformancePoint Server 2007 Service Pack 2. To work around this problem, run the AppDBpreSP2Update command script before you install PerformancePoint Server 2007 SP2. For more information and to download the script, please see Microsoft Knowledge Base article kb960815 (http://support.microsoft.com/?kbid=960815).
    Friday, December 19, 2008 12:12 PM
  • Hi Dan,

      Thanks for the reply. We downloaded the SP2 suite from the Microsoft downloads and we got the 4 files. We have PSCSrv.msp file instead of PSCSrv.msi file. All the files which we have downloaded contains .msp extensions. Any idea??

    thanks.

    Regards,
    Ram
    Friday, December 19, 2008 12:51 PM
  • Hi Ram,

    PPS Service Pack install file extension is .msp.   PPS Service packs are cumulative you can install PPS RTM -> SP2.   The error sounds like you are trying to install the wrong bits example: x64 bits on x86 Server

    Thank you,
    Sundar - MSFT
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, December 19, 2008 2:21 PM
  • Hello,

    Either your issue is what Sundar menitoned or you could also be trying to install SP2 on the Evaluation Version of PPS.  You can only apply SP2 on the full released version of PPS.  To check if you are on eval you can go into add/remove programs.

    Thanks,

    Aseem Nayar - MSFT
    This posting is provided "AS IS" with no warranties, and confers no rights
    Friday, December 19, 2008 5:49 PM