none
MDT 8443 & SCCM 1706 Function to Create MDT Boot Disk does not load DaRT 10 on Windows Server 2016 with ADK 1703 RRS feed

  • Question

  • Just seeing if anyone else is running into this.

    Brand new SCCM 1706 installation on Windows Server 2016. ADK is at 1703 (have tried with both patched and unpatched versions of 1703). MDT is 8443. DaRT 10 from MDOP 2015.

    Adding DaRT option to MDT Boot Image works fine from Deployment Workbench (e.g. standalone MDT). DaRT is added and running.

    When attempted to create an MDT Boot Image from the SCCM console however, the DaRT cab file does not appear to install, flashes by very quickly on the progress wizard.

    When I use DISM to open the boot WIM created directly from Deployment Workbench I see the sources\recovery path and files. When I use DISM to open the boot WIM created from the SCCM/MDT Integration option in SCCM, I do not see the sources\recovery path and files.

    This worked in SCCM 1607 on Windows Server 2016 with ADK 1703. Thanks for any feedback or ideas.

    Thursday, September 28, 2017 7:19 PM

All replies

  • Did you find something ?

    I have the Same problem,

    But it's after upgrading from 1607 to 1706, I just thought it was a problem with the WIM Upgrade process at first but I later saw that it does not want to comeback. 

    Anyway if you found anything it would be great.

    Also did you try to inject the cab manually with DISM ?

    I will try to add it manually

    Extrated the files from toolsx64.cab to D:\_Dart\

    got Dartconfig8.dat renamed it dartconfig.dat copied it in D:\_Dart\Windows\System32

    Mount-WindowsImage -ImagePath "D:\_WIM\WinPE.S01005AC.wim" -Path "D:\_Mount" -Index 1 Copy-Item -Path D:\_DaRT\sources -Destination D:\_Mount -Recurse Copy-Item -Path D:\_DaRT\Windows -Destination D:\_Mount -Recurse Copy-Item -Path D:\_DaRT\etfsboot.com -Destination D:\_Mount -Recurse

    Dismount-WindowsImage -Path "D:\_Mount" -Save

    Will see if this works, if it does then Ill do a Premier Ticket to try to fix this with MS

    ***** Just to Confim that manually it works now.

    Il will do a Ticket with Microsoft to check this with them at some point

    • Proposed as answer by Max Boivin Wednesday, October 11, 2017 4:53 PM
    • Unproposed as answer by Max Boivin Wednesday, October 11, 2017 4:53 PM
    • Proposed as answer by Max Boivin Wednesday, October 11, 2017 4:54 PM
    • Edited by Max Boivin Wednesday, October 11, 2017 4:54 PM
    Saturday, October 7, 2017 10:58 PM
  • Hi Max,

    I was having file not found when trying to do add-package with DISM, but it looks like you have a workaround. Do you get the DaRT remote viewer to start on the WinPE automatically after that? If so that sounds like we all should be able to manually add to the MDT created source WIM file after the SCCM console finishes with it.

    I'll run through your steps on our system to confirm. Thanks for the follow-up.

    Wednesday, October 11, 2017 4:58 PM
  • Hi Walter,

    BTW I got it to work Manually,

    Seems a bit Basic but the toolsx64.cab wasnt in C:\Program Files\Microsoft Deployment Toolkit\Templates\Distribution\Tools\x64

    I recreated a new Wim with SCCM/MDT

    To Check I mounted the wim and the recovery options were there.

    https://docs.microsoft.com/en-us/windows/deployment/deploy-windows-sccm/create-a-custom-windows-pe-boot-image-with-configuration-manager

    And yes I have a prestart Command to start Dart as soon as you enter the password in the boot image.

    Aslo Add-package will not work you need to extract the cab file and add it manually, as per the commands I have stated.

    I've based this on the makepe script

    https://winpeguy.wordpress.com/my-scripts/makepe/

    And he is doing the same thing.

    Thursday, October 19, 2017 1:57 AM
  • I'll try this the next time I'm onsite with this client, we took hiatus due to a pending conversion on their end. I'm hoping a fix comes soon - seems like there's a lot of manual steps you're making for something that was practically hands-free in the last build.

    Thanks again for the feedback.

    Friday, October 20, 2017 10:08 PM
  • Like I said maybe simply putting the toolsx64.cab in the right spot might do the Trick in theory thats the original way to make it work. Not sure why there was no need to put it for a while.

    https://docs.microsoft.com/en-us/windows/deployment/deploy-windows-sccm/create-a-custom-windows-pe-boot-image-with-configuration-manager

    Sunday, October 22, 2017 5:32 PM
  • Hi Max,

    I'm onsite with this client and I can confirm that somehow the toolsx64.cab was missing from the \Program Files\Microsoft Deployment Toolkit\Templates\Distribution\Tools\x64 directory. However the problem still persists, in that creating a boot image using MDT/SCCM does not add the DaRT components to the WIM, it acts like it's skipping adding the feature in the wizard, just blows right by it.

    I'll try your manual steps but I hope this functionality is fixed, it's clearly a problem in 1706. Thanks!

    Wednesday, November 1, 2017 3:56 PM
  • Really Weird, 

    I can say I had the problem myself but its now fixed.

    Weird that is didnt get fixed for you client.

    Sunday, November 5, 2017 8:59 PM