none
How to change the date format in Sharepoint 2010 to dd MMM yyyy

    Question

  • Hi,

    I am looking to change the datetime format with in the modified column from mm/dd/yy to dd MMM yyyy. I dont want to create calculated field with dd MMM yyyy format. I want the actual modified column value to be represented as dd MMM yyyy format.

    Thanks for your help in advance.

    regards

    Kalyan

    Friday, June 22, 2012 10:13 AM

All replies

  • try changing the Locale of the site in the regional settings on the Site Settings page. The locale is used to change the way the site displays numbers, dates, and time

    Dirk Van den Berghe

    Friday, June 22, 2012 10:40 AM
  • Hi Dirk

    Thanks for your reply.

    Unfortunately, It does not change date format. I want En-US to be displayed as dd MMM yyyy not mm/dd/yy.

    Thanks & Regards

    Kalyan

    • Proposed as answer by bzeyger Monday, May 06, 2013 9:34 PM
    Friday, June 22, 2012 10:44 AM
  • I'm not really sure what context you asking to change this for but to change your date time settings -

    Go into Site Settings and under 'Central Administration' there is a link to 'Regional Settings'. Click this and you specify the way dates and times are displayed.

    I have done this and mine displays as DD/MM/YYYY like you are asking.

    My locale is current set to English (United Kingdom) and sort order is general. Even if you're not in the United Kingdom, I can only see this way being your solution as US dates are always set as MM/DD/YYYY.


    http://sharepointythings.blogspot.co.uk




    • Edited by kellehbeans Friday, June 22, 2012 1:27 PM added more detail
    Friday, June 22, 2012 1:23 PM
  • Here is the screenshot. These sharepoint dates that I am talking about.  I have different sites within the site collection each site has to have different locale, but the date format should be dd MMM yyyy across all the sites just for the consistency.

    Friday, June 22, 2012 1:55 PM
  • Oh! I see what you mean, so actually having the characters for the month after than actually the number of the month. (Sorry, I thought the MMM was a typing error, it never occurred to me that it may be that way!)

    Now that you have pointed out that, I have no idea. I've just looked around my site and found no way to change this, perhaps there is an application that can help you change this?

    Good luck, and sorry I could not help any further.


    http://sharepointythings.blogspot.co.uk

    Friday, June 22, 2012 2:05 PM