none
OSD failing after 1910 upgrade RRS feed

  • Question

  • After upgrading my SCCM site to 1910, my Windows 10 OS Upgrade task sequences are failing. It completes the Upgrade Operating System step, then hangs at "Working on Updates 100%". It is supposed to restart at this point, and continue the task sequence. I have not been able to find any relevant errors in the log files. This was working fine until the site upgrade. I am upgrading OS from 1803 or 1809 to 1903 or 1909.  They all hang at the same spot.  I was able to roll back an SCCM client to 1906, and the upgrade ran fine.  Is this a bug in the 1910 client?
    Thursday, January 9, 2020 8:24 PM

All replies

  • following this thread as we are experiencing the same issues since upgrading our Config Mgr to 1910. 

    6.5.0
    Friday, January 10, 2020 3:11 AM
  • Hi,

    Thanks for posting in TechNet.

    If possible, please help install the hotfix KB4535819 for Configuration Manager version 1910 to have a try.



    Thanks for your time.

    Best regards,
    Simon 

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, January 10, 2020 8:55 AM
  • We are facing the exact same issue. TS for Windows 10 upgrade to 1903 was created on SCCM 1906 and it worked well. But recently we upgraded SCCM to 1910 and since then the TS is getting in hung state for the devices which has 1910 client updated.

    However the machines with 1906 client it is working fine. Any bug with 1910 client?


    Rohit

    Friday, January 10, 2020 9:23 AM
  • We are also facing excat the same issue after upgrading our SCCM to Version 1910.
    The  hotfix KB4535819 doesn't apply to us, as we are not in the fast ring and our client version already is on version 5.00.8913.1012

    The very same upgrade Task Sequence runs fine with the prvious client version 5.00.8853.1006.

    So we also suspect a bug in the latest client version.

    Please examine this with priority as is has some kind of impact....

    Friday, January 10, 2020 9:40 AM
  • We already have this version installed, We did the SCCM upgrade after the 17th December.

    Still an issue


    Rohit

    Friday, January 10, 2020 10:54 AM
  • Thank you, but we are not using the early update ring, so this hotfix will not apply.
    Friday, January 10, 2020 2:49 PM
  • Please examine this with priority as is has some kind of impact....

    No one monitoring these forums can or will examine this. If you need priority help with this, you need to open a support case with Microsoft customer support services.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Friday, January 10, 2020 3:45 PM
  • I am unable to install this hotfix, as we are not in the early update ring.
    Friday, January 10, 2020 6:19 PM
  • We are in the same boat (see https://social.technet.microsoft.com/Forums/en-US/4c66e602-bc6c-4ce9-89da-d74e2ec277f7/1909-feature-update-woes?forum=configmanagerosd)

    We need to update more than  400 machines with 1709 soon (EOL in 04/20) and cannot do so due to broken Inplace Upgrade in 1910. Please Microsoft. Fix this now!!!

    Saturday, January 11, 2020 10:37 AM
  • Hi,

    Thanks for your reply.

    I will do more research about this issue and if there is any update, I will let you know. Thanks for your understanding.

    Best regards,
    Simon

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Monday, January 13, 2020 8:02 AM
  • We have installed the Hotfix KB4535818 today, then updated the SCCM client on several reference machines.and subsequently started the 1909 inplace upgrade again on serveral machines.

    Unfortunately the Hotfix seems NOT to solve our problem, not being able to install an Inplace Upgrade any more. 

    We are still seeing the dreadful error 0x8000FFFF in smsts.log at the time where tsmbootstrapp should resume the Task Sequence, right after the OS upgrade has completed. Still this does not happen. The entire Task Sequence is stuck at "Waiting for updates ... 100%..." and after a timeout of ca. 30-45 minutes bombs out and shows the login screen. All upgrade steps post the OS upgrade (i.e. language packs) have been skipped and Software Center show that the upgrade has failed with error 0xFFFF(65535).

    Having done lots of inplace upgrades in the past this is really annoying, since it worked great until 1910. 

    Can we have a solution soon for this?

    Monday, January 13, 2020 9:43 PM
  • > Can we have a solution soon for this?

    Have you opened a support case for this? No one here can fix this for you. You need to let Microsoft know directly that this is an issue for you by opening a support case.


    Jason | https://home.configmgrftw.com | @jasonsandys

    Tuesday, January 14, 2020 2:11 AM
  • We have opened a support case with Microsoft today. I will post any findings here as soon as we have some ...
    Tuesday, January 14, 2020 8:30 PM
  • Yes please keep us posted. I'm still in the process of trying to find out who can open support cases in our organization or i would have one open for the exact same issues. 


    Tuesday, January 14, 2020 8:52 PM
  • Hi,

    Thanks for your reply. Looking forward to hearing from you. Thanks for your time.

    Best regards,
    Simon


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 15, 2020 1:53 AM
  • I am also experiencing this issue since upgrading to 1910 slow ring, upgrade completes bug hungs at setupcomplete.cmd at the following line: "Running C:\windows\CCM\\TSMBootstrap.exe to resume task sequence" and it never resumes the task sequence. Bootstrap process has to be killed to get to the logon prompt.

    Gabriel Lopez

    Thursday, January 16, 2020 9:02 PM
  • Hello,

    Same issue :

    1. SCCM version & Client version : 1910
    2. Try to upgrade Windows 10 to 1909 (with Task Sequence) --> The Task Sequence is stuck at "Waiting for updates ... 100%..."

    We opened a Microsoft case, we are waiting for a response... (SCCM support overload...)

    I let you know as soon as I have a solution


    Florent

    Friday, January 17, 2020 6:32 AM
  • After talking to Microsoft support they advised us to first disable 3rd party Antivirus and then to test if the Inplace upgrade from 1709 to 1809 or 1809 to 1909 is any better. They suspected that the "big jump" from 1709 to 1909 is too big (however this has been working in October). 

    Having tested all these different scenarios I can unfortunately only confirm that NONE of this helped at all. It does not matter from or to which OS version I'm trying to upgrade or if 3rd party AV is installed or not. The inplace upgrade does not work at all, no matter what we try. Our support case is still open and I'll keep you up to date on the progress. 

    Seems like a severe SCCM bug to me ...

    Friday, January 17, 2020 2:56 PM
  • I can now prove this is a bug, after many failures I was able to test with a 1906 client on the same machine same environment, same task sequence. I created some exclusions to avoid the client from being upgraded to 1910 and the task sequence finished with no issues. Hopefully Microsoft releases a hotfix soon. :(

    Gabriel Lopez

    Friday, January 17, 2020 9:22 PM
  • Have you opened a support case with Microsoft to show them your issue and proof? If not, honestly, your proof and the work you putting into getting it is pretty much worthless. The only way Microsoft knows about issues is if customers report them through the official support channels.

    Jason | https://home.configmgrftw.com | @jasonsandys

    Friday, January 17, 2020 10:09 PM
  • This is not currently any type of known issue or bug at Microsoft regarding this issue. Applying KB4535819 will not fix the problem since there is no fix in KB4535819 for the issue (since the issue is currently not even known at Microsoft). To get the issue properly investigated and if needed, fixed, please make sure to open a support case with Microsoft. Posting here will not get the issue investigated or fixed.

    Are by any chance any of you swapping out or making any modifications to the SetupComplete.cmd script? If so can you disable swapping out the file/disable modifications/revert to the default SetupComplete.cmd file of 1910 and see if the issue goes away? The SetupComplete.cmd script was changed in 1910 to support the new SetupCompletePause variable in 1910:

    https://docs.microsoft.com/en-us/configmgr/osd/understand/task-sequence-variables?redirectedfrom=MSDN#SetupCompletePause

    If you are making any modifications to the SetupComplete.cmd file or swapping it out with an older version it could lead to issues like what you are seeing. Also take a look at the SetupComplete.log at the root of C:\Windows to see if it gives any indication as to why the issue is occurring.


    Frank Rojas Sr. Support Escalation Engineer | Cloud & Infrastructure Solutions | Microsoft Endpoint Configuration Manager Customer Services & Support | Microsoft Corporation


    Saturday, January 18, 2020 1:09 AM
  • we have never modified setupcomplete.cmd in the past, so this should not be the cause for the error (at least for us) 
    Saturday, January 18, 2020 9:03 AM