none
Datetime wrong in FIM portal RRS feed

  • Question

  • Hello.

    I'm flowing a date "2014-12-31" to the enddate attribute in FIM, iam running it through datetimeformat and when i look at the attribute in database it looks ok, 2014-12-31 00:00:00.

    But... when i look at the date in FIM portal it has changed to an earlier occation, IE "2014-12-30 16:00:00" this is causing rules to fail.

    How can this be fixed, timezone in Sharepoint seems to be ok.

    Wednesday, December 10, 2014 10:49 PM

Answers

  • Hi,

    Verify that the Time Zone in the database, FIM Servers and the below entry in portal have the same time zone

    FIM Portal -> Administration ->Portal Configuration ->Extended Attributes -> Time Zone

    Thanks,

    Venkatesh

    Monday, December 15, 2014 7:29 AM

All replies

  • There is a TimeZone object in the FIM Service that you may want to adjust. Also, make sure that you exported to the FIM Portal/Service in the right datetime format - http://blog.goverco.com/2010/03/exporting-employeestartdate-to-fim-2010.html

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Thursday, December 11, 2014 8:34 AM
  • Hello Soren

    Thanks for answering.

    Where can i find this timezone object, maybe iam overlooking something.

    Yes iam using that datetimeformat function as you describe and i see that the date in Fim Syncronization is correct, but in portal (fim service) its pre-dated/timed due to som timezone difference.


    Thursday, December 11, 2014 8:38 AM
  • You should be able to find the TimeZone property under Portal Configuration (I think). I'm not at my environment, so cant remember exactly.

    Also, make sure that you're feeding FIM Service UTC time, maybe?

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt


    Thursday, December 11, 2014 8:40 AM
  • Hi,

    Verify that the Time Zone in the database, FIM Servers and the below entry in portal have the same time zone

    FIM Portal -> Administration ->Portal Configuration ->Extended Attributes -> Time Zone

    Thanks,

    Venkatesh

    Monday, December 15, 2014 7:29 AM
  • Did you manage to resolve this? Please mark answered if so...

    Regards, Soren Granfeldt
    blog is at http://blog.goverco.com | facebook https://www.facebook.com/TheIdentityManagementExplorer | twitter at https://twitter.com/#!/MrGranfeldt

    Thursday, December 18, 2014 11:53 AM
  • yes it was resolved.
    Sunday, February 1, 2015 3:31 PM
  • May I ask how did you fix that?

    I checked and my timezone setting is one and the same on database server, FIM Service Server and in FIM Portal configuration and I am still getting this date mismatch.

    Tuesday, August 4, 2015 11:09 AM