none
Can Windows 10 shared folders be accessed without prompting for user credentials? RRS feed

  • Question

  • Hi 

       I have a specific requirement that the shared folders be easily accessed without being asked for user credentials. I am trying to access a shared folder present in Windows 10 pro system. It should work just like in Windows 8 system where all the shared folders are list as soon as we enter the ip/system name in address bar. 

       I tried

          1. adding allowInsecureGuestAuth key

          2. adding the shared folder to Administrative tools->local secuirty policy->local policies->security options. 

              then add folder to "Network access: Shares that can be accessed anonymously"

              or "Network security : LAN Manager Authentication level" to "send LM & NTLM responses".

    in both the cases user credentials dialog box is prompted to access the shared folders. Is there a setting that I can access the shared folders from windows 10 to be accessed without being asked for credentials?

    One behavior i have seen is if a client Windows system has same local user & password credentials as in Windows 10 Server,  Samba is able to open the shared folders without being asked for credentials. 

    Thanks & Regards,

    M.Gurudatha.


    Thursday, April 21, 2016 4:38 AM

Answers

  • Well in "Control Panel\Network and Internet\Network and Sharing Centre\Advanced sharing settings" in the "All Networks" section at the bottom is "Turn off password-protected sharing". Select that. Add a share with Everyone on the share permission on the file \ security permissions and that connects without prompting (most of the time). Have you tried that?

    Thursday, April 21, 2016 10:25 PM

All replies

  • Well in "Control Panel\Network and Internet\Network and Sharing Centre\Advanced sharing settings" in the "All Networks" section at the bottom is "Turn off password-protected sharing". Select that. Add a share with Everyone on the share permission on the file \ security permissions and that connects without prompting (most of the time). Have you tried that?

    Thursday, April 21, 2016 10:25 PM
  • Thanks a lot.

       its so naive of me to forget the basic setting before going for advanced settings.

    Regards,

    Gurudatha

    Friday, April 22, 2016 4:48 AM
  • Hi Gurudatha,

    Sometimes we are easy to overlook the most simple and straight method, the suggestion from Mr. Happy is helpful, please mark his reply to close this case.

    We also appreciate your efforts for troubleshooting. Hope your experience will help other community members facing similar problems.

    Best regards



    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, April 22, 2016 5:27 AM
    Moderator
  • Is there a way we can turn this off using the regedit or some powershell command. I am using windows 10 system.

    Friday, April 22, 2016 9:57 AM
  • For some reason, this didn't work for me.

    One can see the other, but not the other way around?
    All settings match

    Monday, June 27, 2016 11:21 PM