locked
SP Session Timeout - IE timing out before set time RRS feed

  • Question

  • SP Session Timeout - IE timing out before set time

     

    I have enabled Session State under - SP Central Admin - Admin MGMT - CFG session state

    Set it for 180 mins

    But it times out at around 15 min.

     

    Tuesday, November 23, 2010 7:16 PM

Answers

  • Hi,

    Thanks to share your post.

    For the issue you have post, is there anything wrong with the intranet? And are you using forms authentication? You may add the 'timeout="<NN>" to the web.config under the forms section.

    Here is a sample of the section.

    <forms loginUrl="/_layouts/login.aspx"
    timeout="2880"
    slidingExpiration="true"
    requireSSL="false"
    enableCrossAppRedirects="false" />

     And some more references:

    Increase the connection time-out setting:
    By default, the IIS connection time-out setting is 120 seconds. To increase the connection time-out setting, follow these steps:
    1. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
    2. Right-click the virtual server that you want to configure, and then click Properties.
    3. Click the Web Site tab. Under Connections, type the number of seconds that you want in the Connection time-out box, and then click OK.


    Add the execution Timeout value {always backup your web.config before editing}:
    1. Use Notepad to open the {default template} Web.config file.
    By default, this file is in the following location:
    Program Files\Common Files\Microsoft Shared\Web server extensions\12\TEMPLATE\LAYOUTS
    2. Add the execution Timeout value that you want. For example, replace the value as follows.
    Existing code
    <location path="upload.aspx">
    <system.web>
    <httpRuntime maxRequestLength="2097151" />
    </system.web>
    </location>
    Replacement code
    <location path="upload.aspx">
    <system.web>
    <httpRuntime executionTimeout="999999" maxRequestLength="2097151" />
    </system.web>
    </location>
    3. After you change the file, click Save on the File menu.
    4. Use Notepad to open the Web application Web.config file. By default, this file is in the following folder:
    Inepter\wwwroot\wss\VirtualDirectories\VirtualDirectoryFolder
    5. Change the following line in the file.
    Existing line
    <httpRuntime maxRequestLength="51200" />
    Replacement line
    <httpRuntime executionTimeout="999999" maxRequestLength="51200" />
    6. After you change the file, click Save on the File menu.
    7. Exit Notepad.

    And the following links as the references:

    http://slightlybehindthecurve.wordpress.com/2008/02/29/how-to-force-timeouts-in-a-sharepoint-intranet-site-when-using-windows-authentication/.

    http://support.microsoft.com/kb/925083.

    Hope this could help!

    Leo

     

    • Marked as answer by Mike Walsh FIN Wednesday, December 8, 2010 6:38 AM
    Wednesday, November 24, 2010 8:15 AM

All replies

  • Hi,

    Check this link.

    http://vspug.com/erickraus/2007/12/09/enable-session-state-in-sharepoint-2007/

    Let me know if it works


    Cheers, Hemendra-MCTS "Yesterday is just a memory,Tomorrow we may never see"
    • Marked as answer by Leoyi Sun Thursday, December 2, 2010 8:41 AM
    • Unmarked as answer by Mike Walsh FIN Wednesday, December 8, 2010 6:38 AM
    Wednesday, November 24, 2010 8:09 AM
    Moderator
  • Hi,

    Thanks to share your post.

    For the issue you have post, is there anything wrong with the intranet? And are you using forms authentication? You may add the 'timeout="<NN>" to the web.config under the forms section.

    Here is a sample of the section.

    <forms loginUrl="/_layouts/login.aspx"
    timeout="2880"
    slidingExpiration="true"
    requireSSL="false"
    enableCrossAppRedirects="false" />

     And some more references:

    Increase the connection time-out setting:
    By default, the IIS connection time-out setting is 120 seconds. To increase the connection time-out setting, follow these steps:
    1. Click Start, point to All Programs, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.
    2. Right-click the virtual server that you want to configure, and then click Properties.
    3. Click the Web Site tab. Under Connections, type the number of seconds that you want in the Connection time-out box, and then click OK.


    Add the execution Timeout value {always backup your web.config before editing}:
    1. Use Notepad to open the {default template} Web.config file.
    By default, this file is in the following location:
    Program Files\Common Files\Microsoft Shared\Web server extensions\12\TEMPLATE\LAYOUTS
    2. Add the execution Timeout value that you want. For example, replace the value as follows.
    Existing code
    <location path="upload.aspx">
    <system.web>
    <httpRuntime maxRequestLength="2097151" />
    </system.web>
    </location>
    Replacement code
    <location path="upload.aspx">
    <system.web>
    <httpRuntime executionTimeout="999999" maxRequestLength="2097151" />
    </system.web>
    </location>
    3. After you change the file, click Save on the File menu.
    4. Use Notepad to open the Web application Web.config file. By default, this file is in the following folder:
    Inepter\wwwroot\wss\VirtualDirectories\VirtualDirectoryFolder
    5. Change the following line in the file.
    Existing line
    <httpRuntime maxRequestLength="51200" />
    Replacement line
    <httpRuntime executionTimeout="999999" maxRequestLength="51200" />
    6. After you change the file, click Save on the File menu.
    7. Exit Notepad.

    And the following links as the references:

    http://slightlybehindthecurve.wordpress.com/2008/02/29/how-to-force-timeouts-in-a-sharepoint-intranet-site-when-using-windows-authentication/.

    http://support.microsoft.com/kb/925083.

    Hope this could help!

    Leo

     

    • Marked as answer by Mike Walsh FIN Wednesday, December 8, 2010 6:38 AM
    Wednesday, November 24, 2010 8:15 AM