none
Windows 10 1803 client backups failing (Media write protected errors)

    Question

  • Hi,

    I am not sure if this is the right forum as the software I'm using is Azure Backup Server but this is DPM 12 under the bonnet so I thought it would be worth asking the question to see if anyone in DPM world has seen it.
    I have recently upgraded the Windows 10 PCs to 1803 and since then the consistency check has been failing with the following error:

    DPM encountered an error while performing an operation for <OneDrive for Business Folder> on PC.domain.com (ID 2033 Details: The media is write protected (0x80070013))

    The error suggests that it can't get access to the file/folders within the OneDrive folder, I thought this might be because these files are being managed by the OneDrive sync engine but I've never had an issue with this in the past.

    I've tried removing protection and re-applying and even excluding these folders but the error persists.

    Thanks

    Rob



    • Edited by RobC_CTL Tuesday, May 15, 2018 5:00 PM
    Tuesday, May 15, 2018 4:50 PM

All replies

  • Hi,

     

    Please try the method below so see if the issue persist:


    1. Go to the disk properties page.
    2. Select the 'Hardware' tab.
    3. In the 'All disk drives' list, select the name of the external device.
    4. Click the 'Properties' button.
    5. Select the 'Policies' tab.
    6. Under 'Write caching and Safe Removal', select 'Optimize for performance'.



    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Tuesday, May 15, 2018 11:26 PM
  • Thanks for the reply, but I believe those instructions relate to external drives, the issue I have is backing up the OS drive, these options aren't available for this drive.

    Thanks

    Rob

    Wednesday, May 16, 2018 8:48 AM
  • Hi,

    I have a similar issue with SC 2012 R2 DPM Client. After upgrading to Windows 10 1803 the backup fails. The client only says "An unexpected error occurred while the job was running.". The log file lists error 998 and status -2147024877 (The media is write protected).

    Reinstalling the agent doesn't help. I've also cleared the USN journal of the protected disk, whereafter the backup succeeds only once.

    Eric

    Friday, May 18, 2018 6:21 AM
  • Good to hear it's not just me, I was starting to wonder as I couldn't find anything while searching the internet.  I've tried most standard troubleshooting now and it still isn't working, not sure what to try next.
    Friday, May 18, 2018 9:01 AM
  • I have the same problem.
    Sunday, May 20, 2018 7:24 AM
  • It looks like it struggles over the OneDrive directory from the volume snapshot. I've tried to exclude the folder from VSS with the FilesNotToSnapshot and FilesNotToBackup registry keys, but that didn't help either. Also, disabling autostart of OneDrive doesn't make a difference.

    Thursday, May 24, 2018 6:03 AM
  • Same issue here, +1 for the OneDrive comments as well but unfortunately it didn't resolve it.

    Another reason why DPM is just a lost cause, time to switch to Veeam I think.

    Friday, May 25, 2018 7:23 AM
  • Hi,

    I suggest you create a case directly to Microsoft about this issue as it appears there's not much knowledge about this.

    RobC_CTL & eforgacs: Which DPM versions and builds are you using?

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Friday, May 25, 2018 7:28 AM
  • DPM 5.0.342.0

    As far as I am aware that is the latest rollup, if not happy to try any available hotfixes.

    Friday, May 25, 2018 7:30 AM
  • There is one newer, 5.0.361.0 -  Update Rollup 5 for SCDPM 2016
    You could try to see if it would solve the issue.

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Friday, May 25, 2018 7:35 AM
  • As I am using Azure Backup Server, this uses DPM 2012 at the core, the last update for this was back in May 2017.  I am assuming that eforgacs is on 2016?
    Friday, May 25, 2018 8:28 AM
  • Yes, 2016.

    For some reason Windows Update was showing up-to-date even though UR5 was not installed. I  have now installed UR5 and unfortunately it made no difference - same error

    An unexpected error occurred while the job was running. (ID 104 Details: The media is write protected (0x80070013))

    Monday, May 28, 2018 12:40 AM
  • Add me to the list.

    Same Error (0x80070013 Write protected media), Same Client (Windows 10 1803) but DPM 2012R2 4.2.1603.0 client ( SCDPM 2012 R2 Rollup Update 14 ).

    Tuesday, May 29, 2018 11:33 AM
  • I suggest you create a case directly to Microsoft about this issue, as this appears to be happening to multiple users and no fix available as of today. Best regards, Leon

    Blog: https://thesystemcenterblog.com  LinkedIn:   

    Tuesday, May 29, 2018 11:35 AM
  • Same error here.  all backups of the OS drive have failed since the upgrade to 1803 happened.  failing on the onedrive folder. Anyone find any info yet?

    Thanks

    Rob

    Thursday, May 31, 2018 1:22 AM
  • Found a workaround, kind of...

    Backups failing after Win 10 upgrade to 1803

    In essence:

    • Disable OneDrives Files On-Demand.
    • Remove leftover reparse points. (Call "fsutil reparsepoint delete ..." recursively from within your OneDrive folder.)

    My two cents:

    • Delete volume snapshots (vssadmin delete shadows /all).

    Not ideal, but at least my back-ups are running again.

    • Proposed as answer by eforgacs Friday, June 29, 2018 8:23 AM
    Friday, June 1, 2018 12:26 PM
  • Just disabling "onedrive files on-demand" seems to have solved it for me.  I didn't see any reparse points.

    Rob

    Friday, June 1, 2018 7:35 PM
  • Disabling OneDrive Files on Demand also solved it for me. No need to delete the reparse points or snapshots.

    Thanks for the tip Eric.

    Monday, June 4, 2018 1:26 AM
  • I have this same issue in my network.

    Disabling Files on Demand appears to have solved the problem for my machine, but all other 1803 machines are still having the 'Write Protected' error coming up.

    I've excluded the onedrive folders entirely from the backup, and this is still happening with brand new clients that I'm building, so I don't think it's going to be a reparse issue.

    Tuesday, June 26, 2018 3:44 AM
  • I am having the same issue with a couple of my machines, it seems to be only the machines where the user has signed into OneDrive, this may be a coincidence or the cause I am not quite sure yet.

    One was resolved by uninstalling OneDrive but the other I'm still struggling with.

    If I get no joy soon its going to have to be a ticket with the DPM team.

    Thursday, June 28, 2018 8:23 AM
  • So after some playing around the quickest solution I found was to

    * Remove the Windows 10 1803 client from the protection group but keep the data.

    * Uninstall the DPM client from the Windows 10 1803 machine using the DPM console.

    * Reboot the machine.

    * Re-install the DPM client using the DPM console.

    * Add the machine back into the protection group.

    * Reboot the machine

    * Run a consistency check followed by a short term backup using the after sync option.

    So far this has worked on the machine I mentioned in a previous post ^ and is now in progress on another that had the issue this morning :( 

    Not sure if this is the best solution but it works for me and is one less thing to worry about.

    • Proposed as answer by MrPoole Friday, June 29, 2018 8:22 AM
    Friday, June 29, 2018 8:22 AM
  • Be sure to check that synchronization still works after modifying some files in the OneDrive folder... For me, re-installing the client did help only for one sync run. (But I didn't follow all steps you did.)
    Friday, June 29, 2018 8:37 AM
  • I have this same issue in my network.

    Disabling Files on Demand appears to have solved the problem for my machine, but all other 1803 machines are still having the 'Write Protected' error coming up.

    I've excluded the onedrive folders entirely from the backup, and this is still happening with brand new clients that I'm building, so I don't think it's going to be a reparse issue.


    Please note that excluding the OneDrive folder doesn't help. The problem seems to be with VSS, the snapshot still will have the OneDrive folder included, with some files that aren't accessible.
    Friday, June 29, 2018 8:43 AM
  • Eric

    I will check this, however onedrive isn't used on all of them which brings another level of complexity to the table as it was exactly the same issue. 

    The last one I did this morning didnt use OneDrive and I didnt uninstall OneDrive either yet removing the DPM client and installing it again worked.

    I will keep my eyes on it and get one of the other users in install OneDrive again to see if this then breaks it again.

    Friday, June 29, 2018 1:01 PM
  • I have the same problem as well. Just started after upgrading several PC's to 1803.

    daves

    Thursday, August 9, 2018 10:28 PM
  • Same fix for me. disabling "onedrive files on-demand"

    Thank You! :-)


    • Edited by gwj3 Monday, October 8, 2018 2:04 AM
    Monday, October 8, 2018 2:04 AM
    • Disable OneDrives Files On-Demand.

    WORKED FOR ME!

    MSI GT75 Titan 8RF, W10 1809 v17763.55

    Tuesday, October 16, 2018 11:33 AM
  • Thanks so much for sharing this workaround. I thought I was going crazy, as I had just completed a few backups on an earlier version of Windows 10 with the same hardware. So yes, this did work for me, but I am still thinking of now getting a 3rd party back-up, as even when working correctly, the Windows 7, Windows 10 back ups can be a bit tricky.
    Friday, November 23, 2018 8:51 PM
  • I have this case, CASE ID: 118101719238251, opened with Microsoft,  and they do not have any fix due to the following reasons.

    Disabling OneDrive Files On-Demand did not help so they eventually blamed OneDrive reparse points. 

    Even when we take backup of some folders in the C drive , the VSS writer takes the snapshot of the whole volume and during that if it encounter any file which is being in ownership of any other program  (one drive ) which DPM cannot access to it will fail with the above error 


    Regarding Microsoft official Publication , we do not have specific documentation related to one drive , but officially it is not recommended to have any other backup solutions with DPM and One Drive Partially act as a Backup solution.

    Also we have shared the below articles which states that DPM doesn’t support Reparse points Data Type Backup 

    https://docs.microsoft.com/en-us/system-center/dpm/dpm-support-issues?view=sc-dpm-1807
    https://docs.microsoft.com/en-us/previous-versions/system-center/data-protection-manager-2010/ff399413(v=technet.10)

    Is this correct? DPM cannot work with OneDrive because of reparse points?


    acoloma


    • Edited by Ariel Coloma Monday, December 17, 2018 2:03 PM additional comment
    Monday, December 17, 2018 2:00 PM
  • In my case it was corrupted file, after check disk on c:\ and reboot the backup completed successful. 
    Thursday, January 17, 2019 10:00 AM
  • Yes, disabling OneDrives Files On-Demand did it for me! Thanks very much!
    Sunday, February 17, 2019 10:07 AM
  • I'll tell you what did it for me... I bought a new SSD and performed a migration so that I can boot off the SSD.  All of my backup issues being write protected and all that have disappeared.  Seems that everyone is looking at the destination drive as being at issue for the backup and why wouldn't you, Windows is telling you that the drive is write protected.  I think that the drive to look at is the source drive.  I'm now able to run backups without fail.  I'm running Build 18342.19h1_release.190215-1528.  Seems that I had an issue with OneDrive and it was very close to when this problem started.  I did everything that I could possibly do to OneDrive.. I even deleted it and still no fix.  I'll have to do a bit of memory recall.. have patience...  Fredde

    Sunday, March 3, 2019 1:18 PM
  • Very disappointing that Microsoft has not yet addressed this issue.  This is almost a year now since the OP, and this is not the first time they have had a similar issue with Windows Backup.  A system backup really should not be so complicated to execute!

    My last successful backup ran in January, and now all I get is the "Media is write protected" useless error message on a weekly basis.  It would be nice if it at least told us where the log file is so we could comb through it to find out WHAT is write protected!  I have also tried disabling write caching in OneDrive, and even removing ALL user libraries from my backup settings, but I am still unable to get Windows Backup to work successfully again.

    But I do agree with the other poster comments that this is likely an issue with source content being write-protected (or inaccessible), and not necessarily the target device.

    So it looks like this is going to require a dedicated incident with Microsoft.  Since this is core functionality related to security, let's see if I can get them to provide support on this issue without charge.  I'll try to post back here if I get anything useful out of it.

    Monday, March 11, 2019 5:50 AM
  • Hello everyone,

    We have the same problem on a lot of computers. Two months ago we opened a ticket at Microsoft but for now they have no solution. To try to make things happen, I invite you to vote for this proposal on UserVoice: https://feedback.azure.com/forums/914488-system-center-data-protection-manager/suggestions/37577290-fix-onedrive-files-on-demand-bug

    Best regards.

    Wednesday, May 8, 2019 6:56 AM
  • Hello everyone,

    Here is a workaround I found that seems to work on DPM 2019 (to test).
    If you have this problem and you want to leave the "Files On-Demand" option enabled, and ensure that your computers are backed up, do the following:
    At the protection group level, exclude folders used by OneDrive.
    In our case we excluded
    User Profiles\OneDrive => used by OneDrive
    User Profiles\OneDrive - CompanyName => used by OneDrive for Business
    User Profiles\CompanyName => used to sync SharePoint Online Library
    This operation is not sufficient to solve the problem.
    You must remove the problematic computer from the protection group (delete all backups and replica), then you must put it back in the protection group.
    I applied this solution on a computer and in recent days the backup is working properly, and the option Files On-Demand is still enabled on the computer.

    If you have feedback, do not hesitate to share them.

    Best regards.

    Monday, May 13, 2019 1:42 PM