locked
Cannot change list permission on lists with items > 5.000 RRS feed

  • Question

  • Hi,

    i have a large list with > 5.000 listitems. List ViewThreshold ist set to 5.000. When i want to change the list permissons, i get the following error.

    The attempted operation is prohibited because it exceeds the list view threshold enforced by the administrator.

    I am not able to change the lvt. Is this by design? Isnt there a way to do this? I mean when i would have many large lists and i am not able to change the list permission, sharepoint would be not usable for my purpose.


    Best regards,
    Yavuz B.

    My Sharepoint and Enterprise 2.0 Blog http://www.bogazci.com | Microsoft Sharepoint Resources & Blog List

    Wednesday, May 7, 2014 12:28 PM

Answers

  • This is by design, changing the security principal in use requires returning all items in the list, breaching the threshold.

    You can do several things: Reduce the number of items in the list so that it is below the threshold. Set that list so that it is not affected by the threshold or finally you can increase the web application threshold.

    I lean towards the second option, disable the list threshold and make your change, then re-enable the threshold again. You can do this through PowerShell by setting the EnableThrottling parameter on the splist object. 

    • Marked as answer by [Yavuz B.] Wednesday, May 7, 2014 5:04 PM
    Wednesday, May 7, 2014 3:28 PM
  • A useful tip from my experience is to edit the default view to a small time window.  Within the view, filter on the current date minus three months or something similar and it'll hide the bulk of the older entries.  This is also dependant on how fast you're adding items to these lists.

    You might consider setting up a time window for large queries to be made, which will also the configuration changes.

    Large query windows


    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Blog: baron72.wordpress.com
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    • Marked as answer by [Yavuz B.] Wednesday, May 7, 2014 5:04 PM
    Wednesday, May 7, 2014 4:26 PM
    Answerer

All replies

  • This is by design, changing the security principal in use requires returning all items in the list, breaching the threshold.

    You can do several things: Reduce the number of items in the list so that it is below the threshold. Set that list so that it is not affected by the threshold or finally you can increase the web application threshold.

    I lean towards the second option, disable the list threshold and make your change, then re-enable the threshold again. You can do this through PowerShell by setting the EnableThrottling parameter on the splist object. 

    • Marked as answer by [Yavuz B.] Wednesday, May 7, 2014 5:04 PM
    Wednesday, May 7, 2014 3:28 PM
  • A useful tip from my experience is to edit the default view to a small time window.  Within the view, filter on the current date minus three months or something similar and it'll hide the bulk of the older entries.  This is also dependant on how fast you're adding items to these lists.

    You might consider setting up a time window for large queries to be made, which will also the configuration changes.

    Large query windows


    Steven Andrews
    SharePoint Business Analyst: LiveNation Entertainment
    Blog: baron72.wordpress.com
    Twitter: Follow @backpackerd00d
    My Wiki Articles: CodePlex Corner Series
    Please remember to mark your question as "answered" if this solves (or helps) your problem.

    • Marked as answer by [Yavuz B.] Wednesday, May 7, 2014 5:04 PM
    Wednesday, May 7, 2014 4:26 PM
    Answerer