locked
Windows 2012 RDS Collection published app configuration RRS feed

  • Question

  • We have a Windows 2012 RDS collection - 1 connection broker, 2 session hosts.

    I have published an application and able to access it from RD WEB without a problem. 

    There are two issues:

    1. When I click on the app from the RE WEB page, I see a RDP file being downloaded and I need to open it to access the app.  How do I make it so that user can just click on the app and open?

    2. After the app is opened, I check the drives that the app can access by clicking FILE>OPEN.  I see the C drive of the web server is available to the users.  How do I hide it?

    Thanks,
    Wednesday, August 3, 2016 3:46 PM

Answers

All replies

  • Hi,

    1. When I click on the app from the RE WEB page, I see a RDP file being downloaded and I need to open it to access the app.  How do I make it so that user can just click on the app and open?

    If you are using a third party browser, that's the expected behavior.

    2. After the app is opened, I check the drives that the app can access by clicking FILE>OPEN.  I see the C drive of the web server is available to the users.  How do I hide it?

    You may use Group Policy setting to achieve the goal.

    Detailed steps can be found within articles below:

    Terminal Server (RDS) Lockdown - 2003, 2008, and R2
    http://social.technet.microsoft.com/wiki/contents/articles/5800.terminal-server-rds-lockdown-2003-2008-and-r2.aspx

    Securing RDS in Windows Server 2012
    http://social.technet.microsoft.com/wiki/contents/articles/15255.securing-rds-in-windows-server-2012.aspx

    Best Regards,
    Amy


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by TP []MVP Thursday, August 4, 2016 4:01 PM
    • Marked as answer by Amy Wang_ Monday, August 15, 2016 2:06 AM
    Thursday, August 4, 2016 11:00 AM
  • Hi, 

    You have answer my second question. 

    Would you advise the first question?

    Thursday, August 4, 2016 3:08 PM
  • Hi,

    If you are using IE, please enable RDS add-in to avoid the download option.

    Best Regards,

    Amy


    Please remember to mark the replies as an answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Friday, August 5, 2016 12:53 PM