locked
“Windows cannot access the specified device, path, or file, you may not have appropriate permission to access the item” Why? RRS feed

  • Question

  • Whenever i try to access any folder on my computer(Windows 7), it tells me "Windows cannot access the specified device, path, or file, you may not have appropriate permission to access the item", this happens even for My Computer and Control Panel. It's driving me nuts! I'll be honest here, I was trying to uninstall Visual Studio 2013 Communityfrom my computer by going to Programs and Features but for some reason, it was getting stuck at "Configuring Your System". After trying it numerous times, I went to the visual studio installation directory, and removed the installation files from there. I even removed the files from the C:\Program Data folder, then i went back to Programs and Features and tried to remove the listing there, but I got a dialog box saying "you don't have sufficient access to uninstall visual studio" . I googled this problem and found this  solution (http://superuser.com/a/174198)

     then i tried using the solution, I used SubinAcl and changed the registry permissions as mentioned in the solution and ended up like this!

    All the access permissions are set correctly (that's what I can make out...)

    Please Help!

    Wednesday, February 25, 2015 1:20 PM

All replies

  • Hi

    Some required information are needed for us to help you.

    Hi NabeelOmer,

    We wonder if you have taken any action such as system restore after this issue occurred.

    You might also try this command to restore your access control list.

    Run this command to navigate to the drive letter, example is D

    D:

    To reset all permissions, run this command

    icacls * /reset /t /c /q

    Visual Studio is a very invasive program and which provides the ability to enumerate projects and solutions for system, user should never try uninstalling it manually without any guidance.

    Visual Studio made changes for your whole system, if the file has been moved or deleted this error would occur.

    Since you mentioned that you get this error almost everywhere even in control panel. We suggest you repair/reinstall your Visual Studio first and check if it could be fixed.

    How to: Repair Visual Studio

    https://msdn.microsoft.com/en-us/library/aa983433%28v=vs.90%29.aspx?f=255&MSPPError=-2147217396

    Regards

    D. Wu

    Monday, March 2, 2015 1:23 AM
  • Hi Deason,

    I cannot use icacls, all the files say access denied even in safe mode. Also, I cannot repair visual studio because of the file access permissions issue.

    Could you tell me any other solution.

    Nabeel Omer

    Monday, March 2, 2015 10:08 AM
  • Hi NabeelOmer,

    If you could not restore your access control list by using command or repair/reinstall visual studio, I am afraid that it’s bad news.

    You could try fixing it manually by referring to event log and changing permission of folders/files which shows access denied. However, since it might be hundreds even more. If you have a system image backup, I think it’s the time to use it.

    Regards

    D. Wu


    • Edited by Deason Wu Thursday, March 5, 2015 7:11 AM
    Thursday, March 5, 2015 2:29 AM