"Access Is Denied" in Windows Explorer when trying to read contents of External USB Backup disk


  • I would like to view the contents of a backup disk connected to my SBS 2011 server.  Backups are completing successfully and I want to use cloud based backup to store the backup files in the cloud.

    I've opened Disk Management and assigned a drive letter (K:) to my backup disk "Backup Disk 1".  When i try to view the contents in Windows Explorer I get "K:/ is not accessible... Access is denied".

    I am able to view the properties of the disk in Disk Managment and I am able to view the directory structure of the K: drive using an elevated command prompt (i.e. k:, cd\windowsimagebackup, etc.). It's just Windows Explorer where I am having the problem.

    I have checked the permissions and ownership of the and the Domain Admin has full control (Im logged on as a domain administrator).  When I try to change ownership, it errors again with "Access is Denied".

    I've been able to do this on other SBS 2011 systems.  It's this system that is giving me the problem. 

    Any ideas or things I might try? 



    Wednesday, January 23, 2013 8:11 PM


All replies

  • Have you tries takeown (
    Wednesday, January 23, 2013 10:26 PM
  • Hi,

    Regarding the current issue, I suggest we could refer to the following similar threads. They may be useful to us.

    access to external hard drive suddenly denied by windows 7

    Access denied to external Hard Drive on Windows 7?

    Best Regards,

    Andy Qi

    TechNet Subscriber Support

    If you are TechNet Subscription user and have any feedback on our support quality, please send your feedback here.

    Andy Qi
    TechNet Community Support

    Thursday, January 24, 2013 7:46 AM
  • Yes, I ran the command line tool as follows; takeown /f k:\*.* /r.  The reponse was "success" for all the directories.  However, when I try to access the K: drive in Windows Explorer I still get the Access Is Denied message.
    Thursday, January 24, 2013 8:30 PM
  • I've tried takeown both using Windows Explorer and at a Command prompt and still get the access denied message in WINDOWS EXPLORER.   I can transverse the directory and drives from a command prompt just fine.  These articles are nothing more than "hey try this", "hey try that".  Further, one of the articles suggests starting the computer in safe mode.  As mentioned in my initial post, this is a PRODUCTION SBS 2011 server and cannot be started in safe mode whenever I feel like it. 

    I'm disappointed that this is all Microsoft suggests. I would expect much more from a company that claims to be world-class.  I would suggest letting someone who knows about Windows Server 2008 R2 and NTFS security settings answer as they may be more qualified to provide an answer instead of just suggesting reading more forum posts. 

    If no one has an answer, I'll open a support ticket with Microsoft PSS.  I don't have the time to read or "try" different things suggested in other forum posts.

    Thursday, January 24, 2013 8:43 PM
  • Andy,

    Do you have any other recommendations?  Do you know how I might escalate this to a support engineer who is familar with this issue and and provide some troubleshooting steps?  I don't want to read through a bunch of blog posts of other people's troubleshooting.

    Monday, January 28, 2013 9:00 PM
  • I fixed this problem by setting User Account Control to "never notify". 
    Friday, February 01, 2013 4:07 AM
  • Quick & dirty solution: Set permissions to 'Everyone' - full access - did the trick for me at least.

    Wednesday, March 02, 2016 12:00 PM