locked
Networking Windows 7 and Windows XP RRS feed

  • Question

  • Situation:  I have a wired home LAN that connects two PCs running XP and a third running Windows 7 RC.  The Windows 7 machine is using AVG for security, which is set to 'home network' for the firewall.  The Windows 7 machine is a member of the 'MSHOME' workgroup with the XP machines.  Both drives on the Windows 7 machine are set to be shared.

    Problem:  From the Windows 7 machine, both the XP machines can be accessed.  But on the XP machines, while the shared drives on the Windows 7 PC show up under 'My Network Places' attempts to access them yields the 'You might not have permission to use this resource.'

    I know that somewhere among the menus and sub-menus in Windows 7 there is a way to grant this permission.  But poke and prod as I might, I have not been able to locate it.  Any help and hints would be greatly appreciated!
    Saturday, May 23, 2009 1:46 PM

Answers

  • Select a folder you want to share on the Win7 machine. Right-click, select Share with, Specific people. Click the down arrow to open the drop-down list, select Everyone, click Add. Change permissions if you want. Click share. The folder should now be shared, just as from an XP box. I don't think you can share entire drives using Simple file sharing under Windows. I presume you already have set up the Win7 machine with Printer and file sharing permitted. In my case, the above worked fine, but first after a couple of reboots, and a night's sleep. Don't know why.
    • Marked as answer by axfelix Saturday, May 23, 2009 8:22 PM
    Saturday, May 23, 2009 5:46 PM

All replies

  • Select a folder you want to share on the Win7 machine. Right-click, select Share with, Specific people. Click the down arrow to open the drop-down list, select Everyone, click Add. Change permissions if you want. Click share. The folder should now be shared, just as from an XP box. I don't think you can share entire drives using Simple file sharing under Windows. I presume you already have set up the Win7 machine with Printer and file sharing permitted. In my case, the above worked fine, but first after a couple of reboots, and a night's sleep. Don't know why.
    • Marked as answer by axfelix Saturday, May 23, 2009 8:22 PM
    Saturday, May 23, 2009 5:46 PM
  • Thank you - that does work.  I mistakenly thought whole drives could be shared.  I am rather disappointed that they cannot be shared.  I suppose a work-around for that would be to put all the folders on a drive under one main folder, and share that folder.
    • Proposed as answer by erendofe Sunday, May 24, 2009 12:37 AM
    Saturday, May 23, 2009 7:09 PM
  • ok windows vista and win7  use a password level sharing that is tied to the user account by default. in the advanced sharing setting you can turn off password protected sharing  BUT  if you do  windows will automaticallu give full access shareing to the  "USERS" folder.  I think personally this is going to be a serious vulnerability in the future.  At any rate  just go in and un-share the folder and set up the folder(s) you want to share.  the handling of file sharing in win 7 has gone verry  NT-ish  just a heads up
    Sunday, May 24, 2009 12:41 AM