none
Migrating 2007 to 2010 Provisioning fails RRS feed

  • Question

  • I'm trying to migrate a Project Server instance from 2007 to 2010. The project server migration SQL Server Script does not give any issues from the output. Executing the stsadm -o addcontentdb command completes successfully with errors (These are manually written due to client remote software):

    V2VFeatureActivation2UpgradeSiteAction.Upgrade Attempted to perform an unauthorized operation at Microsoft.SharePoint.SPSecurableObject.CheckPermissions(SPBasePermissions permissionMask)
    Template MPS#0: SPWeb ID=7a12aeae-f196-4e3a-8b35-1b9a57e11059 could not be access in SPSite ID=67c3cf0a-3eb0-4b3b-9db4-fe36bd6f7edf due to exception. Skipping this spweb for template upgrade. Exception: System.UnauthorizedAccessException: Access is denied

    The problem that I'm having is Provisioning the Project Web Access Site--Always fails. Some ULS points to workflow lookuptables, and invalid workflow phase or custom field UID? Other ULS logs point to "The enterprise project type sample proposal references a Project Detail Page that was not found in the SharePoint configuration database"

    I've followed the Project Server migration path from 2007 to 2010 perfectly. I'm not sure what I'm missing.

    Added install account as DBO to the Draft/Published/Archive/Reporting databases
    Added install account as DBO to the content database
    Added install account as site collection admin after mounting
    Changing "PWAURL" and "MSPWAPROJUID" property to NULL according to this article
    I used to have it at least load to the front page, but default.aspx does not load. I can get to the /_layouts/settings.aspx, but provisioning in Project Service Application will always fail. Any ideas?

    Tuesday, December 9, 2014 10:36 PM

Answers

  • I ended up reinstalling SharePoint, but instead of using the AutoSPInstaller, I ended up installing it vanilla with no service applications and completely bare site, then installing service applications after that.
    • Marked as answer by mcantin Wednesday, April 20, 2016 5:05 PM
    Wednesday, April 20, 2016 5:05 PM

All replies

  • For the error:

    V2VFeatureActivation2UpgradeSiteAction.Upgrade Attempted to perform an unauthorized operation at Microsoft.SharePoint.SPSecurableObject.CheckPermissions(SPBasePermissions permissionMask)
    Template MPS#0: SPWeb ID=7a12aeae-f196-4e3a-8b35-1b9a57e11059 could not be access in SPSite ID=67c3cf0a-3eb0-4b3b-9db4-fe36bd6f7edf due to exception. Skipping this spweb for template upgrade. Exception: System.UnauthorizedAccessException: Access is denied

    Can you run the following query on the Content DB

    Select FullURL from Webs where siteid = '7a12aeae-f196-4e3a-8b35-1b9a57e11059'

    This query will return the site name for which the upgrade is failing. Please try to browse the site in 2007.

    In case the site opens up in 2007 check whether the account with which we are upgrading the db has the necessary permissions on the site else if the site is not opening and throws an error then we will have to either fix the issue in the site and then upgrade or delete the site if its not being used.

    For the issue observed with the provisioning of PWA site collection. Can you share the event viewer entries observed on the server where the project services are running.



    Cheers! Happy troubleshooting !!! Dinesh S. Rai - MSFT Enterprise Project Management Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you. This can be beneficial to other community members reading the thread.

    Wednesday, December 10, 2014 9:08 PM
    Moderator
  • The query did come back with a site, the query I used was ID = <guid> instead of SiteID = <guid>

    Event Viewer:

    Level Date and Time Source Event ID Task Category

    Error 12/10/2014 2:14:12 PM Microsoft-SharePoint Products-Project Server 6971 Provisioning "Failed to provision site PWA with error: Microsoft.Office.Project.Server.Administration.ProvisionException: Post provisioning setup failed. at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.CreateSite(ProjectProvisionSettings provset)"

    Error 12/10/2014 2:14:12 PM Microsoft-SharePoint Products-Project Server 6966 Provisioning "Provisioning 'PWA': Post provisioning setup failed. Exception 'Microsoft.Office.Project.Server.Administration.ProvisionException: Post provisioning setup failed. at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.CreateSite(ProjectProvisionSettings provset)'."

    Error 12/10/2014 2:14:05 PM Microsoft-SharePoint Products-Project Server 7381 Provisioning ProjectSite post provision setup completed with errors

    Warning 12/10/2014 2:12:41 PM Microsoft-SharePoint Products-Project Server 8101 Provisioning Reusing http://projectserverFQDN/PWA site for provisioning PWA

    ULS Logs (deleting many logs for brevity):

    12/10/2014 14:14:05.71 OWSTIMER.EXE (0x0C3C) 0x0B98 Project Server Provisioning g1or High PWA:http://projectserverFQDN/PWA, ServiceApp:Project Server Service Application, User:i:0#.w|domain\adminaccount, PSI: The Enterprise Project Type Sample Proposal references a Project Detail Page (Name = Project Information, Unique Id = e8ba8b5c-7eb8-45d0-bbbe-50edabcbb826) that was not found in the SharePoint configuration database. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:05.71 OWSTIMER.EXE (0x0C3C) 0x0B98 Project Server Provisioning 7381 Critical ProjectSite post provision setup completed with errors 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.22 OWSTIMER.EXE (0x0C3C) 0x0B98 Project Server Provisioning 6966 Critical Provisioning 'PWA': Post provisioning setup failed. Exception 'Microsoft.Office.Project.Server.Administration.ProvisionException: Post provisioning setup failed. at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.CreateSite(ProjectProvisionSettings provset)'. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.22 OWSTIMER.EXE (0x0C3C) 0x0B98 Project Server Provisioning 7073 Information Removing ProjectSite object for 'SharePoint - PWA:PWA'. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.25 OWSTIMER.EXE (0x0C3C) 0x0B98 SharePoint Foundation Topology 8dyx High Deleting the SPPersistedObject, JobScheduler Name=PwaJobScheduler_SharePoint - PWA:PWA. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.28 OWSTIMER.EXE (0x0C3C) 0x0B98 SharePoint Foundation Topology 8dyx High Deleting the SPPersistedObject, ProjectSite Name=67c3cf0a-3eb0-4b3b-9db4-fe36bd6f7edf. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.30 OWSTIMER.EXE (0x0C3C) 0x0B98 SharePoint Foundation Topology 8dyx High Deleting the SPPersistedObject, ProjectDatabase Name=ProjectServer_Published. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.32 OWSTIMER.EXE (0x0C3C) 0x0B98 SharePoint Foundation Topology 8dyx High Deleting the SPPersistedObject, ProjectDatabase Name=ProjectServer_Archive. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.35 OWSTIMER.EXE (0x0C3C) 0x0B98 SharePoint Foundation Topology 8dyx High Deleting the SPPersistedObject, ProjectDatabase Name=ProjectServer_Draft. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.36 OWSTIMER.EXE (0x0C3C) 0x0B98 SharePoint Foundation Topology 8dyx High Deleting the SPPersistedObject, ProjectDatabase Name=ProjectServer_Reporting. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.39 OWSTIMER.EXE (0x0C3C) 0x0B98 Project Server Provisioning 7074 Information Finished removing ProjectSite object for 'SharePoint - PWA:PWA'. 6354ef50-d726-47eb-8d27-8710fa397279

    12/10/2014 14:14:12.39 OWSTIMER.EXE (0x0C3C) 0x0B98 Project Server Provisioning 6971 Critical Failed to provision site PWA with error: Microsoft.Office.Project.Server.Administration.ProvisionException: Post provisioning setup failed. at Microsoft.Office.Project.Server.Administration.PsiServiceApplication.CreateSite(ProjectProvisionSettings provset) 6354ef50-d726-47eb-8d27-8710fa397279

    • Edited by mcantin Wednesday, December 10, 2014 10:29 PM
    Wednesday, December 10, 2014 10:26 PM
  • I also tried to completely delete the site in question and the provisioning still failed. I tried to start a new project site with a new database and 4 new publishing/archive/reporting/draft databases, and that worked, but that is from scratch, and I want to upgrade the 2007 project server data. I noticed that it may be due to this error:

    The Enterprise Project Type Sample Proposal references a Project Detail Page id= e8ba8b5c-7eb8-45d0-bbbe-50edabcbb826

    What does this mean?


    • Edited by mcantin Monday, December 15, 2014 3:42 PM
    Monday, December 15, 2014 3:42 PM
  • Hi,

    Have you manage to get it fixed, i am having the same problem, please help

    BR

    Kaashifsaeedpk@gmail.com


    Kashif Saeed

    Thursday, January 29, 2015 11:55 AM
  • I ended up reinstalling SharePoint, but instead of using the AutoSPInstaller, I ended up installing it vanilla with no service applications and completely bare site, then installing service applications after that.
    • Marked as answer by mcantin Wednesday, April 20, 2016 5:05 PM
    Wednesday, April 20, 2016 5:05 PM