locked
Outlook 2016 bug - icon not displayed in search results RRS feed

  • Question

  • Notice this annoying bug today- 

    When you perform a search in outlook, the results are displayed without the icon that shows if you have replied to or forwarded the message. This is true for both with and without a message viewing pane. By the way in the viewing pane, you can see if the message was replied to or forwarded, but it does not make sense to preview all the messages to find the ones you have not responded to.

    When you exit search mode, the message list does show the icon properly. The bug exists only when displaying search results.

    Tuesday, July 25, 2017 3:53 PM

All replies

  • Hi J.Farro,

    Are you using Outlook 2016 with an Exchange account?

    If this is your case, this is an expected behavior as in Outlook 2016 it will leverage the Exchange Search Index instead of the local Windows Search Index for more consistent search results across various Outlook configurations and Outlook (Web) Mail apps. This however does affect some of Outlook’s old search results behavior and feature availability as well.

    Important Follow the steps in this section carefully. Serious problems might occur if you modify the registry incorrectly. Before you modify it, back up the registry for restoration in case problems occur.
    Please refer to this article about how to back up and restore the registry in Windows.

    To return the previous search behavior that relies on the local Windows Search Index, we may set the DisableServerAssistedSearch Registry value to 1:

    Key: HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search
    Value name: DisableServerAssistedSearch 
    Value type: REG_DWORD
    Value: 1

    Detailed Instructions:

    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following subkey in the registry:
    HKEY_CURRENT_USER\Software\Microsoft\Office\16.0\Outlook\Search
    3. On the Edit menu, point to New, and then click DWORD Value, type DisableServerAssistedSearch for the name of the DWORD, press Enter.
    4. Right-click DisableServerAssistedSearch, and then click Modify.
    5. In the Value data box, type 1 to enable the registry entry, and then click OK.
    6. Exit Registry Editor, and then restart Outlook.


    If you are not really into editing the Registry yourself, you can also download this zip file which contains a file to add the Registry value and also a file to reset the behavior and re-enable Exchange Based searching again.

    Hope this can be helpful.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, July 26, 2017 7:31 AM
  • Hi J.Farro,

    Just checking in to see if the reply above was helpful. Please let us know if you would like further assistance.

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Monday, July 31, 2017 10:19 AM
  • Hello Yuki
    Thanks for your detailed response. I appreciate the effort you put int o it.
    I am very comfortable making changes in the registry.

    I was really hoping this would solve the issue - alas it did not :-(

    I did exit and restart Outlook when I tested. Maybe I should try to completely logout and relogin test.

    Regards,

    J. Farro

    Wednesday, August 16, 2017 9:36 PM
  • Hi J. Farro,

    Thanks for the update.

    Have you tried to download and install the zip file shared in my reply above and check the result? 

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Thursday, August 17, 2017 1:33 AM
  • I did, but it was similar.

    By the way- interestingly I checked for another user in the same organization, on another computer, and it does work OK. They had 64 bit installed and I had 32 bit. Thought this may be the issue, reinstalled 64 bit, but still no go.

    The next thing I need to understand is if it is a "user account" issue or a computer issue. Strange either way ...


    • Edited by J. Farro Friday, August 18, 2017 4:11 AM
    Friday, August 18, 2017 3:08 AM
  • Hi J. Farro,

    Sorry for providing the inappropriate in my initial reply. I did further test on this and can reproduce the issue now in my currently Outlook 2016 (32-bit). Then I noticed that if we choose search in Subfolders, the icon will show up properly:

    Is this the same in your side? 

    Best regards,
    Yuki Sun


    Please remember to mark the replies as answers if they helped.

    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Friday, August 18, 2017 4:25 AM