none
Ubuntu 16.04 and MKL installation fails under 3.3 RRS feed

  • Question

  • I've tried installing with deb.  I've tried installing with ./install.sh

    If I skip the MKL on the ./install.sh it installs fine, and mro works but without performance libraries (3.3.2)

    Per another post, it had nothing to do with globbing (%shopt -s nullglob reported no such job)

    Press [Enter] key to display the Intel MKL license. When finished reading, press q to continue:  
    Do you agree to the terms of the previously displayed license?
    Choose [y]es|[n]o y

    Updating apt package repositories...done
    Installing apt package dependencies libxt6 libsm6 libpango1.0-0 libgomp1 curl...done
    Installing /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-mro-3.3.deb...done
    Installing /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-foreachiterators-3.3.deb...done
    Installing /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-mkl-3.3.deb...ERROR!

    There was an error installing Microsoft R Open.
    Please check the logs at:
    /home/john/Downloads/microsoft-r-open/logs

    john@john-VirtualBox:~/Downloads/microsoft-r-open$ more /logs/mkl.txt
    more: stat of /logs/mkl.txt failed: No such file or directory
    john@john-VirtualBox:~/Downloads/microsoft-r-open$ more logs/mkl.txt
    (Reading database ... 307534 files and directories currently installed.)
    Preparing to unpack .../microsoft-r-open-mkl-3.3.deb ...
    mv: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/backup/lib/*.so': No such file or directory
    dpkg: warning: subprocess old pre-removal script returned error exit status 1
    dpkg: trying script from the new package instead ...
    rm: cannot remove '/usr/lib64/microsoft-r/3.3/lib64/R/lib/*.so': No such file or directory
    mv: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/backup/lib/*.so': No such file or directory
    dpkg: error processing archive /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-mkl-3.3.deb (--install):
     subprocess new pre-removal script returned error exit status 1
    mv: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/lib/*.so': No such file or directory
    cp: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/backup/lib/libR.so': No such file or directory
    cp: cannot stat '/usr/lib64/microsoft-r/3.3/stage/mkl_install_stage/*.so': No such file or directory
    dpkg: error while cleaning up:
     subprocess installed post-installation script returned error exit status 1
    Errors were encountered while processing:
     /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-mkl-3.3.deb


    Wednesday, February 1, 2017 6:01 PM

All replies

  • Hi John,

    Despite several attempts, we haven't been able to reproduce this issue with a standard Ubuntu 16.04 install with MKL. We noticed that you're using Virtualbox. Perhaps that might be where the problem lies...  

    Have you tried on a standard Ubuntu 16.04 install? Has anyone else tried?

    Thanks,

    Josee

    Thursday, February 2, 2017 1:49 AM
    Moderator
  • I have a 16.04 box at home that I will check on.
    Thursday, February 2, 2017 2:17 PM
  • Looks like exact same issue, but that Ubuntu 16.04 is native and the only OS on the computer.

    Updating apt package repositories...done
    Installing apt package dependencies libxt6 libsm6 libpango1.0-0 libgomp1 curl...done
    Installing /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-mro-3.3.deb...done
    Installing /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-foreachiterators-3.3.deb...done
    Installing /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-mkl-3.3.deb...ERROR!

    There was an error installing Microsoft R Open.
    Please check the logs at:
    /home/john/Downloads/microsoft-r-open/logs

    root@john-linux:/home/john/Downloads/microsoft-r-open# ^C
    root@john-linux:/home/john/Downloads/microsoft-r-open# cd logs
    root@john-linux:/home/john/Downloads/microsoft-r-open/logs# ls
    dependencies.txt      mkl.txt  rstudio-0.99.896-amd64.deb
    foreachiterators.txt  mro.txt  update.txt
    root@john-linux:/home/john/Downloads/microsoft-r-open/logs# more mkl.txt
    (Reading database ... 302603 files and directories currently installed.)
    Preparing to unpack .../microsoft-r-open-mkl-3.3.deb ...
    mv: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/backup/lib/*.so': No such fi
    le or directory
    dpkg: warning: subprocess old pre-removal script returned error exit status 1
    dpkg: trying script from the new package instead ...
    rm: cannot remove '/usr/lib64/microsoft-r/3.3/lib64/R/lib/*.so': No such file or
     directory
    mv: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/backup/lib/*.so': No such fi
    le or directory
    dpkg: error processing archive /home/john/Downloads/microsoft-r-open/deb/microso
    ft-r-open-mkl-3.3.deb (--install):
     subprocess new pre-removal script returned error exit status 1
    mv: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/lib/*.so': No such file or d
    irectory
    cp: cannot stat '/usr/lib64/microsoft-r/3.3/lib64/R/backup/lib/libR.so': No such
     file or directory
    Errors were encountered while processing:
     /home/john/Downloads/microsoft-r-open/deb/microsoft-r-open-mkl-3.3.deb

    Sunday, February 5, 2017 2:05 AM
  • Has there been any solution to this? I'm having the same issues with this (Ubuntu 16.04 via VirtualBox) and have not been able to find any solutions online as of yet.
    Wednesday, April 19, 2017 1:28 AM
  • I still encounter this problem. I am using Xubuntu 16.04.1. The mkl install for 3.4 fails the same was others have reported when 3.3 was previously installed. However I have not had problems with clean installs.

    Now here is the issue: on the machine I most want to install on, 3.3 was already installed. And now both installations appear bricked.

    I have tried all the suggestions I have seen online. The issue seems to be that the installation script just fails when it cannot stat some files it needs to remove. I can see the files, and remove them manually, but the script still fails.

    I suspect the issue is that the state of apt gets screwed up by the 3.4 installer.

    At this point I appear to be stuck with the universal uninstall script: A clean install of Xubuntu.

    Monday, June 26, 2017 5:29 PM
  • I still encounter this problem. I am using Xubuntu 16.04.1. The mkl install for 3.4 fails the same was others have reported when 3.3 was previously installed. However I have not had problems with clean installs.

    Now here is the issue: on the machine I most want to install on, 3.3 was already installed. And now both installations appear bricked.

    I have tried all the suggestions I have seen online. The issue seems to be that the installation script just fails when it cannot stat some files it needs to remove. I can see the files, and remove them manually, but the script still fails.

    I suspect the issue is that the state of apt gets screwed up by the 3.4 installer.

    At this point I appear to be stuck with the universal uninstall script: A clean install of Xubuntu.

    So I reinstalled Xubuntu. For some reason 16.04 would'nt work (Ryzen) although at one point I did get it installed.

    This time Open R installed successfully, including MKL, but unhappily it crashes with a "memory not mapped" segfault.

    Well at least there will be another thread for me to read now.

    Monday, June 26, 2017 7:31 PM