MSTSC - File not found <LANG_NAME>


  • Hi all,

    I am facing an issue with the MSTSC / RDP on a Windows 7 Pro (x64) machine in our Company. The machine was installed with a German-language Win7, but switched to an English UI (en-US).

    When starting the Remote Desktop Protocol Client mstsc.exe, I get the following error message:

    [Window Title]

    The system cannot find the file specified.



    mstsc.exe.mui exists in the de-DE, en and en-US Folders. I have updated mstsc to Version 6.3.xxxx following KB2592687.

    Any Input would be appreciated. Thanks!

    Monday, March 10, 2014 4:20 PM


  • Workaround: Switched back to the original language (German) and it works now.
    • Marked as answer by mersa Tuesday, March 25, 2014 2:36 PM
    Tuesday, March 25, 2014 2:35 PM

All replies

  • Hi,

    MSTSC.exe is the executable of "Remote Desktop". C:\windows\system32\[lang]\ folder contains *.mui files, change the name from mstsc.exe.mui to mstsc.exe.old

    It looks like there are a few system files that are having trouble. You are probably corrupting or missing one or both of these files (assuming Windows is installed on your C drive):


    You could try to use SFC command to see if you have any corrupted system files:

    Use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7

    Also you may run rsop.msc or gpresult /v to see if any policy is related to this.

    In addition, the issue may occurs due to the Region and Language setting is incorrect for the machine.

    After checking the informations above, you may try to update your RDP (a restart is required because the system is running on the old dll) and reconnect.  If the problem continues, contact the owner of the remote computer or your network administrator.

    Hope it helps.


    Blair Deng

    Blair Deng
    TechNet Community Support

    Wednesday, March 12, 2014 2:15 AM
  • Hi Blair,

    thank you for your detailed answer. The user is currently out-of-Office with the machine which makes it impossible to try it until next week. I'll keep you updated. Thanks again!

    Wednesday, March 12, 2014 12:55 PM
  • Tried it, unfortunately without success.

    This particular machine is not in a Domain, therefore no policies apply or affect the machine.

    Monday, March 17, 2014 1:27 PM
  • Workaround: Switched back to the original language (German) and it works now.
    • Marked as answer by mersa Tuesday, March 25, 2014 2:36 PM
    Tuesday, March 25, 2014 2:35 PM
  • if switching back to the original language not works: try install .NET language package

    this worked for me.

    • Proposed as answer by Rion Alexandre Thursday, June 23, 2016 2:13 PM
    Wednesday, June 4, 2014 5:03 PM
  • Hi,

    What do you mean with "Switched back to the original language"?

    Where/How did you switch back?

    In my case this issue seems to have started after a recent Windows 7 update. Not sure which one because there have been a lot lately.



    Thanks JP

    Monday, December 15, 2014 8:05 PM
  • I executed once again Windows Update and installed the .NET language pack that fixed the issue.

    Thanks for the hint.

    • Proposed as answer by Ed Weij Wednesday, November 2, 2016 8:50 AM
    Thursday, June 4, 2015 8:20 AM
  • Ive installed again and it works.
    Thursday, August 4, 2016 1:42 PM
  • Ive installed again and it works.
    Thank you, work fine for me.
    Tuesday, September 20, 2016 12:58 PM
  • thanks! It solved my problem.
    Friday, May 26, 2017 2:41 PM