none
WDS Error Access is denied RRS feed

  • Question

  • Hi. I have one server with Windows 2008, SCCM 2007 SP2 and WDS.

    Use WDS for Deploy Windows 7 with SCCM. Install WDS in server but at finish installation, show error: Access is denied, although the WDS service and server is running.

    Access properties for WDS, I try to make a configuration change but show error: Access is denied.

    I install WDS and log on to server with account Domain Admin.


    Carlos Morales http://itprosmex.blogspot.com/
    Thursday, May 20, 2010 4:55 PM

Answers

  • Hi,

     

    Please make sure you log on as a Domain administrator of the domain that contains the Windows Deployment Services server.

     

    If the issue persists, please check what error events appear in Event Viewer.

     

    Please also refer to the following article to enable logging in WDS

     

    http://support.microsoft.com/kb/936625/en-us

     

    Install WDS again and paste the result in the log.

     

    Tim Quan - MSFT

     

    Friday, May 21, 2010 6:00 AM
    Moderator

All replies

  • Hi,

     

    Please make sure you log on as a Domain administrator of the domain that contains the Windows Deployment Services server.

     

    If the issue persists, please check what error events appear in Event Viewer.

     

    Please also refer to the following article to enable logging in WDS

     

    http://support.microsoft.com/kb/936625/en-us

     

    Install WDS again and paste the result in the log.

     

    Tim Quan - MSFT

     

    Friday, May 21, 2010 6:00 AM
    Moderator
  • Hi,

     

    How are things going? I have not heard back from you in a few days and wanted to check on the status of the issue. Please let me know how things turned out.

     

    Tim Quan - MSFT

     

    Monday, May 24, 2010 5:09 AM
    Moderator
  • Hi Tim.

    I appreciate you support.

    The problem is solved, the account not have a Domain Admins permissions. Add permissions and WDS working.

    Thanks,


    Carlos Morales http://itprosmex.blogspot.com/
    Monday, May 24, 2010 1:26 PM
  • HI Tim et all,

    We have a similar issue on our environment.  The server is running Windows Server 2003 R2 SP2 running WDS in Mixed mode (DHCP and RIS).  The issue we have is that users who are not members of the Domain Administrators group are unable to administer the WDS server properties.

    Whilst the easy way around the issue is to give the users Domain Admin privileges, we are in the challenging position that the customer does not want the third party supplier to have Domain Admin privileges.  Is there a way to configure WDS to allow full administration for WDS without DA privileges?

    To date I have tried the following all to no avail:

    • Local administrators group on WDS server
    • Full permissions to specificed group in AD in the WDS server object
    • Looked at WDS SQL Database and given elevated rights to WDS database

    Event viewer shows the following:

    Object Open:

    Object Server: SC Manager

    Object Type: SERVICE OBJECT

    Object Name: McShield

    Handle ID: -

    Operation ID: {0,3086068}

    Process ID: 468

    Image File Name: C:\WINDOWS\system32\services.exe

    Primary User Name: N24BLDSM01$

    Primary Domain: domainname

    Primary Logon ID: (0x0,0x3E7)

    Client User Name: username

    Client Domain: domainname

    Client Logon ID: (0x0,0x2EBAA1)

    Accesses: Query status of service

    Pause or continue the service

     

    Privileges: -

    Restricted Sid Count: 0

    Access Mask: 0x44

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

     

    Any help would be most appreciated.

    Kind regards,

    Andrew.

    Thursday, June 10, 2010 8:56 AM