Lync 2010: Internal Server Error when dialing a response group RRS feed

  • Question

  • Hi!

    I have created a simple response group in Lync 2010, just a round robin to agents in a group.

    When I dial this group, I get "Internal Server Error" on the device and in the event log on the Lync server the following errors are present:

    "Unhandled exception occurred when the service was running on a thread pool thread used by the platform.

    Unhandled exception: System.Reflection.TargetInvocationException - Exception has been thrown by the target of an invocation.

    Inner Exception: System.FormatException - Guid should contain 32 digits with 4 dashes (xxxxxxxx-xxxx-xxxx-xxxx-xxxxxxxxxxxx).

    Cause: Unhandled exception."

    The workflow runtime encountered an error while connecting the call.

    The workflow runtime encountered a critical error.

    Failure occurrences: 4, since 12/7/2010 11:35:30 AM.

    The last encountered error was from a workflow having the display name: Competella AB, the URI: sip:mainqueue@competella.com, and the GUID: 1fdc6ec1-950b-4463-b81d-00fe29b7c863.

    Exception: Microsoft.Rtc.Signaling.OperationFailureException - Unhandled internal exception thrown

    Inner Exception: -


    Restart service.


    • Moved by Ben-Shun Zhu Monday, December 13, 2010 10:07 AM incorrect queue (From:Management)
    Tuesday, December 7, 2010 11:09 AM

All replies

  • Strange. Can you create a second one with the Response Group web tool and see if it has the same behavior? If it does I would try removing the response group configuration for both completely and start over.

    Technical Specialist Microsoft OCS & UC Voice Specialisation - http://www.uwictpartner.be
    If you think my post is the answer to your question, please mark it as answer so future visitors can easily find it.
    Tuesday, December 7, 2010 10:48 PM
  • Doesn't work. I still receive the same error...
    Wednesday, December 8, 2010 8:28 AM
  • What type of endpoint/client are you using to call the response group? I'm having the same issue, but the error only happens with a Snom phone.
    Friday, December 10, 2010 12:14 PM
  • EdwB: Yes, you are correct. I get this error when I use a Snom-phone... either call from it to the RG or answer a call to the RG.

    Well, the current Snom OCS phones seem to be incompatible with response group, but... the response group should handle this error in a better way. I ended up having to reboot the Lync server.

    Friday, December 10, 2010 12:17 PM
  • I had the same error with a snom 300. i opened a call at ms - they found the reason and will fix it hopefully on the lync server side...  MS accepted to give the exact failure description to snom - they were so kind to program a work around - i was allowed to test it -> works. snom told me, the workaround fix would be included in the next regular firmware update...

    • Proposed as answer by Lesorub Tuesday, February 1, 2011 9:18 AM
    Thursday, January 20, 2011 11:59 AM
  • We are experiencing the exact same problem. The RG works fine with the Polycom CX500/600 and Lync client but you get the "Internal Server Error" with the SNOM300 phone. What was the fix Mike and where did you get it from?
    Monday, October 3, 2011 2:30 PM