locked
Word Mail Merge does not accurately import a Text field in Excel with more than 15 numbers RRS feed

  • Question

  • Hi, I've looked through some of the discussions regarding importing numbers from excel into word mail merge. I'm having a problem. In Excel I have a column that includes numbers with more than 15 digits. In Excel, I have made this column a text format, so now in Excel those long numbers show up correctly. However, when doing a mail merge in Word, again the numbers past 14 digits change to zeros. I've read many help articles about this but am still not finding a solution. I even tried going the DDE route and that didn't do it either. I checked out this answer: http://www.techsupportforum.com/forums/f57/mail-merge-data-corruption-429351.html which was the most helpful, but again, DDE seemed to work for this person but not for me. I hope someone can offer a solution. I was hoping that I could do a picture switch, but that does not seem to be an option for this particular problem. I don't know why importing it in DDE format did not solve the problem. Thanks for any help!

    Tuesday, January 20, 2015 3:12 PM

Answers

  • Wow! After all my searching and just after posting this I figured out the solution! I originally had { MERGEFIELD Field_Name \# # } But then I just removed everything after the field name, as is normal for any other text field, so not indicating it was a number, and now it shows up correctly even if the number (from a Text formatted field in Excel) is longer than 15 digits. Hope this helps anyone else who has a problem. I did not use DDE to solve this problem.
    • Marked as answer by Steve Fan Wednesday, January 21, 2015 4:12 PM
    Tuesday, January 20, 2015 3:23 PM