none
Project Server 2013, The current operation was cancelled because another operation in the transaction failed. RRS feed

  • Question

  • Hi guys,

    I have an issue with Project server 2013 installed in my SharePoint 2013 Farm.
    After Configured Analysis Services and Olap Databses on My ProjectServer WebApp,
    I have Build error when I want To build DB. The Olap DB is created but with errors :

    Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'Project Reporting data source', Name of 'Project Reporting data source'.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Risk List', Name of 'Risk List' was being processed.
    Server: The current operation was cancelled because another operation in the transaction failed.

    I have read this process to resolve my issues :

    http://blogs.msdn.com/b/brismith/archive/2012/07/03/a-new-sql-server-and-some-different-cube-building-errors.aspx

    I resolved part 1 and 2 because I encountered theses errors.
    But I 'm blocked to part 3, because I don't see what is "ProjectServer_Reporting database"
    So I have wrong step to configure my Project Server 2013 ?
    the only DB on My SQL Server 2012 are ProjectserverWebApp and ProjectServer Website.
    I configured properly Excel Service and I followed this process to install and configure differents parts of Project Server.

    http://technet.microsoft.com/en-us/library/jj943761.aspx

    for what database I need to give "db_datareader role membership "  ?

    Thanks.

    Monday, March 18, 2013 4:18 PM

All replies

  • Hi there,

    Yes, your observation is correct, there is no "ProjectServer_Reporting" database in 2013, ProjectserverWebApp is the only one database.

    This article is for Project Server 2010 with SQL 2012.


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    • Marked as answer by DarkMoutch Tuesday, March 19, 2013 8:33 AM
    • Unmarked as answer by DarkMoutch Tuesday, March 19, 2013 10:56 AM
    Monday, March 18, 2013 8:37 PM
    Moderator
  • Hi,

    Thanks, so I have done part 3 but on ProjectServerWebappDB but I have the same issue.
    any idea ?

    Tuesday, March 19, 2013 10:58 AM
  • I need to download SQLNCLI.msi 10.0 and SQLSERVER2008_ASAMO10.0 !!!
    corresponding to the Feature Pack SQL Server 2008. (no service pack)
    Microsoft Link is dead !
    Tuesday, March 19, 2013 1:28 PM
  • So, SharePoint Server 2013 installed on SQL Server 2012, Project Server 2013 installed and Configured.
    When I start Build database and cubes I have this error :

    [3/19/2013 2:20 PM] Failed to build the OLAP cubes. Error: Failed to process the Analysis Services database ProjectServer2013 on the SFRASSQL01.demostraining.com server. Error: Errors in the back-end database access module. The provider 'SQLNCLI10' is not registered.
    The following system error occurred:  Class not registered
    Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'Project Reporting data source', Name of 'Project Reporting data source'.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Task Is Overallocated', Name of 'Task Is Overallocated' was being processed.
    Server: The current operation was cancelled because another operation in the transaction failed.

    The database is created well but te Build failed...
    I have installed SQLNCLI 10.0 and SQL Server 2008 AMO 10.1 (I don't find 10.0)

    Please help me.

    Tuesday, March 19, 2013 1:58 PM
  • Try restarting Analysis service

    Also ref. 2013 specific blog from Brian Smith

    http://blogs.msdn.com/b/brismith/archive/2012/11/12/project-server-2013-requirements-to-build-an-olap-cube.aspx


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Tuesday, March 19, 2013 6:33 PM
    Moderator
  • Thanks,

    I have restarted Analysis Services and I checked article but don't work yet :-(
    I have tested with  v10.0, 10.1, 10.2, 11 of SCLNCLI and AMO but not work.

    [3/20/2013 10:13 AM] Failed to build the OLAP cubes. Error: Failed to process the Analysis Services database ProjectServer2013 on the SFRASSQL01.demostraining.com server. Error: Errors in the back-end database access module. The provider 'SQLNCLI10' is not registered.
    The following system error occurred:  Class not registered
    Errors in the high-level relational engine. A connection could not be made to the data source with the DataSourceID of 'Project Reporting data source', Name of 'Project Reporting data source'.
    Errors in the OLAP storage engine: An error occurred while the dimension, with the ID of 'Resource Base Calendar', Name of 'Resource Base Calendar' was being processed.
    Server: The current operation was cancelled because another operation in the transaction failed.

    When SQL client is installed, I must to uninstall last version ? because SQLNCLI 2012 is installed too on my server.
    If I installed two versions of Client, the app use appropriate version or I need to uninstal v11 ?
    I must to install AMO on SQL Server ? or just on Project Server ?

    Thanks.
    • Edited by DarkMoutch Wednesday, March 20, 2013 9:53 AM
    Wednesday, March 20, 2013 9:45 AM
  • I have uninstalled 2012 version of AMO and SQL Client but I have the same error...
    I'm desperate :-(
    Wednesday, March 20, 2013 10:19 AM
  • I had the same problem. Try to install the Analysis Services on the same machine as your PWA. This should surely resolve this issue. I think this issue arises when the cube is building against the Analysis DB on a different server. If you find a different resolution please advise as i will be keen on building the cube against SSAS DB on a different server.

    Cheers


    Raul


    • Edited by Raul007 Thursday, March 28, 2013 2:31 AM
    Thursday, March 28, 2013 2:29 AM
  • I don't think so that is the issue here. I was able to build OLAP cube build using different system than PWA


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Tuesday, April 2, 2013 3:28 PM
    Moderator
  • Hi!

    I don't want install SQL Server or analysis services on my sharepoint Farm...
    I will reinstall Analysis Services and I back to you


    • Edited by DarkMoutch Thursday, April 4, 2013 9:42 AM
    • Proposed as answer by Raul007 Thursday, April 4, 2013 9:44 AM
    Thursday, April 4, 2013 9:41 AM
  • I meant installing analytical services and not the SQL server full install. Also confirm that the user you run the cube build against in project server app has appropriate rights in the database server

    Raul


    • Edited by Raul007 Thursday, April 4, 2013 9:48 AM
    Thursday, April 4, 2013 9:47 AM
  • the SQL Native Client goes on the SSAS server, not on the SharePoint / Project Server.

    Can you please confirm you have that.

    Don't worry about SQL 2012, they are side by side, different libraries, different versions.

    if you were to examine a SQL SSAS Data source that gets created, you will see that SSAS tries to reach DBMS over SQLNative10 libraries.

    Provider=SQLNCLI10;Data Source=MSPS2013DevSQL;Initial Catalog=ProjectServer_PWA_ProjectWebApp_POC;Integrated Security=SSPI;Persist Security Info=False

    Hope this helps,


    Thanks, Eric S. Pcubed

    Monday, April 13, 2015 10:21 PM