locked
Failed to mount database 'Mailbox Database' after I deleted logs manually RRS feed

  • Question

  • I have a new SBS 2011 server, after few days Exchange logs got huge (60gb or so) and stuck "c" drive (I didn't had external hdd for backups yet) I didn't knew what to do to free some space so I deleted manually exchange logs from c drive (the database moved to d drive through sbs standard console).

    This is the message I get when I'm trying to mount the database with sbs 2011 EMC:

     

    --------------------------------------------------------

    Microsoft Exchange Error

    --------------------------------------------------------

    Failed to mount database 'Mailbox Database'.

     

    Mailbox Database

    Failed

    Error:

    Couldn't mount the database that you specified. Specified database: Mailbox Database; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)

    . [Database: Mailbox Database, Server: V4705SERVER.v4705.local].

     

    An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)

    . [Database: Mailbox Database, Server: V4705SERVER.v4705.local]

     

    An Active Manager operation failed. Error: Operation failed with message: MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)

    . [Server: V4705SERVER.v4705.local]

     

    MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)

     

     

     

     

     

    --------------------------------------------------------

    OK

    --------------------------------------------------------

    Thanks!

     


    • Edited by K834T953 Monday, September 12, 2011 2:34 PM
    Monday, September 12, 2011 1:50 PM

Answers

  • Remove the existing files (actually remove everything other then the .edb and .stm) to another temp location. When you try to mount it will recreate the files.

    This solution or moving out the log files may or may not work in all cases. If it doesn't you will have to resort to restoring from back up.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by K834T953 Monday, September 12, 2011 3:32 PM
    Monday, September 12, 2011 2:53 PM

All replies

  • Can you recover those logs?

     

    Monday, September 12, 2011 2:17 PM
  • No

    Monday, September 12, 2011 2:19 PM
  • I don't think so...

    Monday, September 12, 2011 2:19 PM
  • Perhaps this solution would work for you:

    http://social.microsoft.com/Forums/en-US/Offtopic/thread/0bc6ece5-004c-4521-83d2-5f1dfab499b2

     

    Did you remove ALL the files in the logs dir?

     

    Monday, September 12, 2011 2:23 PM
  • I did removed all the files.
    How do I create those files manually? (tmp.edb and e00tmp.log ? I tried to create an empty files with these names under program files/microsoft/exchange/v14/mailbox/mailbox database/
    and move the location of both database and log to a different drive with EMC, but still when I'm trying to mount I get an error message:
    --------------------------------------------------------
    Microsoft Exchange Error
    --------------------------------------------------------
    Failed to mount database 'Mailbox Database'.
    Mailbox Database
    Failed
    Error:
    Couldn't mount the database that you specified. Specified database: Mailbox Database; Error code: An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)
    . [Database: Mailbox Database, Server: V4705SERVER.v4705.local].
    An Active Manager operation failed. Error: The database action failed. Error: Operation failed with message: MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)
    . [Database: Mailbox Database, Server: V4705SERVER.v4705.local]
    An Active Manager operation failed. Error: Operation failed with message: MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)
    . [Server: V4705SERVER.v4705.local]
    MapiExceptionJetErrorMissingLogFile: Unable to mount database. (hr=0x80004005, ec=-528)
    --------------------------------------------------------
    OK
    --------------------------------------------------------
    Monday, September 12, 2011 2:33 PM
  • Remove the existing files (actually remove everything other then the .edb and .stm) to another temp location. When you try to mount it will recreate the files.

    This solution or moving out the log files may or may not work in all cases. If it doesn't you will have to resort to restoring from back up.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com
    • Marked as answer by K834T953 Monday, September 12, 2011 3:32 PM
    Monday, September 12, 2011 2:53 PM
  • Do you have a good backup?

    What log files are missing? (Check shutdown state: eseutil /mh)

     Perhaps mounting the store and accepting data loss is your only option?

    http://technet.microsoft.com/en-us/library/aa998871.aspx 

      -AcceptDataLoss

    If all else fails, you may have to repair with eseutil.

     

     

    Monday, September 12, 2011 2:55 PM
  • Remove the existing files (actually remove everything other then the .edb and .stm) to another temp location. When you try to mount it will recreate the files.

    This solution or moving out the log files may or may not work in all cases. If it doesn't you will have to resort to restoring from back up.


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    Deleting everything (except the .edb one) fixed the problem.

    I learned my lesson, make sure backups are running as scheduled.

     

    Thanks!

    Monday, September 12, 2011 3:34 PM
  • THANK YOU!
    Wednesday, August 19, 2015 6:21 PM
  • Thanx hey, it worked like a charm.
    Monday, February 1, 2016 9:37 AM