locked
Windows Server 2016 automatically restart RRS feed

  • Question

  • Hi!

    Last week I upgraded a physical server from 2012R2 to 2016 and until yesterday everything worked fine. We have a few group policy to prevent automatic restart of the servers if a new update(s) is available:

    -      No auto-restart with logged on users for scheduled automatic updates installations
    -      Re-prompt for restart with scheduled installations
    -      Configure automatic updating: 3 - Auto download and notify for install

    These settings just working fine on the 2012R2 servers, but yesterday afternoon this server restarted without administrator consent. The event log contains this entry:

    The process C:\WINDOWS\system32\svchost.exe ("servername") has initiated the restart of computer "servername" on behalf of user NT AUTHORITY\SYSTEM for the following reason: Operating System: Service pack (Planned)
    Reason Code: 0x80020010
    Shutdown Type: restart

    Is there anything that I can do, to prevent this behavior?


    • Edited by david_ai Thursday, June 15, 2017 7:39 AM
    Thursday, June 15, 2017 7:38 AM

Answers

  • Hi,

    Policy “no auto-restart with logged on users for scheduled automatic updates installations” only applies when “Configure Automatic Updates” is set to option “4-Auto download and schedule the install”.

    At the same time, option “4-Auto download and schedule the install” only valid if values exist for ScheduledInstallDay and ScheduledInstallTime.

    So, although you have configured to not re-start when there are log on users, automatically re-start will still happens at scheduled time.

    Below are relate articles, just for you to have an further understanding.

    Manage device restarts after updates:
    https://docs.microsoft.com/en-us/windows/deployment/update/waas-restart

    Configure Automatic Updates using Registry Editor:
    https://msdn.microsoft.com/en-us/library/dd939844(v=ws.10).aspx

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by david_ai Tuesday, June 20, 2017 9:16 AM
    Friday, June 16, 2017 6:22 AM

All replies

  • Hi,

    Policy “no auto-restart with logged on users for scheduled automatic updates installations” only applies when “Configure Automatic Updates” is set to option “4-Auto download and schedule the install”.

    At the same time, option “4-Auto download and schedule the install” only valid if values exist for ScheduledInstallDay and ScheduledInstallTime.

    So, although you have configured to not re-start when there are log on users, automatically re-start will still happens at scheduled time.

    Below are relate articles, just for you to have an further understanding.

    Manage device restarts after updates:
    https://docs.microsoft.com/en-us/windows/deployment/update/waas-restart

    Configure Automatic Updates using Registry Editor:
    https://msdn.microsoft.com/en-us/library/dd939844(v=ws.10).aspx

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Marked as answer by david_ai Tuesday, June 20, 2017 9:16 AM
    Friday, June 16, 2017 6:22 AM
  • Hi Eve,

    Thank you for your answer! So if I understand it correctly the no auto-restart with logged on users for scheduled automatic updates installations" policy beharviour changed in Windows 10/Windows Server 2016? Because as I wrote it in my first post these policy just working fine with the 3 - Auto download and notify for install option on our Windows Server 2012 R2 servers.

    Best regards,
    David

    Friday, June 16, 2017 8:40 AM
  • Hi,

    Yes, as you can see the clear definition/description as below screenshot displays:


    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 20, 2017 2:13 AM
  • Thank you for your help!

    Best regards,
    David

    Tuesday, June 20, 2017 9:17 AM
  • Hi,

    It’s my pleasure.

    If there is anything else we can do for you, please feel free to post in the forum.

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 20, 2017 9:23 AM
  • OK, I'll give it a whirl.

    The original poster asked whether there was anything he could do to prevent Win2K16 from restarting on its own after installing updates. Eve explained what his GP settings meant, but did not answer the question.

    How can we prevent mission-critical servers from restarting when they feel like it?

    Note that this does not mean setting some kind of window when they can reboot. This means the server will not install updates or reboot itself AT ALL unless manually initiated by an administrator.

    Thanks for any information,

    ianc

    Friday, November 17, 2017 5:31 PM
  • OK, I'll give it a whirl.

    The original poster asked whether there was anything he could do to prevent Win2K16 from restarting on its own after installing updates. Eve explained what his GP settings meant, but did not answer the question.

    How can we prevent mission-critical servers from restarting when they feel like it?

    Note that this does not mean setting some kind of window when they can reboot. This means the server will not install updates or reboot itself AT ALL unless manually initiated by an administrator.

    Thanks for any information,

    ianc

    I would like to know the answer to that as well.

    Brad

    Thursday, December 14, 2017 2:43 PM
  • OK, I'll give it a whirl.

    The original poster asked whether there was anything he could do to prevent Win2K16 from restarting on its own after installing updates. Eve explained what his GP settings meant, but did not answer the question.

    How can we prevent mission-critical servers from restarting when they feel like it?

    Note that this does not mean setting some kind of window when they can reboot. This means the server will not install updates or reboot itself AT ALL unless manually initiated by an administrator.

    Thanks for any information,

    ianc

    I would like to know the answer to that as well.

    Brad

    BUMP !

    And I would like to know the answer for this as well.

    Windows 2016 is broken by design if it does reboots without our explicit permission.

    It's bad enough that Microsoft changed the licensing from processor to core (MORE $$$$$$)
    But this new update feature is another reason to stick with 2012r2

    Thursday, December 21, 2017 9:12 PM
  • Count me in as well. Any suggestions for preventing any type of auto restart would be helpful. This needs to be a manual process for our servers; no surprise reboots. I know there may be a couple of ways to work around this, but I don't want that. I need to be assured that no auto restarts will occur on 2016 servers. 
    Friday, December 22, 2017 2:43 PM
  • OK, I'll give it a whirl.

    The original poster asked whether there was anything he could do to prevent Win2K16 from restarting on its own after installing updates. Eve explained what his GP settings meant, but did not answer the question.

    How can we prevent mission-critical servers from restarting when they feel like it?

    Note that this does not mean setting some kind of window when they can reboot. This means the server will not install updates or reboot itself AT ALL unless manually initiated by an administrator.

    Thanks for any information,

    ianc

    Is there seriously no answer yet for this?  PLEASE tell me I'm just missing something obvious...
    Friday, December 29, 2017 5:12 PM
  • I had a case open with MS for months about this issue. There has been no resolution. 

    GPO is set and applied to "3 - Auto Download and notify for install", yet the 2016 servers ignore this setting and proceed to install and reboot outside of their "active hours".

    Wednesday, January 3, 2018 3:26 PM
  • Any suggestions Microsoft? Most admins don't like being surprised with an unexpected server reboot. I certainly prefer this to be a manual process. It appears from my experience that there is no way to disable/bypass Active Hours and Server 2016 will automatically reboot outside of these hours and in some cases within these hours as other users have stated. Thanks.
    Wednesday, January 3, 2018 4:20 PM
  • I looked around on this quite a bit and wasn't able to find any definitive answers. However I did find an article saying that the default mode for server 2016 is to download updates, but not install them or restart. You can check or change this behaviour by running the command line util sconfig.exe (server config).

    I've since deployed some 2016 machines and thus far they have not automatically rebooted or installed updates, only downloaded them.

    HTH,

    ianc 

    Wednesday, January 3, 2018 7:32 PM
  • Same here... we've had a 2016 reboot on us without any approval whatsoever! Even worse, during operating hours! Gladly, no harm done besides the unexpected downtime.

    Eagerly awaiting an answer from MS.

    Alain.

    Wednesday, January 10, 2018 8:12 PM
  •  

    In order to be certain, i'd suggest making a GP to disable windows update service for mission critical servers? It can't can't install updates without this service.

    Edit: I'm assuming you will be performing regular manual maintenance on these servers to stay up to date. Just be sure to adjust monitoring for this service.


    Asbjørn Vang Jacobsen


    Tuesday, January 16, 2018 10:49 AM
  • Came here today to find an answer to this as I see our Windows Server 2016 servers are saying they're going to restart and we've had them restart without any admin intervention even though they should be set to only download and not automatically restart as per the reg keys here:
    https://msdn.microsoft.com/en-us/library/dd939844(v=ws.10).aspx

    For those who had your server restart without intervention can you run "sconfig.cmd" from a regular admin command prompt and list your value for option 5?  Ours is set to "DownloadOnly"

    Also the output from an Admin Powershell from this "Get-ChildItem HKLM:\SOFTWARE\Policies\Microsoft\Windows\WindowsUpdate"

    This is what we get:
    Name                           Property                                                                                                                                                       
    ----                           --------                                                                                                                                                       
    AU                             NoAutoUpdate                    : 0                                                                                                                            
                                   AUOptions                       : 3                                                                                                                            
                                   ScheduledInstallDay             : 0                                                                                                                            
                                   ScheduledInstallTime            : 3                                                                                                                            
                                   DetectionFrequencyEnabled       : 1                                                                                                                            
                                   DetectionFrequency              : 2                                                                                                                            
                                   RebootRelaunchTimeoutEnabled    : 1                                                                                                                            
                                   RebootRelaunchTimeout           : 60                                                                                                                           
                                   EnableFeaturedSoftware          : 0                                                                                                                            
                                   UseWUServer                     : 1                                                                                                                            
                                   AlwaysAutoRebootAtScheduledTime : 0                                                                                                                            
                                   NoAutoRebootWithLoggedOnUsers   : 1    

    We don't want these servers to restart on their own and should require an admin or some admin powered tooling (which is what we use) to restart them.
    Tuesday, January 16, 2018 7:32 PM
  • What about sconfig option 5 and D  Download only or M manually ?

    Thursday, January 25, 2018 9:28 AM
  • Looking for an answer here too re. Server 2016. My Hyper-V host rebooted after active hours, taking multiple machines including a SQL Server down with it. No WSUS, not domain-joined, haven't started fiddling with registry. Of course no one is usually logged in to the server, so NoAutoRebootWithLoggedOnUsers wouldn't help.

    There is something in the UI to schedule the reboot but it only activates when the reboot is pending. I checked the server around lunchtime and it was still downloading. This evening--boom!--rebooted.

    If I set ScheduledInstallDay to Saturday, will it at least wait until then to reboot?

    Saturday, January 27, 2018 4:52 AM
  • Here, to W2k16 Servers, we disabled the Automatic Updates on PowerShell to test.

    1 - Open Windows PowerShell

    2 - Run sconfig command

    3 - Select the option 5 "Windows Update Settings" 

    4 - Them press (M) to Manual Updates

    Here, until this moment  this solution has solved my problem with unplanned server restart.

    With this config, we are  manually managing the Updates on Hyper-V instances and critical server to prevent this issue

    Regards,

    • Proposed as answer by SCM-1101 Wednesday, February 21, 2018 5:51 PM
    Wednesday, February 7, 2018 5:13 PM
  • Yup, that is what we've resorted to as well.  Not ideal, but luckily the downloads, huge as they are, don't take a long time over a fast Internet connection so we're not losing much time during our monthly maintenance cycle by not having them pre-downloaded and ready for install.

    1 - Open command prompt or Powershell window
    2 - Run sconfig.cmd
    3 - Select option 5 to change "Windows Update Settings"
    4 - Type M to select Manual Updates
    5 - Exit command prompt and cross fingers.  So far so good.

    Wednesday, February 21, 2018 5:46 PM
  • Not really an answer\solution.

    More like a clunky workaround...

    ianc

    Wednesday, February 21, 2018 8:24 PM
  • I am wondering if some of the confusion here--and my own mistake a couple weeks ago--is about what happens AFTER you tell Windows 2016 to install updates. Before 2016, it would install the updates, then patiently wait for you to do the reboot. Now, I'm thinking that once you tell it to install updates, if no one is logged on, it will just reboot whenever (or perhaps during quiet hours if that option is available). In other words, even the Manual scenario, once you give it the go-ahead on updating, be prepared for a reboot.

    Maybe a sort-of workaround would be to set NoAutoRebootWithLoggedOnUsers, then just stay logged on until you're ready to reboot.

    Wednesday, February 21, 2018 10:24 PM
  • mcbsys gets to the point. In our company the servers are in use 24/7 and it is only possible to restart the systems manually at different times. In order not to make the update process even more complicated, we have already installed the updates manually and then restarted them at a suitable time (if production allows it!!!!!)!
    This procedure is no longer possible since Server 2016 - without deactivating these stupid active hours dirty! This can't be true!

    @ Mr. Wang - is there still a chance for the administrators that another GPO will be issued to solve this problem?

    Es kann doch wirklich nicht in Microsofts Sinn sein, dass Hyper-V Server oder andere produktive Systeme einfach neu starten?!

    Thx

    Tuesday, March 13, 2018 8:52 AM
  • mcbsys gets to the point. In our company the servers are in use 24/7 and it is only possible to restart the systems manually at different times. In order not to make the update process even more complicated, we have already installed the updates manually and then restarted them at a suitable time (if production allows it!!!!!)!
    This procedure is no longer possible since Server 2016 - without deactivating these stupid active hours dirty! This can't be true!

    @ Mr. Wang - is there still a chance for the administrators that another GPO will be issued to solve this problem?

    Es kann doch wirklich nicht in Microsofts Sinn sein, dass Hyper-V Server oder andere produktive Systeme einfach neu starten?!

    Thx

    This is ridiculous for the enterprise environment, Microsoft! I've just installed two Win 2016 servers for file servers, now unusable because we do not reboot unless maintenance is scheduled and intentional.  Unbelievable!
    Tuesday, March 13, 2018 10:50 PM
  • I created a task in Task Scheduler as a workaround for this nasty issue. It deactivates the Update Orchestrator "Reboot" task every 30 minutes.

    Command: schtasks
    Arguments: /change /tn \Microsoft\Windows\UpdateOrchestrator\Reboot /DISABLE

    It's a workaround, but it's working.

    Wednesday, March 14, 2018 7:57 AM
  • Have you tried sconfig.cmd? It is working for us, setting to download only makes it only download. Or set to manual to totally disable updates?

    I had a server just reboot on me today. I thought I had set sconfig.cmd but had not, was set to automatic. There is no GP to control this apparently. Looks like SConfig overrules GP but this is not documented anywhere in technet land that I can find. So I set GP to download and notify, and then set Sconfig to DL only. I can only assume sconfig is what matters.

    Jason

    Wednesday, March 28, 2018 3:45 AM
  • My 2016 server was previously set to use WSUS but I couldn't make WSUS download any 2016 updates. Therefore, I removed the WSUS connection and am trying to set it to download and update itself without rebooting.  I've tried changing through sconfig to both "DownloadOnly" and "Manual" but what I get is a prompt that says it's currently set to "Custom" and it won't change.  Does anyone know what change I could make (registry edit possibly?) to get rid of the "Custom" setting so that I can change it to "DownloadOnly"?

    Deb


    • Edited by SYNOFF Thursday, March 29, 2018 4:44 PM
    Thursday, March 29, 2018 4:43 PM
  • I would also like to know the answer to this. It is ridiculous that Microsoft would design servers to automatically reboot without providing a simple option to disable it. Who would want a server rebooting on it's own????
    Friday, April 13, 2018 3:41 PM
  • Dear Microsoft,

    Same here.

    We got an almost 24/7 operation.

    Questions:

    1) "Active Hours" would not allow anything like 06:15 - 05:00. - Could the "Active Hours" be set as required from a Command Line (Script)?

    2) If not - how to tame the Update process so it would not effect the 24/7 production cycle?

    3) For example if W2016 driving an Intensive Care Unit - what are the Microsoft Recommendations for such case?

    Or

    Should Hospitals, Airports, Power Plants including Nuclear scrap any plans of using W2016 for the mission-critical applications?

    Thank you for your understanding.

    Best Regards,

    Boris

    • Edited by M3700 Wednesday, April 25, 2018 3:40 PM
    Wednesday, April 25, 2018 3:25 PM
  • It feels like shit!

    Such simple setting is not working in GPO.

    Wednesday, May 9, 2018 9:08 PM
  • Setting to DownloadOnly or Manual is irrelevant - the big issue is that WS2016, when told to install updates, will automatically reboot instead of simply waiting for an admin to manually reboot the server.  We ran in to this last night on a stand-alone Windows Server Enterprise 2016 Hyper-V host.  Fortunately it was outside business hours, but it is still 100% unacceptable for a server to ever reboot without being explicitly instructed to by an admin.

    Interesting to note that this issue only seems to impact servers with a GUI; our 2016 Enterprise Core servers behave as expected (so far).

    Friday, May 11, 2018 11:44 AM
  • I had this happen to me as well. I happily allowed 2016 to go ahead and install updates on several servers, only to find out a while later that all sorts of havoc had broken loose by them going down for a restart!!! Thanks for randomly changing how things work, MS.

    On 2012, I could initiate installation of updates and then, when I had a scheduled maintenance window, manually kick off the reboot and make sure everything came back up ok - nice and easy.

    I'm getting to the point where I'm almost too paranoid to even try updating these things, as if I do start the process, I better be sitting there babysitting it during the entire lengthy process while it does its thing and hope it doesn't run off the end of the maintenance window till it gets around to going for a reboot.  

    I guess I'm going to have to resort to some of the suggested "hacks" to prevent this nonsense. 

    :(

    Friday, June 15, 2018 9:41 PM
  • Took me ages to just explain this issue with the server restarting on its own after updates were installed manually.  Glad to find others voicing their displeasure at this terrible implementation of windows update from Microsoft.

    I am too Looking for a solution to prevent this auto restart after installing updates, from Microsoft.

    Currently using the task scheduler hack to disable the restart.

     It is much more convenient to download and install the updates, then come back to this the next day and do the restart.  Now once I do the download and install, I cannot leave it because it will just randomly restart at some unknown time.  Even the restart timer, doesn't enable until a restart is actually scheduled.   So if you trigger the installation, you don't even know when the restart timer is going to become available to set it, doh.

    Tuesday, July 10, 2018 9:27 PM
  • This is not an answer and not even an explanation. 24/7 servers must not be allowed to randomly restart, causing business losses. Microsoft wanted to enforce updates - now the servers will be left with no updates at all because of this stupid management decision on MS side.

    Wednesday, July 18, 2018 2:01 PM
  • We have the same problem as well, but only on Server 2016 but nearly on every customer. For me and our customer this situation is not acceptaple, Server should restart when the administrator would it, but not fully automatic ! And if the GPO's can't handle that, we need another solution, but current situation is bad ( no word about the quality of releases patches and how Microsoft are testing these patches...)

    Philipp Menzi

    Thursday, July 19, 2018 7:44 AM
  • I would like to know the answer to this as well, but based on the lack of answers in this thread I'm going to operate under the assumption that when MS moved towards treating Windows 0 as a service with mandatory updates it did the same thing for servers. At my university the Windows 10 machines frequently update during lectures and it would be infinitely worse if the entire server did this. (the irony there is that those machines are instanced,  meaning it can't really update anyway since at midnight all changes are refreshed) 

    For my office computer I hacked a solution by using folder permissions to make updates impossible (because the folders that the update files download to don't have write permissions) and associates use programs like Deep Freeze to prevent changes at the partition level. I imagine the same would work here, but the problem with this approach is that it means killing updates altogether. In their zeal to force us to update they essentially made our systems less secure by preventing us fom updating at all (since allowing an update means unexpected downtime).

    We could just stick with older windows software: windows 2012 server and Windows 7 clients,  but it's ridiculous to think we'd have to stick with an operating system for a decade just to maintain stability and uptime. Im wondering if maybe we should just abandon windows entirely and cut our losses. We could run a linux server,  and launch virtual machines for any software that requires windows,  where running old versions of Windows won't compromise the security of the server. 


    Wednesday, August 8, 2018 1:27 PM
  • Hi Eve,

    your post isnt the solution for the problem.

    You could not automatically reboot 24/7 Server.
    And if you install the Update manually the needed time window is ridiculous. In our environtment with 15 Server 2016 everything von 30 minutes to 3 hours is needed for the installing windows updates.

    How could we disable the automatic reboot?

    Regards

    Para


    Wednesday, September 12, 2018 5:38 AM
  • Hello,

    We're currently experiencing this issue on 1/20 Windows 2016 Servers. 

    We had it (and all the other 20 servers) configured via Group Policy to to download and prompt. No schedule settings. 

    To work around this I've excluded this server from the GP and set the SCONFIG "Windows Update Settings" to "Manual".

    It seems to relate to monthly cumulative updates.

    Any update on a fix for this issue?

    Friday, September 14, 2018 4:46 PM
  • To make things worse, the 'active hours' setting has a maximum duration of twelve hours. So if we want to prevent reboots from 06:00 - 20:00 - we can't. Shockingly poor from Microsoft.
    Friday, September 28, 2018 11:24 AM
  • As an Administrator you always can reboot now after update installation or plan the pending reboot for a later time/ day.

    What about "Specify active hours range for auto-restarts" GPO setting? I think you can extend the default range of 12h to 18h.

    "Specify Deadline before auto-restart for update Installation" could delay restart up to 14 days (in theory).

    Both is better than nothing. Pending reboot leave a system in an unstable state (depends on the update) and should not delayed for an undefined time.

    ThOM 

    Wednesday, December 5, 2018 11:52 AM
  • Hi,

    Policy “no auto-restart with logged on users for scheduled automatic updates installations” only applies when “Configure Automatic Updates” is set to option “4-Auto download and schedule the install”.

    At the same time, option “4-Auto download and schedule the install” only valid if values exist for ScheduledInstallDay and ScheduledInstallTime.

    So, although you have configured to not re-start when there are log on users, automatically re-start will still happens at scheduled time.

    Below are relate articles, just for you to have an further understanding.

    Manage device restarts after updates:
    https://docs.microsoft.com/en-us/windows/deployment/update/waas-restart

    Configure Automatic Updates using Registry Editor:
    https://msdn.microsoft.com/en-us/library/dd939844(v=ws.10).aspx

    Best Regards,
    Eve Wang

    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    We have many servers that are set to option 4- auto download and install and also no auto restart for logged on users.

    Does 'schedule the install' actually mean 'schedule the restart'? Because it seems like it!

    Monday, December 17, 2018 12:33 PM
  • That's for windows 10 not Windows Server 2016. Windows Server 2016 has different setting in registry.

    Rthomas529

    Tuesday, January 15, 2019 8:26 PM
  • Our "fix" for this was to disable the scheduled task that causes this reboot to occur.

    So we created a scheduled task that runs every 30 minutes after 4:30 PM to 8 AM (outside the time you have it set to not restart on updates) and during the days when you might pull updates down if you're using WSUS.

    It runs this to disable the reboot.
    C:\Windows\System32\schtasks.exe /Change /TN "\Microsoft\Windows\UpdateOrchestrator\Reboot" /Disable

    The reason you need to keep disabling it is that Windows seems to re-enable it after installing of updates.  :(

    I worked with an engineer at MS on this but they were unable to reproduce the problem.  Really hoping this isn't an issue with Server 2019.  We're not going to make any more 2016 servers as WU is far too problematic on it, 2012 R2 still behaves well with our automation for patching servers.

    • Proposed as answer by mle_ii Wednesday, April 22, 2020 11:14 PM
    Thursday, May 9, 2019 11:37 PM
  • Hello,  My solution is simple.....  MOVE ALL OF YOUR SERVERS TO LINUX LIKE THE REST OF THE WORLD!!!  

    Microsoft is NOT the solution for servers.... EVER!...  If its not bad memory management and 'Heavy' unwanted application use (For example, why would you have any sort of xbox applications automatically running on servers?) , then its Microsoft sticking you with bad designs and implementations of new features like we have here... Leave Microsoft where they belong, in front of users that need GUI to get work done...  Im not implying that Microsoft isnt king in the 'User' world, they are without a doubt for most business needs the best for applications and compatibility but do not compare a Windows server lifetime of 30 days before reboot to the Linux machine that will run 4 years while doing updates and never need a restart.  My Explanation is simple in why Microsoft does this.... THEY FIGURE THE OS WILL DIE EVERY 25-35 DAYS UNEXPECTEDLY ANYWAY!  might as well get an update in lols.  Move your servers to linux and let Microsoft figure out their own update problems with whats left, AZURE......


    • Edited by Dellsmash1 Friday, June 7, 2019 8:16 PM
    • Proposed as answer by Rolf Kirsch Thursday, June 13, 2019 5:18 PM
    • Unproposed as answer by Rolf Kirsch Thursday, June 13, 2019 5:18 PM
    Friday, June 7, 2019 8:13 PM
  • muuuuuaaahahha…. Fanboy bullshit.
    Thursday, June 13, 2019 5:17 PM
  • Bloody hell Dellsmash1, it's like the 1990s! All you missed off was micro$oft and windoze.

    Thanks for the memories. 

    Thursday, November 21, 2019 11:51 AM
  • Okay I have 18 windows 2016 servers and only one of them is restarting. 

    All servers are subject to the same policy of "3 Download and notify for install". 

    All 18 use WSUS and are subject to the same conf group policy.

    The ONLY difference is the server that is restarting was an actual OS upgrade from 2012 R2 to 2016. All other servers was a clean default windows 2016 install (keeping old settings in .old folders). )(Never done an actual OS upgrade before). 

    The reboots are occurring MONTHLY. It coincides with the "monthly role up/cumulative"????? being available. 

    What is bothering me is that the community is not all over this. While we are experiencing it, it seems we are in a tiny minority.  Is it because we are all making the same mistake that others are quickly spotting and fixing (or not making to begin with)?

    I would like to know

    1) is your server an OS upgrade keeping previous settings and software?

    2) How often does it restart (monthly??). you can use event ID 1074 to determine it.

    3) are you getting event id 1074!

    4) Does sconfig report "downloadonly"

    Thursday, November 21, 2019 12:17 PM
  • Our "fix" for this was to disable the scheduled task that causes this reboot to occur.

    So we created a scheduled task that runs every 30 minutes after 4:30 PM to 8 AM (outside the time you have it set to not restart on updates) and during the days when you might pull updates down if you're using WSUS.

    It runs this to disable the reboot.
    C:\Windows\System32\schtasks.exe /Change /TN "\Microsoft\Windows\UpdateOrchestrator\Reboot" /Disable

    The reason you need to keep disabling it is that Windows seems to re-enable it after installing of updates.  :(

    I worked with an engineer at MS on this but they were unable to reproduce the problem.  Really hoping this isn't an issue with Server 2019.  We're not going to make any more 2016 servers as WU is far too problematic on it, 2012 R2 still behaves well with our automation for patching servers.

    Unfortunately my fears of it being on Server 2019 have come true.  It's there as well as we just found out last night when 2 of our MS SQL database servers spontaneously rebooted on their own.  Remove this scheduled task.  It does not belong on a Server product.
    Wednesday, April 22, 2020 11:23 PM
  • Hello,

    Option 5 is set to custom and the server rebooted 11:20 am in the middle of working day!!!

    (Windows Server 2016)

    Registry are empty no WUServer

    What are my options to block this reboot?

    Thanks,
    Dom


    Security / System Center Configuration Manager Current Branch / SQL

    Friday, July 31, 2020 1:04 AM