none
Trying to run powershell script after OS install, task sequence won't use credentials.. RRS feed

  • Question

  • Hello!

    Im trying to create a reference image of Windows Embedded 8.1. Im using the "Standard Client Task Sequence" as template with an added powershell script to install .Net Framework 3.5. The problem that i experience is that when the OS have installed and MDT has logged in as Administrator the task sequence can't run the powershell script that is located on the deploymentshare since my MDT server wan't credentials. Under the deployment of the OS there is no problem using the local account that i have configured in Bootsstrap.ini. The Deploymentshare on the server is shared to everyone with full access so i don't really understand why this happends.. How can i solve this?

    Tried to turn off protecting shareing on the server but the option doesn't exists for some reason.. Is it because the server is in a domain? If i run the task sequence without the script everything works perfect.

    Thanks in advance.

    // Anthon

    Tuesday, November 4, 2014 7:54 AM

All replies

  • *Where* is the script located? is it located on the same server your MDT Deployment Share (optimal)? Did you import the application into MDT?

    If it's calling a script on a *different* server, how did you ensure that the correct credentials were passed so the drive letter mapping was done correctly?

    If you called the script using a full UNC path to a new server that was not connected previously in the task sequence (Say your MDT server is \\MDT01\DeploymentShare$ :

    powershell.exe -executionPolicy Bypass \\Server\Share$\Path\File.ps1

    This should not work. You must establish a connection to the share first.


    Keith Garner - Principal Consultant [owner] - http://DeploymentLive.com

    Tuesday, November 4, 2014 8:16 PM
    Moderator