locked
Vista doesn't install properly... Possible to download dll files anywhere? RRS feed

  • Question

  •  

    OK, got my new computer at Christmas (packard Bell), with a upgrade to Vista when it was released. Got the Packard Bell upgrade cd (eventually), and installed it. (Had a plethora of problems with the upgrade program, but sort of got around them.) Finally installed Vista, and ever since, whenever I start up the computer I get messages saying 'Activboard App has stopped working', and any time I try to use IE, it comes up with the message 'IE7 has stopped working'. (Without even starting it...)

     

    Been using another computer to access the internet, until I finally downloaded Firefox, and installed it on this computer and had a look around. Tried a number of things for IE (completely clueless as regards Activboard though), for example:

     

    IE runs when viewing offline webpages, or when run as administrator. (Despite my account being an administrator account). Of course, given that IE is an integral part of Vista, and used to report errors etc. (even with IE errors... what bright spark had that idea?), this isn't really much use.

     

    Tried using the Sfc tool, which (I think) has narrowed down the problem. Scrolling through the CBS log gives:

     

     

    Code Snippet

    2007-08-21 00:45:43, Info                  CSI    0000000c Hashes for file member \SystemRoot\WinSxS\msil_system.design_b03f5f7f11d50a3a_6.0.6000.16386_none_b5757f4b02c7c5b0\System.Design.dll do not match actual file [l:34{17}]"System.Design.dll" :
      Found: {l:20 b:ipdtIoX91Apq+H5BpNeD7NDgxvb=} Expected: {l:20 b:eGNe/RknaO2qV2EP5a8RZ8q+h+q=}
    2007-08-21 00:45:43, Info                  CSI    0000000d [SR] Cannot repair member file [l:34{17}]"System.Design.dll" of System.Design, Version = 6.0.6000.16386, pA = PROCESSOR_ARCHITECTURE_MSIL (8), Culture neutral, VersionScope neutral, PublicKeyToken = {l:8 b:b03f5f7f11d50a3a}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch
    2007-08-21 00:45:47, Info                  CSI    0000000e Repair results created:

     

     

    So I find a (the?) problem. Now my question is, is it safe to manually replace the dll, and if so, where can I download it, and how do I do it. If it isn't safe... what do I do?!

     

    Thanks for any help in advance.

     

    EDIT

     

    Okay, through searching around (mainly through trial and error, and google...) I found the helpful article at: http://support.microsoft.com/kb/929833

     

    Unfortunately, this doesn't tell me where I can get a "known good copy of the file"... Argh!

     

    Also, this is slightly different to the given error, in that it is a hash mismatch, but I assume, (hope!) replacing it should sort that out. Of course, finding the file from the Packard Bell Windows Vista Home Premium Express Upgrade cd has proven impossible, so I am stuck unless someone is able to direct me to a trusted place where I can download it.

     

    ARGH!

     

    SECOND EDIT

     

    Okay, eventually fixed the dll problem... but every other problem still remains, so I guess it's not an install problem. Maybe I'll head off to join the many other people complaining on the IE forum. I hate to say it, but I am finally starting to understand people who pirate software, if this is what you get for your money! Maybe instead of spending all their time devising new software protection for their products, MS can make sure they run first...

     

    I need to blow off some steam. Hours and hours spent in front of a computer getting nowhere isn't good for the health.

    Tuesday, August 21, 2007 10:32 PM