none
When trying to connect to internal webpage, IE throws "Internet Explorer cannot display the webpage" error RRS feed

  • Question

  • I've inherited a Windows 2008 R2 server (no snickering and let's stay on topic please).

    It's on a closed, flat network.

    There's a webserver elsewhere in this closed, flat network.

    All the other hosts in this network can go to the webserver and see the landing page.http://10.242.34.100:8000

    EXCEPT the W2K8 box.

    On the W2K8 box:

    • I've turned off IE ESC
    • Made sure port 8000 is allowed through the Advanced Firewall
    • Added http://10.242.34.100:8000 to the trusted sites
    • I can indeed ping 10.242.34.100

    * telnet 10.242.34.100 8000 just hangs

    When I go to http://10.24.34.100:8000, it throws this error, "Internet Explorer cannot display the webpage"

    What am I missing?

    Tuesday, June 26, 2018 8:48 PM

Answers

  • Hi,

    well... I can't look over your shoulder (words can only convey so much... that's why questions and answers are confusing.. me too. ) …

    only IE11 is supported now... You will find the IE version number and Update version on the Help>About Internet Explorer dialog.

    the last update for win2008 R2 SP2 is available from https://www.microsoft.com/en-us/download/details.aspx?id=42454

    … the error message "Cannot display webpage"... is associated with security zone settings and certificates. There is a checkbox on the Trusted and Intranet sites tab in Internet Options, to require https.. one would expect that auto-detection of Intranet sites would map the failed host request to the Intranet zone by default.

    My last guess would be to go

    Tools>Internet Options>Security tab, Trusted sites icon, 'Sites' button and remove the IP address from the list of hosts.

    then select the Intranet icon,

    check "automatically detect intranet sites". Then click the Advanced button and remove any hosts entries there that you may have added manually. The require https checkbox is on that dialog.

    If you could include a screen shot of your Trusted and Intranet sites security zone settings, that would be good.


    Rob^_^


    Friday, June 29, 2018 10:02 PM

All replies

  • Hi,

    What am I missing?

    File>Properties will tell you which IE security zone a host has been mapped to.... Adding an intranet site to the Trusted sites list over-rides the automatic setting of Intranet.

    You did not mention which version of IE you are currently using. Server versions of windows run IE in an enhanced security configuration. It is unclear whether you mean, IE11 running on a windows client or IE running on your server.

    Regards.


    Rob^_^

    Wednesday, June 27, 2018 12:25 AM
  • Thanks for the reply... but really confused by some of it.

    > File>Properties will tell you which IE security zone a host has been mapped to

    File properties of what?  IE?  If it's IE, File -> Properties brings up a for which says:

    Internet Explorer cannot display the webpage

    Protocol: Unknown Protocol
    Type: File
    Connection: Not Encrypted
    Address: res://ieframe.dll/dnserror.htm#http://10.242.34.100:8000
    (URL)
    Size: 5947 bytes

    Created: 6/27/2018
    Modified: 6/27/2018

    Adding an intranet site to the Trusted sites list over-rides the automatic setting of Intranet.

    Should I have not added as a Trusted Site?

    Server versions of windows run IE in an enhanced security configuration

    Yes. I mentioned I disabled IE ESC to make sure with wasn't the culprit.

    Wednesday, June 27, 2018 4:25 PM
  • Hi,

    on a server that is working open the landing page at http://10.242.34.100:8000 and use the File>Properties menu in IE to determine which IE security zone that machine maps the host to.

    or

    Compare the LAN settings on both machines from the Internet Options control panel. One would expect that they both have the same configuration for you lan settings and the Security tab, Intranet sites, 'Sites' button. Is "Automatically detect intranet sites" checked?

    Do the machines have unique Computer names?

    Regards.


    Rob^_^

    Thursday, June 28, 2018 9:08 PM
  • > on a server that is working open the landing page at http://10.242.34.100:8000 and use the File>Properties

    The 2008 R2 host is the only Windows box in the network.  The rest don't and cannot run IE.  The rest all work though so I know this isn't a network problem but rather something with the 2008 R2 box.

    > Do the machines have unique Computer names?

    Yes.

    Thursday, June 28, 2018 9:16 PM
  • next

    try

    Tools>Internet Options>Advanced tab, Security section, check "SSL 3" and "TLS 1.0". Save changes and refresh.


    Rob^_^


    Friday, June 29, 2018 2:17 AM
  • Thanks.

    Those boxes had checks in them when I opened the form

    Friday, June 29, 2018 2:21 PM
  • Hi,

    well... I can't look over your shoulder (words can only convey so much... that's why questions and answers are confusing.. me too. ) …

    only IE11 is supported now... You will find the IE version number and Update version on the Help>About Internet Explorer dialog.

    the last update for win2008 R2 SP2 is available from https://www.microsoft.com/en-us/download/details.aspx?id=42454

    … the error message "Cannot display webpage"... is associated with security zone settings and certificates. There is a checkbox on the Trusted and Intranet sites tab in Internet Options, to require https.. one would expect that auto-detection of Intranet sites would map the failed host request to the Intranet zone by default.

    My last guess would be to go

    Tools>Internet Options>Security tab, Trusted sites icon, 'Sites' button and remove the IP address from the list of hosts.

    then select the Intranet icon,

    check "automatically detect intranet sites". Then click the Advanced button and remove any hosts entries there that you may have added manually. The require https checkbox is on that dialog.

    If you could include a screen shot of your Trusted and Intranet sites security zone settings, that would be good.


    Rob^_^


    Friday, June 29, 2018 10:02 PM
  • Thanks for all the replies and assistance Rob.  Very much appreciated.  I'm just going to use a workaround for this single W2K8 host.

    Regarding the comment about IE11 being supported the webserver doesn't check the user agent so it, in theory, shouldn't care what the browser is.

    Thanks again!

     
    Monday, July 2, 2018 2:26 PM
  • Hi,

    YW! What was the workaround you used? or was it a matter of just mapping to an IE security zone and uncheck 'require https'?

    Regards.


    Rob^_^

    Monday, July 2, 2018 9:14 PM
  • The workaround is not using the W2K8 host. 
    Tuesday, July 3, 2018 9:18 PM