none
log in scripts won't run

    Question

  • hello every one 

    i'm contacting you today cause on my domain i'm trying roll out some login scripts but thy don't seem to run even when following this tutorial

    https://technet.microsoft.com/en-us/library/cc770908.aspx

    here are copies of the login script that i try to run

    this is what rns when the computer starts up or logs in

    robocopy \\serveur\MDL\MDL\ D:\MDL\ /XO /MIR
    and this is what run when the computer shuts down or logs off
    robocopy D:\MDL\ \\serveur\MDL\MDL\ /XO /MIR

    and then on another group of computers i have this script that run a the computers startup or login

    ::kill explorer
    Taskkill /IM explorer.exe /F
    
    ::set to server time ?
    ::net time \\server /set /yes
    
    ::copy background
    robocopy \\serveur\Background\ C:\background\ /XO /MIR
    
    :: Add the required values ​​to the registry, if these people are using a System Wallpaper.
    ::If they have always modified their wallpapers, the following lines are not necessary. "They have no habit of hurting themselves, constantly"
    REG ADD "HKCU\Control Panel\Desktop" /V Wallpaper /T REG_SZ /F /D "C:\background\pre-background.png"
    
    :: Modify the following line in the last number to 0 if you want to center the bitmap on the desktop.
    ::Change the last number in the following line to 2 if you wish to extend the bitmap vertically and horizontally to fit on your desktop.
    REG ADD "HKCU\Control Panel\Desktop" /V WallpaperStyle /T REG_SZ /F /D 2
    
    ::copy games
    robocopy \\serveur\Games\Riot_Games\ C:\Games\Riot_Games /XO /MIR
    robocopy \\serveur\Games\World_of_Warplanes\ C:\Games\World_of_Warplanes\ /XO /MIR
    robocopy \\serveur\Games\World_of_Tanks\ C:\Games\World_of_Tanks\ /XO /MIR
    robocopy \\serveur\Games\Dofus2\ C:\Games\Dofus2\ /XO /MIR
    robocopy \\serveur\Games\Hi-Rez_Studios\ C:\Games\Hi-Rez_Studios\ /XO /MIR
    
    ::launch cyberlux client
    start C:\Windows\
    

    the thing is that none of the scripts will i've tried adding a pause to double check that but it didn't even show up

    when i mannually run them they run fine they do they copy everything that there ment to

    i would like to able add the login scripts useing the gpo so i can control them easier

    any help would be very much appreciated

    and if you need any more info please just ask


    Friday, February 6, 2015 12:31 PM

Answers

  • If the script runs manually this shouldnt be an issue

    you have probably set the GPO up incorrectly for that see this

    http://www.petri.com/setting-up-logon-script-through-gpo-windows-server-2008.htm

    How and where did you link the created GPO? does gpresult show an applied gpo?

    Friday, February 6, 2015 1:27 PM