none
DPM PowerShell Command not working RRS feed

  • Question

  • We recently upgraded out SQL Server from Windows 2008 to Windows 2012. Among some of the issues I had, is when I removed the SQL Server DB's to re-add them, I lost all of my recovery points for the DB's. I am trying to run the following command to see if I can see the recovery points in case we need to restore  db: $pg = Get-ProtectionGroup -DPMServerName (&hostname). When I run this command with our server name substituted for (&hostname), it returns no data. I have six protection groups, all of which have servers with recovery points. Can someone let me know what I may be doing wrong so I can see if I have any recovery points? No data was deleted, just lost recovery points for SQL DB's.

    Thanks,

    Friday, June 7, 2013 3:43 PM

All replies

  • OK It is a Monday morning (pre-coffee) so bear with me.

    You have a DPM Server...what version? ...2007,2010,2012? Is this DPM server running a local SQL instance or was this SQL instance on the SQL servers that you upgraded to Windows 2012?

    I assume everything is accessible through the console - all datasources are consistent and you have tried a test restore from the console.

    Try:

    $DPMServer = "DPMServerName"

    Connect-DPMServer $DPMServer

    Get-ProtectionGroup

    Another silly question ..and this is no reflection on yourself and I have no idea what your level of PS knowledge is ...once you ran your $pg = Get-ProtectionGroup -DPMServerName "DPMServerName" command ...you did check the $pg variable didnt you ...to confirm it was empty :)

    Cheers

    Monday, June 10, 2013 7:57 AM