locked
Windows 10 - Edge not responding to password manager GPO since 1803 update RRS feed

  • Question

  • Hi,

    We currently disable password manager in Microsoft Edge via GPO to prevent our users from saving passwords in their Edge browser.  Since upgrading to 1803 Build 17134.1 Edge has begun to remember passwords again.  The GPO is still responsive as I have switched between Enabled and Disabled and this has been reflected within the Edge advanced settings UI however Edge continues to prompt to save a password regardless of how it is set.  Can someone offer assistance?

    Many thanks,

    Tom


    Monday, May 14, 2018 2:55 PM

All replies

  • Hi Tom,

    Thank you for your post.

    I try to reproduce on my Windows 10 1803 OS build 17134.48, the group policy works well on Microsoft Edge after I configured. So please check on those client machine if the group policy was removed or not applied well. We could run "gpresult /h C:\gp.html" to check the applied group policies.

    We also could configure the group policy object "Configure Autofill" to cooperate with "Configure Password Manager" in same Microsoft Edge path.

    If the issue persists, I recommend to re-apply the group policy and check again. Also Update Windows to the latest version might be a choice for checking.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Joy-Qiao Wednesday, May 16, 2018 1:24 AM
    Tuesday, May 15, 2018 7:06 AM
  • Hi,

    Any update?

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, June 7, 2018 2:48 AM
  • I'm not sure about the original poster, but I have also seen the same. I have verified with RSOP.msc that the policy seems to be installed correctly on the system. Also, in Edge, the option to enable saving passwords is greyed out.

    Edge will still ask to save a new password.

    We're using the setting in Computer Configuration instead of User Configuration. Could that be the reason?


    Tuesday, June 26, 2018 1:30 PM
  • Our organization is having the exact same issue.  GPO in place to disable "Configure Password Manager" via computer policy, and you can see in Edge settings that "save passwords" is off.  However, since upgrading to 1803 (17134.1), Edge is prompting our users "Would you like to save your password for …"

    We are on Windows 10 Pro

    Some of my testers are on Win10 1803 17134.112 and still having this issue, so it wasn't fixed in the June 2018 Cumulative update.
    • Edited by Steve St Wednesday, June 27, 2018 3:24 PM
    Wednesday, June 27, 2018 2:59 PM
  • With the July cu 1803 has been marked as SAC and this still hasn't been fixed. what the hell microsoft
    Wednesday, July 11, 2018 2:17 AM
  • I have the exact same experience. Microsoft Edge browser is offering the user to save passwords even though is prohibited by GPO (Group Policy Object). See attached screen dump.

    Its a security breach seen from a domain perspective … And users are annoyed by a the popup message …

    Any work arounds? When can a fix be expected?

    Server: Windows Server 2016.  Client: Windows 10


    Thursday, July 12, 2018 10:29 AM
  • We are affected by this as well, exact same symptoms.  Since rolling out 1803 like this would be unacceptable, I decided to just deploy this registry key via GPO preferences, it works great, no more prompt to save passwords in Edge:

    https://www.tenforums.com/tutorials/8488-turn-off-offer-save-passwords-microsoft-edge.html

    [HKEY_CURRENT_USER\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wekyb3d8bbwe\MicrosoftEdge\Main]
    "FormSuggest Passwords"="no"

    Tuesday, July 31, 2018 9:23 PM
  • The workaround described by Joe111122311344 works.

    A part of the GPO setup can be found in the picture below.

    Monday, October 8, 2018 1:12 PM