none
Group Policy to Set Lock Screen Image for Windows 10

    Question

  • I have set up a Group Policy to set the Lock Screen image to a defined image located on the C:\users\public\pictures\

    There is also a registry key to change the lock screen image location.

    I have also made it so that they can't change the Lock Screen.

    I have installed the relevant Admx for windows 10 on the server and updated the group policy.

    Some computers, when a gpupdate /force is done the lock screen does not change.

    does anyone have any idea on how to get the lock screen changed via group policy?

    Thanks


    Henry Edwards

    Tuesday, September 29, 2015 9:27 AM

All replies

  • Hi,
     
    Please try to run "gpresult /h result.html" and see if the setting has been applied successfully. Also, make sure that the faulty computers are in the correct container in ADUC to pick up that GPO.
     
    For the steps on How to Manage the Lock Screen Image, please refer to this KB article:
     
    https://support.microsoft.com/en-us/kb/2787100 (It's for Windows 8, but the steps should hold good for Windows 10)
     
    By the way, could you please share the exact registry key that you've changed?
     

    Regards,

    Ethan Hua


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com

    Thursday, October 1, 2015 4:04 AM
    Moderator
  • Hi

    I am unable to apply the update as it just gives me Windows 8 RT update.

    I have enabled it using the correct GPO.

    The registry key is the following:

    HKEY Local Machine -> Software -> Polices -> Microsoft -> Windows -> Personalization -> LockScreenImage

    that is a REG_SZ and the path is C:\Users\Public\Pictures\ScreenArtwork5.jpg

    I have run the result many times and this is what is in the applied GPO, this sets the default lockscreen image using GPO. I also have the above registry in place and it's still showing my own lock screen image.

    <sub></sub><sup></sup><strike></strike>


    Henry Edwards


    • Edited by Henryed07 Thursday, October 1, 2015 7:54 AM
    Thursday, October 1, 2015 7:54 AM
  • If you get this registry key populated on the machine, then the policy got applied on that machine successfully.
     
    As per the screenshot, seems you have configured security filters for this GPO, can you please confirm whether the faulty computhers have the required access to this GPO?
     

    Tuesday, October 6, 2015 9:23 AM
  • Yes it applies the Registry, but does not change it.

    yes, those are just applying to me domainname\username and domainname\computername


    Henry Edwards

    Thursday, October 8, 2015 3:20 PM
  • I can confirm that the same method to set up a Win8 lockscreen still works in Win10.  By "same method", I mean the way I'm doing it.  :-)  There's no need fart around with registry keys - instead, simply use these settings:

    Computer Configuration \ Policies \ Admin Templates \ Control Panel \ Personalization

    -and-

    Computer Configuration \ Preferences \ Windows Settings \ Files

    And lastly, don't call on a picture from the Public profile.  I would suggest your problem stems from some/all users not having sufficient rights to this directory.  Why not just use C:\Windows\Web\Screen (the default location)?


    • Edited by bondg Wednesday, October 14, 2015 9:52 PM added info
    Wednesday, October 14, 2015 9:46 PM
  • Hi, bondg

    I have tried this. I have created a GPO, assigned my laptop to the group.

    then I did gpupdate /force but this did not change the lockscreen.

    It did not force to use the image specified in the C:\Windows\Wed\Screen

    Any more ideas?


    Henry Edwards

    Thursday, October 22, 2015 7:35 AM
  • I had the same issue, it turns out the GPO mentioned above only works with Enterprise, Education and Server editions as stated in the note section of the setting.

    

    Friday, September 23, 2016 2:18 PM
  • I had the same issue, it turns out the GPO mentioned above only works with Enterprise, Education and Server editions as stated in the note section of the setting.

    

    We are running Windows 10 Enterprise

    running the same GPO as stated above

    Reg key is being populated use lockscreen image at C:\Windows\Web\Screen\Lockscreen.jpg

    But the lockscreen is still not updating to the jpg file at the above location when doing a gpupdate /force and or reboot

    Wednesday, November 16, 2016 1:38 AM
  • I can confirm that the same method to set up a Win8 lockscreen still works in Win10.  By "same method", I mean the way I'm doing it.  :-)  There's no need fart around with registry keys - instead, simply use these settings:

    Computer Configuration \ Policies \ Admin Templates \ Control Panel \ Personalization

    -and-

    Computer Configuration \ Preferences \ Windows Settings \ Files

    And lastly, don't call on a picture from the Public profile.  I would suggest your problem stems from some/all users not having sufficient rights to this directory.  Why not just use C:\Windows\Web\Screen (the default location)?


    Hi Bondg

    Can you please specify what GP setting you were using for:

    Computer Configuration \ Preferences \ Windows Settings \ Files

    We are having the same issue as the OP

    Running Windows 10 Enterprise and lockscreen is not updating

    Is the above GPO setting just for updating the image file?

    We use SCCM for that to copy a new image every month


    • Edited by Drekko Wednesday, November 16, 2016 2:24 AM
    Wednesday, November 16, 2016 1:41 AM
  • Hi

    Have the same IDENTICAL Problem.

    Some PC get the updated Lockscreen, Others ... Not.

    I am becaming mad.

    All settings are applied and GPRESULT confirm it.

    What do you intend with the policy settings of :

    Computer Configuration \ Preferences \ Windows Settings \ Files  ??

    Friday, December 16, 2016 8:54 AM
  • I found a workaround to fix the image not updating.  Configure a computer group policy to delete the following registry keys - when the lock screen is called, the keys are regenerated and in the process the image will be updated from the location specified in the "Path to lock screen image:" policy

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen\CacheFormat_P

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen\GPImagePath_P

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen\SizeX_P

    HKLM\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen\SizeY_P

    It's really disappointing/frustrating how group policy is so broken in Windows 10.  I can't tell if Microsoft just doesn't care any more or is deliberately breaking thigns / making life painful for enterprise admins in order to shepherd them toward managing endpoints via AzureAD/Intune.

    Tuesday, February 7, 2017 6:19 AM
  • Your recommendation seems promising, however, I find that none of the 4 values re-generate when the lock screen is called. It does seem directly related to the issue, however. Removing those 4 values will break whatever lock screen you have.
    Tuesday, March 7, 2017 3:48 PM
  • Just FYI, i have this problem on selected computers. taking ownership of the key
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen

    deleting it, and then rebooting does work for fixing the lock screen to the new image. The key is regenerated, and even if it existed before and was correct, this allows the lockscreen to actually work.

    So thanks for the tip o sysadmin. I am not deleting the key enmasse using policy at this time incase it breaks currently working lockscreens. However as its only a handful of computers with this problem, i can delete and regenerate the key on an as needed basis. This method does appear to work and not break the lockscreen  for me anyway.

    Wednesday, November 1, 2017 3:43 PM
  • Hi!

    I'm can not delete  CacheFormat_P  , GPImagePath_P  , SizeX_P  , SizeY_P

    Help me please!


    • Edited by Pogreb Monday, November 27, 2017 12:25 PM
    Monday, November 27, 2017 12:24 PM
  • just look up taking ownership of a registry key:

    https://www.howtogeek.com/77878/take-ownership-of-or-assign-full-permission-for-a-registry-key-in-windows-7/

    you need to take ownership of the key to delete it

    if you download the program SetAcl.exe , then you can script it even. thats what i have been doing. I guess i never posted the script here, so here it is:

    "\\NETWORKSERVER.LOCAL\setacl\SetACL.exe" -on "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen" -ot reg -actn setowner -ownr "n:Administrators"
    
    "\\NETWORKSERVER.LOCAL\setacl\SetACL.exe" -on "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen" -ot reg -actn ace -ace "n:Administrators;p:full"
    
    reg delete "HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\SystemProtectedUserData\S-1-5-18\AnyoneRead\LockScreen" /f

    after doing that, and rebooting, the updated lockscreen is refreshed from policy, copied to the machine and implemented.

    Monday, November 27, 2017 3:58 PM
  • I did not have a section S-1-5-18
    I created it
    Added all sections (screen)
    It did not work.
    Then in other sections I deleted CacheFormat_P, GPImagePath_P, SizeX_P, S izeY_P

    Restarted PC
    The picture has not changed
    • Edited by Pogreb Tuesday, November 28, 2017 2:30 PM
    Tuesday, November 28, 2017 2:19 PM
  • hmm well it looks russian to me. maybe its a different key? do you have a small set of numbers under your systemProtectedUserData key as shown below? Could be a different set of numbers by localization.

    Are you using win10 ENTERPRISE? it wont work in any other windows 10 version from what i understand.

    oh and i make sure to copy the file using GPO from a network location to the local machine at "c:\windows\system32\oobe\info\backgrounds\backgrounddefault.jpg" and with that particular file name, overwriting the default one.

    Im not sure if network locations for the image are supported.

    Tuesday, November 28, 2017 4:22 PM
  • I'm use Windows 10 Pro - Russian language. Licensed

    "c:\windows\system32\oobe\info\backgrounds\backgrounddefault.jpg"  - I do not have this catalog

    hidden directories included

    Wednesday, November 29, 2017 6:01 AM
  • right, as i said, microsoft has made this NOT work in PRO versions. Only enterprise. so theres your problem right there. it will never work in PRO since some update they did.

    And yes F m$ because i have a bunch of pro workstations around here that i now have to convert to enterprise because of the stupid lock screen restriction.

    If you dont believe me you can search for info on that. will not work in PRO, as per microsoft. only win10 ENT

    • Proposed as answer by Yavar Fall Sunday, January 7, 2018 4:04 PM
    Wednesday, November 29, 2017 3:58 PM
  • Big thanks!!!

    You're fight
    • Edited by Pogreb Thursday, November 30, 2017 8:19 AM
    Thursday, November 30, 2017 8:09 AM
  • You are 100% right! This shit only works at Windows 10 Enterprise as you said.
    Sunday, January 7, 2018 4:04 PM