none
Windows 7 for x64-based Systems (KB4022719) installation failure 0x80004005 - CBS.log shows Attempted to uninstall a version of a non-driver component that is not installed

    Question

  • Over the past four days I've not been able to install the KB4022719 windows update on my Windows Ultimate 64bit laptop (Dell L702X). It repeatedly fails with the error 0x80004005.

    From the WindowsUpdate.log file I can see:
    2017-06-18 14:31:28:379 4976 1078 Handler Starting install of CBS update 907279C7-1F8B-4D90-A980-016CE24A2E5D
    2017-06-18 14:31:28:675 4976 1078 Handler CBS package identity: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6
    2017-06-18 14:31:28:675 4976 1078 Handler Installing express with source=C:\Windows\SoftwareDistribution\Download\a021ca4fd1e92e19406ed08979073a70, workingdir=C:\Windows\SoftwareDistribution\Download\a021ca4fd1e92e19406ed08979073a70
    2017-06-18 14:31:33:340 1220 1bb0 Report REPORT EVENT: {281CEB78-700D-44C4-9B0D-E879E01FC150} 2017-06-18 14:31:28:332+0100 1 181 101 {4228CA7B-BF66-41F4-89BF-AC4C07C24CF7} 200 0 AutomaticUpdates Success Content Install Installation Started: Windows successfully started the following update: 2017-06 Security Monthly Quality Rollup for Windows 7 for x64-based Systems (KB4022719)
    2017-06-18 14:31:54:010 4976 11c4 Handler FATAL: CBS called Error with 0x80004005, 
    2017-06-18 14:31:54:010 4976 1078 Handler FATAL: Completed install of CBS update with type=0, requiresReboot=0, installerError=1, hr=0x80004005
    2017-06-18 14:31:54:010 4976 1078 Handler :::::::::
    2017-06-18 14:31:54:010 1220 10fc AU >>##  RESUMED  ## AU: Installing update [UpdateId = {4228CA7B-BF66-41F4-89BF-AC4C07C24CF7}]
    2017-06-18 14:31:54:010 4976 1078 Handler ::  END  ::  Handler: CBS Install
    2017-06-18 14:31:54:010 1220 10fc AU  # WARNING: Install failed, error = 0x80004005 / 0x80004005
    2017-06-18 14:31:54:010 4976 1078 Handler :::::::::::::
    2017-06-18 14:31:54:025 1220 c2c Agent LogHistory called. idUpdate={4228CA7B-BF66-41F4-89BF-AC4C07C24CF7}.200, resultMapped=80004005, resultUnMapped=80004005
    2017-06-18 14:31:54:135 1220 c2c Agent *********
    2017-06-18 14:31:54:135 1220 10fc AU Install call completed.
    2017-06-18 14:31:54:135 1220 c2c Agent **  END  **  Agent: Installing updates [CallerId = AutomaticUpdates]
    2017-06-18 14:31:54:135 1220 10fc AU  # WARNING: Install call completed, reboot required = No, error = 0x00000000
    2017-06-18 14:31:54:135 1220 c2c Agent *************
    2017-06-18 14:31:54:135 1220 10fc AU #########
    2017-06-18 14:31:54:135 1220 10fc AU ##  END  ##  AU: Installing updates [CallId = {2E24A732-2424-42B3-8A44-82E27B8DB75A}]

    And from the CBS.log I can see:

    2017-06-18 14:31:49, Error                 CBS    Failed. Attempted to uninstall a version of a non-driver component that is not installed, version: 0X600011db15ced, component: amd64_microsoft-windows-m..do-backcompat-tlb60_31bf3856ad364e35_6.1.7601.23789_none_4b46113920e375d8, owner: Package_857_for_KB4019264~31bf3856ad364e35~amd64~~6.1.1.3.4019264-3005_neutral_LDR [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CBS    Failed to mergecomponent [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CBS    ComponentAnalyzerUninstallDeployment: Failed on update: 4019264-3005_neutral_LDR [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CBS    Failed to execute item[0] in Package: Package_857_for_KB4019264~31bf3856ad364e35~amd64~~6.1.1.3, Update: 4019264-3005_neutral_LDR [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CBS    Failed to execute execution update. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CBS    Failed to execute execution package: Package_857_for_KB4019264~31bf3856ad364e35~amd64~~6.1.1.3 [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CBS    Failed to prepare execution [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CSI    0000000e@2017/6/18:13:31:49.595 CSI Transaction @0xe8bc50 destroyed
    2017-06-18 14:31:49, Info                  CBS    Perf: InstallUninstallChain complete.
    2017-06-18 14:31:49, Info                  CBS    Failed to execute execution chain. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-18 14:31:49, Info                  CBS    WER: Generating failure report for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, status: 0x80004005, failure source: Execute, start state: Staged, target state: Installed, client id: WindowsUpdateAgent
    2017-06-18 14:31:49, Info                  CBS    Failed to query DisableWerReporting flag.  Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2017-06-18 14:31:49, Info                  CBS    Failed to add %windir%\winsxs\pending.xml to WER report because it is missing.  Continuing without it...
    2017-06-18 14:31:49, Info                  CBS    Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing.  Continuing without it...
    2017-06-18 14:31:53, Info                  CBS    Reboot mark refs: 0
    2017-06-18 14:31:53, Info                  CBS    SQM: Reporting package change for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, current: Staged, pending: Default, start: Staged, applicable: Installed, target: Installed, limit: Installed, hotpatch status: DisabledBecauseNoHotpatchPackagesInitiated, status: 0x0, failure source: Execute, reboot required: False, client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 1916, first merged sequence: 1916
    2017-06-18 14:31:53, Info                  CBS    SQM: Upload requested for report: PackageChangeBegin_Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, session id: 142859, sample type: Standard
    2017-06-18 14:31:53, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
    2017-06-18 14:31:53, Info                  CBS    SQM: Reporting package change completion for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, current: Staged, original: Staged, target: Installed, status: 0x80004005, failure source: Execute, failure details: "(null)", client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 1916, first merged sequence: 1916
    2017-06-18 14:31:53, Info                  CBS    SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2017-06-18 14:31:53, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, session id: 142862, sample type: Standard
    2017-06-18 14:31:53, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
    2017-06-18 14:31:53, Info                  CBS    Enabling LKG boot option
    2017-06-18 14:31:53, Info                  CBS    Exec: End: nested restore point - complete.
    2017-06-18 14:31:53, Info                  CBS    Restored system sleep block state: 0x80000000
    2017-06-18 14:31:54, Info                  CBS    Exec: Processing complete.  Session: 30599223_815784531, Package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6 [HRESULT = 0x80004005 - E_FAIL]

    Also I cannot run many of the Administrative Tools from the Control Panel. These fail with: 'Microsoft Management Console has stopped working'. 

    Chkdsk reports no errors, SURT reports no errors but has a couple of expired warnings in CheckSUR.log:
    (w) CSI Catalog Expired 0x800B0101 winsxs\Catalogs\ca64bfc2d908945b49aa5ebb689117da620ccbd536b71a6d3a8ab5a79e1a1639.cat sagesystemcontrols_1255b113b2b03444_12.1.93.0_dab06a2ea37ba405

    sfc /scannow reports no errors either. 

    I've even tried repairing Win7 from the original DVD but that reports no errors either.

    Suggestions welcome! 


    • Edited by MrHew Sunday, June 18, 2017 7:11 PM
    Sunday, June 18, 2017 3:35 PM

Answers

  • Just to let you know that the July Monthly Security roll-up (KB4025341) installed okay. Since it includes the previous months fixes then the initial problem doesn't need to be fixed. I guess it was a bug with last months rollup....

    Thanks to those who replied.
    • Marked as answer by MrHew Tuesday, July 11, 2017 10:23 PM
    Tuesday, July 11, 2017 10:23 PM

All replies

  • Hi,

    I want to confirm that did the issue occur before? Have you made any changes before the issue occurred?

    First of all, we could try turning it on in safe mode and clean boot with networking first, then try restart the update.

    Windows updates and service packs may fail to install if there are corruption errors. For example, an update might not install if a system file is damaged. The DISM or System Update Readiness tool may help you to fix some Windows corruption errors.

    Try fixing Windows Update errors by using the DISM or System Update Readiness tool:

    https://support.microsoft.com/en-us/kb/947821

    To automatically reset Windows Update components, run the appropriate Windows Update diagnostic, and then follow the on-screen instruction.

    How do I reset Windows Update components?

    https://support.microsoft.com/en-us/kb/971058

    For more about installation issue, this article can also help you.

    Installation of Service Pack 1 for Windows 7 fails with errors 0x8004a029 or 0x80004005 - E_FAIL

    https://support.microsoft.com/en-us/help/2530477/installation-of-service-pack-1-for-windows-7-fails-with-errors-0x8004a029-or-0x80004005---e-fail

    In addition, I also found several users who had the similar issue as yours, they gave the advices may help you, please refer to the link:

    Error 0x80004005 Window 10 update Failure

    https://answers.microsoft.com/en-us/windows/forum/windows_10-update/error-0x80004005-window-10-update-failure/156adfb8-e7e1-46fa-b5c6-cbd5dcfebbb9

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 20, 2017 2:32 AM
    Moderator
  • Hi,

    Thanks for your reply.

    There wasn't any problems before this update - other updates had installed fine. In fact I've even tried installing optional ones since and they work okay.
    Clean booting in safe mode makes no difference, the KB4022719 update still fails.

    I'd ran the SURT previously and it only reported a couple of expired warnings and no errors. I've done it a few times since and no errors were reported.
    I've been through the resetting the Windows Update components steps twice, including step 4, and the update still reports the same error. Changing the number of network filters makes no difference. The last link is essentially a subset of the steps to reset WU components but I tried it anyway and the error persists.

    So I've been through all of the steps in each of the links you gave and the problem is still there.

    My latest CBS.log has the following lines where the error number (0x80004005) appears:

    2017-06-21 19:50:47, Info                  CBS    TrustedInstaller service starts successfully.
    2017-06-21 19:50:47, Info                  CBS    SQM: Initializing online with Windows opt-in: False
    2017-06-21 19:50:47, Info                  CBS    SQM: Cleaning up report files older than 10 days.
    2017-06-21 19:50:47, Info                  CBS    SQM: Requesting upload of all unsent reports.
    2017-06-21 19:50:47, Info                  CBS    SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm, flags: 0x2 [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:50:47, Info                  CBS    SQM: Failed to start standard sample upload. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:50:47, Info                  CBS    SQM: Queued 0 file(s) for upload with pattern: C:\Windows\servicing\sqm\*_all.sqm, flags: 0x6
    2017-06-21 19:50:47, Info                  CBS    SQM: Warning: Failed to upload all unsent reports. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:50:47, Info                  CBS    No startup processing required, TrustedInstaller service was not set as autostart, or else a reboot is still pending.
    2017-06-21 19:50:47, Info                  CBS    NonStart: Checking to ensure startup processing was not required.

    and 4 minutes later...

    2017-06-21 19:54:15, Info                  CBS    Exec: Unprojecting Package: Package_857_for_KB4019264~31bf3856ad364e35~amd64~~6.1.1.3, Update: 4019264-3005_neutral_LDR, UninstallDeployment: amd64_eda40e1fb40c46c4a0ffb92f17a7cdf9_31bf3856ad364e35_6.1.7601.23789_none_9846d402a84d2203
    2017-06-21 19:54:15, Error                 CBS    Failed. Attempted to uninstall a version of a non-driver component that is not installed, version: 0X600011db15ced, component: amd64_microsoft-windows-m..do-backcompat-tlb60_31bf3856ad364e35_6.1.7601.23789_none_4b46113920e375d8, owner: Package_857_for_KB4019264~31bf3856ad364e35~amd64~~6.1.1.3.4019264-3005_neutral_LDR [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CBS    Failed to mergecomponent [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CBS    ComponentAnalyzerUninstallDeployment: Failed on update: 4019264-3005_neutral_LDR [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CBS    Failed to execute item[0] in Package: Package_857_for_KB4019264~31bf3856ad364e35~amd64~~6.1.1.3, Update: 4019264-3005_neutral_LDR [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CBS    Failed to execute execution update. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CBS    Failed to execute execution package: Package_857_for_KB4019264~31bf3856ad364e35~amd64~~6.1.1.3 [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CBS    Failed to prepare execution [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CSI    0000000e@2017/6/21:18:54:15.386 CSI Transaction @0x11eb360 destroyed
    2017-06-21 19:54:15, Info                  CBS    Perf: InstallUninstallChain complete.
    2017-06-21 19:54:15, Info                  CBS    Failed to execute execution chain. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Error                 CBS    Failed to process single phase execution. [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:15, Info                  CBS    WER: Generating failure report for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, status: 0x80004005, failure source: Execute, start state: Staged, target state: Installed, client id: WindowsUpdateAgent
    2017-06-21 19:54:15, Info                  CBS    Failed to query DisableWerReporting flag.  Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2017-06-21 19:54:15, Info                  CBS    Failed to add %windir%\winsxs\pending.xml to WER report because it is missing.  Continuing without it...
    2017-06-21 19:54:15, Info                  CBS    Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing.  Continuing without it...
    2017-06-21 19:54:15, Info                  CBS    Failed to add %windir%\inf\setupapi.dev.log to WER report because it is missing.  Continuing without it...
    2017-06-21 19:54:22, Info                  CBS    Reboot mark refs: 0
    2017-06-21 19:54:22, Info                  CBS    SQM: Reporting package change for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, current: Staged, pending: Default, start: Staged, applicable: Installed, target: Installed, limit: Installed, hotpatch status: DisabledBecauseNoHotpatchPackagesInitiated, status: 0x0, failure source: Execute, reboot required: False, client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 1955, first merged sequence: 1955
    2017-06-21 19:54:22, Info                  CBS    SQM: Upload requested for report: PackageChangeBegin_Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, session id: 142859, sample type: Standard
    2017-06-21 19:54:22, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
    2017-06-21 19:54:22, Info                  CBS    SQM: Reporting package change completion for package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, current: Staged, original: Staged, target: Installed, status: 0x80004005, failure source: Execute, failure details: "(null)", client id: WindowsUpdateAgent, initiated offline: False, execution sequence: 1955, first merged sequence: 1955
    2017-06-21 19:54:22, Info                  CBS    SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2017-06-21 19:54:22, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6, session id: 142862, sample type: Standard
    2017-06-21 19:54:22, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
    2017-06-21 19:54:22, Info                  CBS    Enabling LKG boot option
    2017-06-21 19:54:22, Info                  CBS    Exec: End: nested restore point - complete.
    2017-06-21 19:54:22, Info                  CBS    Restored system sleep block state: 0x80000000
    2017-06-21 19:54:22, Info                  CBS    Exec: Processing complete.  Session: 30599871_2341863360, Package: Package_for_RollupFix~31bf3856ad364e35~amd64~~7601.23833.1.6 [HRESULT = 0x80004005 - E_FAIL]
    2017-06-21 19:54:22, Info                  CBS    Session: 30599871_3418044914 initialized by client WindowsUpdateAgent.
    2017-06-21 19:54:32, Info                  CBS    Trusted Installer signaled for shutdown, going to exit.


    It seems to me that there are two sources of the error (0x80004005). 
    Firstly it's the 'SQM: Failed to start upload with file pattern: C:\Windows\servicing\sqm\*_std.sqm.'' 

    I'm unsure as to why this causes a problem. I have another desktop machine running W7 Ultimate which I updated without issue. It also doesn't have anything in the sqm directory but an error isn't thrown in it's case.

    The second source is 'CBS Failed. Attempted to uninstall a version of a non-driver component that is not installed'. This may have something to do with the line Package_857_for_KB4019264 which seems to refer to a Security Update (KB4019264) installed a few weeks ago.

    I've no idea what to try next but suggestions would be much appreciated...

    Regards
    Michael


    • Edited by MrHew Thursday, June 22, 2017 8:27 PM
    Wednesday, June 21, 2017 7:48 PM
  • Hi,

    We haven’t heard from you for a couple of days, have you solved the problem? We are looking forward to your good news.

    Best Regards,

    Tao


    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, June 27, 2017 8:41 AM
    Moderator
  • Hi,

    No, not been able to solve the problem yet. I'm still looking for inspiration from the forum (see my latest post on trying the steps you suggested) as I'm at a loss as to what to try next.

    As I mentioned previously, other optional updates work okay, it's just KB4022719 which fails.

    I've sent the information from the Action Center to MS so maybe something will come from that and will try some more radical things if the forum doesn't come through...

    Thanks

    Michael


    Tuesday, June 27, 2017 10:40 AM
  • OK, we are looking forward to your good news:)

    Please remember to mark the replies as answers if they help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, June 28, 2017 1:08 AM
    Moderator
  • Just to let you know that the July Monthly Security roll-up (KB4025341) installed okay. Since it includes the previous months fixes then the initial problem doesn't need to be fixed. I guess it was a bug with last months rollup....

    Thanks to those who replied.
    • Marked as answer by MrHew Tuesday, July 11, 2017 10:23 PM
    Tuesday, July 11, 2017 10:23 PM