locked
Auto mapping of shared mailboxes 2016 and 2010 in coexistence RRS feed

  • Question

  • Hi

    My situation is that we have a 2010 environment up and running, now we have added 2016 servers. Everything seems to work as expected except auto mapping of shared mailboxes.

    Users in 2016 that has been granted full access (with auto mapping enabled) to mailboxes located in 2016 gets them connected automatically, but not shared mailboxes that remains in 2010.

    User in 2010 that has been granted full access (with auto mapping enabled) gets mailboxes located in both 2010 and 2016 connected automatically.

    Both 2010 and 2016 users are using autodiscover from 2016 as it should be, in all situations except when a 2016 user has access to a 2010 mailbox I can see the AlternativeMailbox in the result from autodiscover.

    Is this supposed to work?

    Thanks 
    Peter

    Friday, September 30, 2016 11:40 AM

Answers

  • Yes

    This is the current setting on 2016 servers

    ExternalClientAuthenticationMethod : Ntlm
    InternalClientAuthenticationMethod : Ntlm
    IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}
    XropUrl                            :
    ExternalClientsRequireSsl          : True
    InternalClientsRequireSsl          : True

    Thanks
    Peter

    Hi,

    Try to set InternalClientsRequireSSL to false. Remove full access permission on shared mailbox in exchange 2010 for exchange 2016 users. Then re-add full access permission:

    Add-MailboxPermission <Shared mailbox in exchange 2010> -User <User in exchange 2016> -AccessRights "FullAccess" -AutoMapping $true

    Re-configure outlook profile for users in exchange 2016.

    By the way, are users using the same version of outlook?


    Regards,

    Lynn-Li

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Lynn-Li Monday, October 10, 2016 10:00 AM
    • Marked as answer by Lynn-Li Tuesday, October 11, 2016 1:27 PM
    Monday, October 3, 2016 3:15 AM

All replies

  • It should be supported.

    did you already set the external authentication to NTLM instead of negotiate if not please see the below artical.

    https://support.microsoft.com/en-us/kb/2834139

    Friday, September 30, 2016 12:03 PM
  • Should this be set on the 2016 servers or 2010 CAS servers?

    I can add the shared mailbox manually in the situation that it is not provided by autodiscover, so logon and access to the mailbox works

    Thanks
    Peter

    Friday, September 30, 2016 12:11 PM
  • It should be set on exchange 2016 CAS server.
    Friday, September 30, 2016 1:10 PM
  • Yes

    This is the current setting on 2016 servers

    ExternalClientAuthenticationMethod : Ntlm
    InternalClientAuthenticationMethod : Ntlm
    IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}
    XropUrl                            :
    ExternalClientsRequireSsl          : True
    InternalClientsRequireSsl          : True

    Thanks
    Peter

    Friday, September 30, 2016 1:25 PM
  • Yes

    This is the current setting on 2016 servers

    ExternalClientAuthenticationMethod : Ntlm
    InternalClientAuthenticationMethod : Ntlm
    IISAuthenticationMethods           : {Basic, Ntlm, Negotiate}
    XropUrl                            :
    ExternalClientsRequireSsl          : True
    InternalClientsRequireSsl          : True

    Thanks
    Peter

    Hi,

    Try to set InternalClientsRequireSSL to false. Remove full access permission on shared mailbox in exchange 2010 for exchange 2016 users. Then re-add full access permission:

    Add-MailboxPermission <Shared mailbox in exchange 2010> -User <User in exchange 2016> -AccessRights "FullAccess" -AutoMapping $true

    Re-configure outlook profile for users in exchange 2016.

    By the way, are users using the same version of outlook?


    Regards,

    Lynn-Li

    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    • Proposed as answer by Lynn-Li Monday, October 10, 2016 10:00 AM
    • Marked as answer by Lynn-Li Tuesday, October 11, 2016 1:27 PM
    Monday, October 3, 2016 3:15 AM
  • Please refer to below links might helps you to get in more detailed:

    https://kb.intermedia.net/article/2582

    http://www.stevieg.org/2010/08/auto-mapping-shared-mailboxes-in-exchange-2010-sp1-with-outlook-2010/

    Also try to use the Exchange 2010 management console to add the full control to the 2010 mailbox.

    Client Connectivity in an Exchange 2016 Coexistence Environment with Exchange 2010:
    https://blogs.technet.microsoft.com/exchange/2015/10/26/client-connectivity-in-an-exchange-2016-coexistence-environment-with-exchange-2010/

    Hope this helps!


    Migrate mailboxes, Public Folders, Outlook profiles and rules and GAL etc. to-and-fro Exchange Servers and Office 365 with LepideMigrator for Exchange


    Monday, October 3, 2016 7:36 AM