none
DPM 2016 after switching to MBS, no backups to secondary DPM possible anymore

    Question

  • Hi,

    in my test bed for DPM 2016 I ran into problems with a Primary / Secondary setup when utilizing Modern Backup Storage.

    Setup:
    Primary DPM 2016 UR1 on Server 2016, using MBS and the old storage method in parallel (to test if a smooth migration is possible)
    Secondary DPM 2016 UR1 on Server 2016, using MBS

    When I create a new or modify an existing protection group on the secondary, I can see the Primary DPM as an available member. Expanding it, I can see the HyperV Cluster and when expanding the Cluster, I can see all protected VMs from the Primary.

    However, when I try to expand a VM, I can only expand the VMs which are still backed up on the old "legacy" storage. For every VM which is backed up on the Primary on the MBS, I get this message after a few seconds:

    "DPM was unable to get the list of data sources on <protected source> that are protected by the Primary DPM Server <Primary>.
    Make sure that <Primary> is protecting the data sources for which you want to set this DPM Server as the secondary Server. If the Problem persists, restart the DPMWriter Service on <Primary>. ID 33119"

    This only happens for VMs stored on MBS on the Primary. VMs stored on the legacy storage on the Primary can be backed up on the secondary.

    When trying to expand the VM in the Modify / Create Group wizard, the moment I click on the + and watch the Event logs of the HyperV host where the VM is currently residing, I can see Audit Success messages in the security log coming from the Secondary DPM. So these systems are talking. But I don´t see any error messages on the Primary, Secondary or the HyperV Host.

    Tuesday, December 27, 2016 12:42 PM

All replies

  • I have the same issue here. We have had an open ticket with MSFT for a few weeks now while they try to reproduce the issue. I did get a call back but I was not available so I'm hoping that they might be onto something.
    Wednesday, December 28, 2016 7:15 PM
  • Thank you very much for your reply. Somehow Alert me did not work, so I only came back today to see that you replied to my post.

    Now you made me very curious and if it´s possible to share what they have to tell, I would appreciate it very much if you could let me know.

    Seeing how much space MBS saves compared to the old storage method, it would be great if I don´t need to switch back.

    Thanks again and a happy new year!


    Monday, January 2, 2017 3:28 PM
  • Also interesting to hear MS comments about this issue. 
    Thursday, January 5, 2017 2:56 PM
  • i have the same issue

    any news?

    Tuesday, January 10, 2017 10:37 PM
  • Hello, 

    Has this been resolved? Anyone? We're literally having the same issue.

    Thanks
    Monday, January 16, 2017 8:29 PM
  • I did not hear any news and so far I have not found a solution either. I really hope P_Brock has some good news.
    Tuesday, January 17, 2017 3:23 PM
  • We followed the MS documentation on this precisely: https://technet.microsoft.com/en-us/system-center-docs/dpm/get-started/upgrade-to-dpm-2016?f=255&MSPPError=-2147217396

    It was suggested that this may occur using 'legacy' storage, but we're using MBS throughout. 

    We also made a couple extra changes. Unsure if these matter in the context of ID 33119:

    1. Renamed the secondary server. Originally this produced DCOM errors but have since been resolved between itself and the primary. Agents have connectivity and read "OK". But of course PG creation on the secondary server produces error ID 33119.

    2. Instead of doing a clean install for Server 2016, we simply upgraded it. Not sure if this was supported or if it makes any difference here regarding DPM.

     
    Tuesday, January 17, 2017 5:04 PM
  • Hello Microsoft & DPM friends,

    So, we "resolved" the situation here regarding ID 33119 - and you probably aren't going to like it..

    We concluded, at least in our case, and possibly yours, is that the primary server was bugged. We don't know why and couldn't fix the primary itself, but concluded for sure that it was the problem. 

    A secondary test VM was created to try and copy from the primary server - that failed with ID 33119- but we could use this test VM to copy from the secondary server. Therefore everything was transferred over to the VM and that will be our primary server and the secondary will remain as the secondary. 

    HTH.
    Thursday, January 19, 2017 5:15 PM
  • Still working with MSFT support on this. The issue of trying to backup a primary MBS protection group on a secondary and not getting it to work seems to be a well known problem by now and easily reproduced. Support can't verify if UR2 is going to fix this or not and they continue to look at our system. At this point I think it might be just a waiting game for the fix to come out of development.
    Saturday, February 4, 2017 12:04 AM
  • Thank you P_Brock for keeping us posted on that matter. I appreciate that very much :-)
    Wednesday, February 8, 2017 2:35 PM
  • We applied UR2 yesterday and while it did resolve a few problems it did not resolve this specific issue of backing up modern storage protected groups to the secondary DPM server.
    Wednesday, February 8, 2017 5:24 PM
  • Looks that this issue will be fixed only with next UR. 

    https://blogs.technet.microsoft.com/dpm/2017/02/09/announcing-sc-2016-dpm-guest-blog-series/

    Friday, February 17, 2017 2:43 PM
  • Hi,

    you can try to delete all Files under "%Program Files%\Microsoft System Center 20xx\DPM\DPM\Active Owner" and then retry to add the Protection Source on the Secondary Server.

    The Files will be recreated at the next Backup Job. 

    lg

    Amon



    • Edited by Amon Gernig Monday, February 20, 2017 3:21 PM
    Monday, February 20, 2017 3:09 PM
  • Hello,

    Can you please check if the dpmwriter service is running on the Primary DPM servers?

    Thanks,
    Aditi Gangwar.

    Thursday, March 30, 2017 6:23 AM
  • Hi there,

    I have checked the dpmwriter service on our Primary DPM server and it is running, is this the workaround mentioned in the Announcing SC 2016 DPM Guest Blog Series comments?

    I see update Rollup 3 is out for System Center but under the DPM section is reports "There are no updates to this component in this rollup".

    Has anyone got this working?

    Thanks

    Tuesday, May 30, 2017 5:15 AM
  • This is a known bug with DPM 2016 and the official fix should be released with UR4. You can contact Microsoft Support for the private fix. 

    Regards


    MCSE, MCSA, MS, MCP, MCTS, System Engineer

    Tuesday, May 30, 2017 10:40 AM
  • Great thanks for the update
    Wednesday, May 31, 2017 1:49 AM
  • We have the same problem, when will fix be released?
    Monday, October 9, 2017 12:31 PM
  • Great news, UR4 was released

    MCSE, MCSA, MS, MCP, MCTS, System Engineer

    Wednesday, October 25, 2017 12:10 PM
  • But it still doesn't work here.

    EDIT: From my production server, upgraded from 2012R2 I am not able to backup MBS protection groups to secondary DPM. From a freshly installed Test DPM server I am able to backup MBS to secondary.

    Wednesday, October 25, 2017 5:35 PM
  • Here still problem, and MBS not working for us, jobs are very slow.
    Tuesday, October 31, 2017 1:57 PM
  • Hi, Has this been resolved?  I'm having the same issue.  On UR5.

    Wednesday, May 9, 2018 6:40 PM