none
Exchange 2010 autodiscover issue in Windows 7 RRS feed

  • Question

  • Hi guys,

    The issue I am seeing is really bizzare and I have been working on this for the last few days with no luck. I wonder if anyone can give me some pointers?

    We are in the middle of a transition from Exchange 2003 to 2010, some users running on Windows 7 and some (mostly) on XP.

    With the XP users, autodiscover is working fine. Test E-mail Auto Configuration successfully succeeds in finding the autodiscover service and consequently, Out Of Office works fine and also downloading the offline address book. However, the Windows 7 users get an error when running the test e-mail Auto Configuration .....autodiscover.xml Failed (0x80072F78). Consequently the offline address book down load fails with ....object cannot be found error 0x8004010F and OOF returns 'your automatic reply settings cannot be displayed because the server is currently unavailable. Try again later.'

    Test-OutlookWebServices returns (see below). All looks good!

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1019
    Type       : Information
    Message    : A valid Autodiscover service connection point was found. The Autodiscover URL on this object is https://em
                 ail2.surreyheath.gov.uk/Autodiscover/Autodiscover.xml.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1006
    Type       : Information
    Message    : Contacted the Autodiscover service at https://email2.surreyheath.gov.uk/Autodiscover/Autodiscover.xml.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1016
    Type       : Information
    Message    : [EXCH] The AS is configured for this user in the Autodiscover response received from https://email2.surrey
                 heath.gov.uk/Autodiscover/Autodiscover.xml.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1015
    Type       : Information
    Message    : [EXCH] The OAB is configured for this user in the Autodiscover response received from https://email2.surre
                 yheath.gov.uk/Autodiscover/Autodiscover.xml.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1014
    Type       : Information
    Message    : [EXCH] The UM is configured for this user in the Autodiscover response received from https://email2.surrey
                 heath.gov.uk/Autodiscover/Autodiscover.xml.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1022
    Type       : Success
    Message    : Autodiscover was tested successfully.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1024
    Type       : Success
    Message    : [EXCH] Successfully contacted the AS service at https://email2.surreyheath.gov.uk/EWS/Exchange.asmx. The e
                 lapsed time was 77 milliseconds.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1026
    Type       : Success
    Message    : [EXCH] Successfully contacted the UM service at https://email2.surreyheath.gov.uk/EWS/Exchange.asmx. The e
                 lapsed time was 55 milliseconds.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1124
    Type       : Success
    Message    : [Server] Successfully contacted the AS service at https://email2.surreyheath.gov.uk/ews/exchange.asmx. The
                  elapsed time was 120 milliseconds.

    RunspaceId : 5ba81f1f-b2b5-425a-8523-e6f90ee779d0
    Id         : 1126
    Type       : Success
    Message    : [Server] Successfully contacted the UM service at https://email2.surreyheath.gov.uk/ews/exchange.asmx. The
                  elapsed time was 28 milliseconds.

    Is this a certificate problem? We are using a self signed certificate, but why do XP users experience no issues??

    Any help would be much appreciated.

    Cheers

    Robert

     

     



    Thursday, June 9, 2011 4:11 PM

Answers

All replies

  • SSL certificates can be an issue, and I wouldn't recommend their use. Not when you can get a commercial SSL certificate for less than $80/year, I don't think council tax payers would object.

    The self signed certificate that Exchange creates is also not supported for Outlook Anywhere or ActiveSync, so if you intend to use either of those you need to change to a commercial certificate.

    The error code is a connection failure, and the other codes are similarly related.
    However OAB is unconnected to autodiscover, so would tend to indicate a general connection issue.

    Can you browse to the server?

    Simon.

     


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Thursday, June 9, 2011 7:17 PM
  • From Outlook, run a "Test-Email Configuration" from one of your Windows 7 clients and just choose "Use AutoDiscover".  Confirm that the default E-mail address is the users valid email.  Take a look at the Log and XML tabs and make sure the URLs are valid.  There is an Outlook 2007 bug where the wrong E-mail address is used for AutoDiscover.  For example, if my AD domain is addomain.com and my email domain is emaildomain.com, it would try to use eric@addomain.com instead of eric@emaildomain.com.  This will normally cause an issue with AutoDiscover.
    Thursday, June 9, 2011 9:59 PM
  • Hello rmturpie,

    One thing you will notice from Exchange 2003, is the way it handled Offline Address Books etc. Exchange 2007 and Exchange 2010 is created so that the autodiscover needs a little bit of tweaking with DNS records to get it to work correctly to pull down the Offline Address Book, Out of Office and also fix the Free / Busy from within Outlook. This normally generates as you say the error 0x8004010F and disallows you to do certain things.

    If your Autodiscover is testing correctly, the fix for this is by adding an SRV record to your DNS.

    Something like;

    _autodiscover._tcp.domainname SRV 0 5 443 exchange.servername.com

    This will then allow Outlook to go off and get the xml file it needs to get connected to the exchange server.

    Also you may want to remove the following records you have such as;

    Wildcard domain (like anything.domain.com) and also autodiscover.domain.com (usually a CNAME to your server address).

    Regards

    CJ.

    Thursday, June 9, 2011 10:23 PM
  • Hello rmturpie,

    One thing you will notice from Exchange 2003, is the way it handled Offline Address Books etc. Exchange 2007 and Exchange 2010 is created so that the autodiscover needs a little bit of tweaking with DNS records to get it to work correctly to pull down the Offline Address Book, Out of Office and also fix the Free / Busy from within Outlook. This normally generates as you say the error 0x8004010F and disallows you to do certain things.

    If your Autodiscover is testing correctly, the fix for this is by adding an SRV record to your DNS.

    Something like;

    _autodiscover._tcp.domainname SRV 0 5 443 exchange.servername.com

    This will then allow Outlook to go off and get the xml file it needs to get connected to the exchange server.

    Also you may want to remove the following records you have such as;

    Wildcard domain (like anything.domain.com) and also autodiscover.domain.com (usually a CNAME to your server address).

    Regards

    CJ.


    That information isn't actually correct.
    Internally no DNS changes are required, unless you modify the configuration of the autodiscover URI value on the client access server. The autodiscover URL will be set to the server's internal FQDN, and in most deployments that doesn't need to be changed.

    Externally, most places will use autodiscover.example.com rather than SRV records, as SRV records are not supported by many DNS providers. I have never used SRV records internally because it simply isn't required. Furthermore, even if you do set the SRV records internally, Outlook clients that are installed on machines that are members of the domain will not use them. They get their autodiscover information from the domain, not an autodiscover DNS lookup.

    I don't think changing the DNS records are going to resolve this issue, certainly not for internal users.

    Simon.


    Simon Butler, Exchange MVP
    Blog | Exchange Resources | In the UK? Hire Me.
    Friday, June 10, 2011 11:53 AM
  • Hello Robert,

     

    Since this issue occurs intermittently, the issue may be mainly related to the client side.

     

    When the issue happens, please manually access the autodiscover url in IE and see if it can be access successfully. Let us know of if you receive any certificate warnings or error code.

     

    You can also check the IIS log to see the detailed error code of those failed autodiscover requests from the Win7 clients.

     

    Thanks,

    Simon

     

    Monday, June 13, 2011 2:48 AM
    Moderator
  • Hi Robert,

     

    Is there any update on this issue?

     

    Thanks,

    Simon

    Wednesday, June 15, 2011 1:38 AM
    Moderator
  • Hi Robert,

     

    Is there any update on this issue?

     

    Thanks,

    Simon


    Hi Guys/Simon,

    I think I have finally got to the bottom of this.

    It turned out to be the autodiscover service url. This was
    https://email2.surreyheath.gov.uk/Autodiscover/Autodiscover.xml
    I changed this to https://email2/Autodiscover/Autodiscover.xml and the autodiscover service started working.

    I changed the OOF URL from https://email2.surreyheath.gov.uk/EWS/exchange.asmx to https://email2/EWS/exchange.asmx and I could finally see the Out of Office assistant.

    Not sure why it was working in XP workstations and not Windows 7 but hey its now working for both so I'm a happy bunny!

    Cheers for the help.

    Robert

     

    Wednesday, June 15, 2011 9:32 AM
  • Hello Robert,

     

    Thank you for your time on this issue and sharing the final solution with us. I will mark your solution as the answer and I believe this will be helpful for other people also.

     

    Thanks,

    Simon

    Friday, June 17, 2011 8:33 AM
    Moderator
  • rmturpie,

    Thank you for figuring that out.  Modifying those two URLs by removing the domain.com fixed the Outlook 2007 (Windows 7) issue of some of my users being continually prompted to enter their password as well as being unable to download the offline address book and use the out of office assistant.  We have 200 users in the company and only about 5 were affected.  Still not sure what the underlying issue was.  I believe it stems from security settings in AD for those specific users but I couldn't find out exactly what.

    Thanks again,

    -ruit

    Thursday, July 14, 2011 2:33 PM