locked
OWA keeps prompting for username and password RRS feed

  • Question

  • We have Exchange 2003 (SP2) running on Server 2003 (SP2) and OWA seems (on the whole) to be running fine but this morning one user called in to say they keep getting prompted for their username and password. They can log in OK and see their mailbox but if they try to do anything (read mail, delete mail etc) they get prompted for their log in again and it will not let them do what they want to do.

     

    Seems like some kind of permissions thing but I'm not sure what as other users seem fine AND it only seems to behappening externally (I can login using the users login credentials to OWA internally and it works fine!).

    .

    Any ideas are appreciated

    Wednesday, October 24, 2007 10:30 AM

Answers

  • Richard,

    make sure that client machine doesnt have the IE security setting that requires to prompt for username and password.

     

     

    Wednesday, October 24, 2007 6:10 PM

All replies

  • OK...update time...seems like this may be only happening on one PC or from one remote location (I was able to check it from an external source and it works fine). So are there any settings on an XP PC that I should be getting the user to check?

    Wednesday, October 24, 2007 1:57 PM
  • Richard,

    make sure that client machine doesnt have the IE security setting that requires to prompt for username and password.

     

     

    Wednesday, October 24, 2007 6:10 PM
  • Something regarding OWA authentication -

     

    I setup OWA in the EX 2007 as a whole - using one server only - I setup OWA to use windows integrated authentication and also to digest the autenthication. Also set it up in IIS - the reason why I set it up like that is becuase I would like the users to be able to go to straight to their mailbox without typing user/pass. I did everything MS Exchange guide on the site and it still prompting user for authentication. Is there something not working properly in 2007? or am I missing something?

     

    thanks for the help guys!

     

    Wednesday, October 24, 2007 8:29 PM
  • Are you using OWA internally or are there clients outside your network that are having to enter their username / password to get access?

    Friday, October 26, 2007 2:05 PM
  • Hey,

    For Integrated Authentication to work, the users must be working on computers and user accounts that are part of your domain.

    Assuming they are. it sounds like a Internet Explorer security issue.  Make sure the Intranet is trusted.

    Go to:

    Internet Explorer > Properties > Security (tab)

    Select 'Local intranet' from 'Select a zone to view or change security settings.' and click 'Sites'.

    If IE7 disable 'Automatically detect intranet network'

    Check off 'Include all local (intranet) sites not listed in other zones'
    Check off 'Include all sites that bypass the proxy server'
    Check off 'Include all network paths (UNCs)

     

    Hope this helps,

    Mike Clarke
    http://mystyleit.com
    CLS, WSCP, MCP, MCTS, MCSA+M, MCSE+M

    Friday, October 26, 2007 2:56 PM

  • Still not luck. This is what I have setup at this moment

    OWA on https://webmail.xxxxx.com/owa

    IIS: Web Sites on Digest and integrated authentication
    Exchange 2007: is on Digest and Integrated authentication.

    IE on local machine - everythign is setup as Mike mentioned above.

    Still asking for username and password.

    Thanks all.

    Tuesday, October 30, 2007 12:31 PM
  •  

    Ok is this was fixed a while ago. Make sure the integraded authentication is set on IIS and that the firewall is set properly so users can connect. Also make sure that those setting are ported to Exchange
    Friday, March 14, 2008 8:26 PM