locked
Lync Mediation server calls via edge server not working RRS feed

  • Question

  • Hi,

    I have enabled co-located Mediation on one of my Lync FE servers in a branch site.  The PSTN gateway is a Cisco 2801 router.  Calls from Lync clients on the LAN via this mediation server are running fine.  The legacy OCS FE for this site has been decommissioned as has the OCS Mediation server.

    Calls from Lync clients via the Lync Edge server are failing with “Call failed due to network issues”.  Calls out other gateways still running the OCS Mediation servers are connecting ok, so I am confident it isn’t a firewall rule issue (unless Lync Mediation requires some different ports?).

    So :

    Lync Client on LAN to PSTN =ok

    Lync Client on internet via Edge to Lync Client on LAN =ok

    Lync Client on internet via Edge to PSTN via OCS Mediation = ok

    Lync Client on internet via Edge to PSTN via Lync Mediation = Failed

     

    The call rings through and is answered but the voice session cannot start.

    Here is a SIP Log from the Mediation server:

    (0000000002DC4D31)$$START-MEDIATIONSERVER

    MediationCall: a29d6ee146e34e169dcfa5f4576a8729

    CallId: 2e73e1f7aff845f8ad083167c1f80de2

    From: sip:testuser@sipdomain.com

    To: sip:+64800838383@sipdomain.com;user=phone

    Direction: Outbound

    Start-Line: Proxy side invite dialog established successful, Remote participant uri: sip:testuser@sipdomain.com, Local participant uri: sip:+64800838383@sipdomain.com;user=phone

    $$END-MEDIATIONSERVER

     

    (0000000000239372)$$START-MEDIATIONSERVER

    MediationCall: a29d6ee146e34e169dcfa5f4576a8729

    CallId: 2e73e1f7aff845f8ad083167c1f80de2

    From: sip:testuser@sipdomain.com

    To: sip:+64800838383@sipdomain.com;user=phone

    Direction: Outbound

    Start-Line:  ICEv19 RtpEndpoint [54111058] Connectivity EndpointEvent: ConnectivityChecksCompleted; Status: OperationFailed; DiagnosticsBlob: [ICEWarn=0x1120,LocalSite=<mediationIP>:56920,LocalMR=10.55.1.173:448,RemoteSite=118.93.215.228:16011,RemoteMR=<EdgeServerIP>:51381,PortRange=49152:57500,RemoteMRTCPPort=51381,LocalLocation=2,RemoteLocation=1,FederationType=0]

    $$END-MEDIATIONSERVER

     

    (0000000002DC4D31)$$START-MEDIATIONSERVER

    MediationCall: a29d6ee146e34e169dcfa5f4576a8729

    CallId: 2e73e1f7aff845f8ad083167c1f80de2

    From: sip:testuser@sipdomain.com

    To: sip:+64800838383@sipdomain.com;user=phone

    Direction: Outbound

    Start-Line: ProxyCall SignalingState is disconnected, reason is: TerminatedRemotely

    $$END-MEDIATIONSERVER

     

    (0000000002DC4D31)$$START-MEDIATIONSERVER

    MediationCall: a29d6ee146e34e169dcfa5f4576a8729

    CallId: 2e73e1f7aff845f8ad083167c1f80de2

    From: sip:testuser@sipdomain.com

    To: sip:+64800838383@sipdomain.com;user=phone

    Direction: Outbound

     

    (0000000003EF2637)$$START-MEDIATIONSERVER

    MediationCall: a29d6ee146e34e169dcfa5f4576a8729

    CallId: 2e73e1f7aff845f8ad083167c1f80de2

    From: sip:testuser@sipdomain.com

    To: sip:+64800838383@10.51.1.8:5070;user=phone;maddr=o2akl-lcs01.sipdomain.com

    Direction: Outbound

    Start-Line: Mediation Call Terminate successfully.

    $$END-MEDIATIONSERVER

    Start-Line: Send back P-Asserted-Identity header to Proxy with displayname: "[none]" value: <sip:+64800838383@sipdomain.com;user=phone>

    $$END-MEDIATIONSERVER

     

    (0000000002DC4D31)$$START-MEDIATIONSERVER

    MediationCall: a29d6ee146e34e169dcfa5f4576a8729

    CallId: 2e73e1f7aff845f8ad083167c1f80de2

    From: sip:testuser@sipdomain.com

    To: sip:+64800838383@sipdomain.com;user=phone

    Direction: Outbound

    Start-Line: Terminating Proxy side call with session state: Disconnected, sip-response: 200, ms-diag: 4294967295, ms-diag reason: NULL.

    $$END-MEDIATIONSERVER

     

    Any advice on what could be causing this issue?

    Thanks

     

    Tuesday, March 22, 2011 10:45 PM

Answers

All replies

  • James -

    could you verify the following:

    * Are there any HLB in the configuration? If so, are the correct ports open on that?
    * Are the Certificates valid between the Lync  
    * is IPv 6 enabled on the Lync Mediation server? If so , can you disable that?
    * Is the Lync Mediation server added to the Voice route?

    Can you gather the log from the Edge server as well.

     

    Jim

    Wednesday, March 23, 2011 1:22 AM
  • Hi, the public NAT IP wasn't entered in the Edge server configuration.  After entering it these calls have started working.  I'm not sure why they were connecting via the OCS Mediation servers ok without this setting, but it has solved the problem.

    Solution found by reading this thread: http://social.technet.microsoft.com/Forums/en/ocsedge/thread/522e7f53-d0d4-4b08-9917-45b80a292963

    • Marked as answer by James Bellaart Wednesday, March 23, 2011 7:37 PM
    Wednesday, March 23, 2011 3:45 AM