none
windows store fails to open Dec 2017 RRS feed

  • Question

  • Hi, I am running windows 8.1 pro on a toshiba S855 Satellite.  The windows store app stopped working a while back.  I have tried a variety of fixes found on the net (like WSrest, and powershell -ExecutionPolicy Unrestricted Add-AppxPackage -DisableDevelopmentMode -Register $Env:SystemRoot\WinStore\AppxManifest.xml, none have fixed the problem.

     If I click on the winstore exe icon in the winstore folder I get the following message in a popup

    script: C:windows\winstore\winstore.js

    line: 15

    Char: 1

    Error: Expected identifier, string or number

    Code: 800A0404

    Source: Microsoft JScript compilation error

    If I try to start winstore by typing, start "" "ms-windows-store:"  in a command prompt I get the following message,  "the remote procedure call failed.

     I did also try going back in time with a restore thinking that a windows update may have caused the problem but that did not solve it.

    Ted

     

    Wednesday, December 6, 2017 3:54 PM

All replies

  • Hi try this command in powershell to reinstall the store app;

    Get-AppxPackage -allusers Microsoft.WindowsStore | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}

    Wednesday, December 6, 2017 3:59 PM
  • Thanks for your time.

      I tried the command you provided and got this response  "‘Get-AppxPackage’  is not recognized as an internal or external command".  You'd think that Microsoft would make it very easy to install/reinstall WinStore since it can be a money maker.

    Thanks for the try.  Ted


    Wednesday, December 6, 2017 11:47 PM
  • hi just to confirm you tried this in powershell and not command promt?
    Thursday, December 7, 2017 9:01 AM
  • Hi, I ran it both ways, here is what resulted using powershell

    Get-AppxPackage : Access is denied.

    Access is denied.

    At line:1 char:1

    + Get-AppxPackage -allusers Microsoft.WindowsStore | Foreach {Add-AppxPackage -Dis ...

    + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

        + CategoryInfo          : NotSpecified: (:) [Get-AppxPackage], UnauthorizedAccessException

        + FullyQualifiedErrorId : System.UnauthorizedAccessException,Microsoft.Windows.Appx.PackageManager.Commands.GetApp

       xPackageCommand

    Thursday, December 7, 2017 1:48 PM
  • in start type wsreset and run that file after about 5 6 seconds try the store app again
    Thursday, December 7, 2017 1:55 PM
  • wsreset did not help.
    Friday, December 8, 2017 12:02 AM
  • On Windows 10, fall update, same issue. Attempted all suggested solutions, no joy.

    Tuesday, December 19, 2017 3:33 AM
  • I found a program that fixed my problem.  I used    http://www.tweaking.com/     worked great.  Thanks to those who tried to help.

    Sunday, December 31, 2017 10:05 PM
  • download and run   http://www.tweaking.com/    It fixed the problem for me.
    Sunday, December 31, 2017 10:06 PM