locked
Outgoing mails are going with old email ID in OWA. How to change it to the New mail ID? RRS feed

  • Question

  • Hi,

    We have changed our company name recently. One of our users is facing an issue with his outgoing mails with OWA.

    When he sends mails, they are going with old email ID rather than the new mail ID. His account settings are as normal as other users who are able to send mails with the new mail ID.

    When I try to type a user name at To address bar, it is showing old email id of that user rather than new one, if I chek the names then it comes the new mail ID.

    Please help me to solve these issues.

    Regards,

    Ram.


    Ramakrishna

    Tuesday, July 24, 2012 2:07 PM

Answers

  • It's likely resolving to the old legacyexchangedn. What you can do is update the legacyexchangedn and replace it with the new name, but before you do that you need to save the old legacyexchangedn and add it as an x500 address.

    1. open adsiedit from the run menu (windows support tools)

    expand domain, keep expanding and find your user, right click properties and find the attribute legacyexchangedn

    http://www.msexchange.org/tutorials/Understanding-LegacyExchangeDN.html

    It will look like /o=microsoft/ou=northamerica/cn=Recipients/cn=James Chong

    Save this value into notepad than

    change it to the new name /o=microsoft/ou=northamerica/cn=Recipients/cn=new name

    Now go into the mailbox properties of the user mailbox, email address tab. Add a new custom email address and email address type the original legacyexchangedn o=microsoft/ou=northamerica/cn=Recipients/cn=James Chong and email  type enter x500


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Proposed as answer by Xiu Zhang Tuesday, July 31, 2012 6:19 AM
    • Marked as answer by Xiu Zhang Monday, August 6, 2012 2:42 AM
    Tuesday, July 24, 2012 2:19 PM
  • When I try to type a user name at To address bar, it is showing old email id of that user rather than new one, if I chek the names then it comes the new mail ID.

    Please help me to solve these issues.

    Regards,

    Ram.


    Ramakrishna

    Clear the AutoComplete Cache.
    If you are on Exchange 2007/2010 you can do that in OWA Light.

    Martina Miskovic

    • Proposed as answer by Xiu Zhang Tuesday, July 31, 2012 6:19 AM
    • Marked as answer by Xiu Zhang Monday, August 6, 2012 2:42 AM
    Tuesday, July 24, 2012 3:06 PM
  • When I try to type a user name at To address bar, it is showing old email id of that user rather than new one, if I chek the names then it comes the new mail ID.

    Please help me to solve these issues.

    Regards,

    Ram.


    Ramakrishna

    Clear the AutoComplete Cache.
    If you are on Exchange 2007/2010 you can do that in OWA Light.

    Martina Miskovic

    You can try the following method to clear autocomplete cache.

    1. Delete an entry from the list using OWA

    2. Delete the entire list using OWA

    1. Delete an entry from the list using OWA:

    To remove one entry of the list, highlight the name in the list (arrow up and arrow down allow you to highlight the name you want to remove, and press the Delete button on your keyboard).

    2. Delete the entire list using OWA

    To remove all entries in the list, you can log on to your mailbox using Outlook Web Access Light

    Go to Options - Messaging - Under Email Name Resolution - Click “Clear Most Recent Recipients List”.

    Where does autocomplete gets stored in OWA?

    http://blogs.msdn.com/b/deva/archive/2010/07/12/where-does-autocomplete-gets-stored-in-owa.aspx



    Xiu Zhang

    TechNet Community Support

    • Proposed as answer by Xiu Zhang Tuesday, July 31, 2012 6:18 AM
    • Marked as answer by Xiu Zhang Monday, August 6, 2012 2:42 AM
    Wednesday, July 25, 2012 7:53 AM

All replies

  • It's likely resolving to the old legacyexchangedn. What you can do is update the legacyexchangedn and replace it with the new name, but before you do that you need to save the old legacyexchangedn and add it as an x500 address.

    1. open adsiedit from the run menu (windows support tools)

    expand domain, keep expanding and find your user, right click properties and find the attribute legacyexchangedn

    http://www.msexchange.org/tutorials/Understanding-LegacyExchangeDN.html

    It will look like /o=microsoft/ou=northamerica/cn=Recipients/cn=James Chong

    Save this value into notepad than

    change it to the new name /o=microsoft/ou=northamerica/cn=Recipients/cn=new name

    Now go into the mailbox properties of the user mailbox, email address tab. Add a new custom email address and email address type the original legacyexchangedn o=microsoft/ou=northamerica/cn=Recipients/cn=James Chong and email  type enter x500


    James Chong MCITP | EA | EMA; MCSE | M+, S+ Security+, Project+, ITIL msexchangetips.blogspot.com

    • Proposed as answer by Xiu Zhang Tuesday, July 31, 2012 6:19 AM
    • Marked as answer by Xiu Zhang Monday, August 6, 2012 2:42 AM
    Tuesday, July 24, 2012 2:19 PM
  • When I try to type a user name at To address bar, it is showing old email id of that user rather than new one, if I chek the names then it comes the new mail ID.

    Please help me to solve these issues.

    Regards,

    Ram.


    Ramakrishna

    Clear the AutoComplete Cache.
    If you are on Exchange 2007/2010 you can do that in OWA Light.

    Martina Miskovic

    • Proposed as answer by Xiu Zhang Tuesday, July 31, 2012 6:19 AM
    • Marked as answer by Xiu Zhang Monday, August 6, 2012 2:42 AM
    Tuesday, July 24, 2012 3:06 PM
  • When I try to type a user name at To address bar, it is showing old email id of that user rather than new one, if I chek the names then it comes the new mail ID.

    Please help me to solve these issues.

    Regards,

    Ram.


    Ramakrishna

    Clear the AutoComplete Cache.
    If you are on Exchange 2007/2010 you can do that in OWA Light.

    Martina Miskovic

    You can try the following method to clear autocomplete cache.

    1. Delete an entry from the list using OWA

    2. Delete the entire list using OWA

    1. Delete an entry from the list using OWA:

    To remove one entry of the list, highlight the name in the list (arrow up and arrow down allow you to highlight the name you want to remove, and press the Delete button on your keyboard).

    2. Delete the entire list using OWA

    To remove all entries in the list, you can log on to your mailbox using Outlook Web Access Light

    Go to Options - Messaging - Under Email Name Resolution - Click “Clear Most Recent Recipients List”.

    Where does autocomplete gets stored in OWA?

    http://blogs.msdn.com/b/deva/archive/2010/07/12/where-does-autocomplete-gets-stored-in-owa.aspx



    Xiu Zhang

    TechNet Community Support

    • Proposed as answer by Xiu Zhang Tuesday, July 31, 2012 6:18 AM
    • Marked as answer by Xiu Zhang Monday, August 6, 2012 2:42 AM
    Wednesday, July 25, 2012 7:53 AM