none
Remove VM from SCVMM and readd it. RRS feed

  • Question

  • One of the Hyper-V VM shows configuration error in SCVMM console, but VM is running fine in Hyper-V host. There is no issue with the VM, its working fine. But due to configuration error in SCVMM console backups are getting failed.

    Repair option is not able to fix this issue, other options are greyed out. How can I remove the VM from SCVMM and re-add it. 

    Any help on this will be much appreciated. 

    Thanks, 


    Abhishek

    Sunday, April 28, 2019 7:54 AM

All replies

  • Hi,

    Did you try to re-register the virtual machine (VM)?

    Register an existing virtual machine on a Hyper-V host

    $VMHost = Get-SCVMHost -ComputerName "HyperVHost01"
    Register-SCVirtualMachine -VMHost $VMHost -Path "E:\Hyper-V\VMName"

    Best regards,
    Leon


    Blog: https://thesystemcenterblog.com LinkedIn:

    Sunday, April 28, 2019 8:05 AM
  • Hi Leo, 

    I tried re-registering VM, but getting below error. 

    ----------------------------
    Register-SCVirtualMachine : VMM cannot complete the host operation on the host server because
    of the error: Failed to import a virtual machine. (Error ID: 12700, Detailed Error: Unknown error (0x8006))

    Resolve the host issue and then try the operation again.

    To restart the job, run the following command:
    PS> Restart-Job -Job (Get-VMMServer localhost | Get-Job | where { $_.ID -eq "{VM ID}"})


    Abhishek

    Sunday, April 28, 2019 8:43 AM
  • Since this issue concerns more SCVMM, I would suggest creating a thread in the dedicated forums for SCVMM below:

    System Center - Virtual Machine Manager  >  Virtual Machine Manager – Hyper-V

    I can give still give you a method that used to work for me:

    Ty removing the VM from the Failover Cluster Manager console on the Hyper-V host, refresh the Hyper-V Host in SCVMM, then re-add the VM in the Failover Cluster Manager console and finally refresh the Hyper-V host in SCVMM.



    Blog: https://thesystemcenterblog.com LinkedIn:

    • Proposed as answer by Tim CerlingMVP Sunday, April 28, 2019 11:37 AM
    Sunday, April 28, 2019 8:50 AM
  • Thanks Leon.

    I performed the steps suggested by you, but issue still exists. I will create a thread in SCVMM forum. 


    Abhishek

    Monday, April 29, 2019 7:01 PM
  • Hi ,

    You could mark the useful reply as answer if you want to end this thread up.

    Best Regards,

    Candy


    Please remember to mark the replies as an answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com   

    Tuesday, April 30, 2019 3:51 AM