locked
"‘Edit Document’ requires a Windows SharePoint Services-compatible application and Microsoft Internet Explorer 6.0 or greater." RRS feed

  • Question

  • since roughly a week ago, i get the above message when trying to open a word document for editing on one of our workstations (win7 64bit pro, fully wsus patched, no sp1; office 2003 sp3)

    i checked http://support.microsoft.com/kb/840024/en-us which seems to describe the problem pretty close (though we see this with wss3 and the message says ie6 instead of 5 or 4)

    tried the regsvr32 aproach and a repair install of the office, both dont solve the issue though.

    anyone had this issue before or has another idea?

    Thanks

    Florian

    • Edited by Mike Walsh FIN Tuesday, March 8, 2011 4:24 PM quotes put around error message in Title
    Tuesday, March 8, 2011 2:39 PM

Answers

  • Tom,

    There are issues with using 64-bit versions of Office to open data in SharePoint. I am guessing you are using Office 64-bit, so here are some links concerning the issue and the workaround:

    http://knowsharepoint.com/sharepoint-datasheet-view-and-office-2010-64-bit/

    http://support.microsoft.com/kb/2266203

    As you can see, these relate to the datasheet view, but I believe the ActiveX issue will cause the problem with "Edit in...." issue as well.


    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:08 AM
    • Edited by Daniel-GMVP Sunday, March 4, 2012 4:38 AM Fixed url to the knowsharepoint.com site
    Monday, March 14, 2011 8:38 PM
  • Thanks, Mike and dangg.  I installed IE 9 full version this morning, running it as 32 bit on a 64 bit machine, and also switched to Office 32 bit.  Everything appears to work properly now.  I appreciate your help.
    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:08 AM
    Tuesday, March 15, 2011 2:18 PM
  • Hi FZB,

    There are 3 reasons would cause this problem:
    1. Office XP or later not installed on the computer.
    2. SharePoint support component is not installed on the computer.
    3. The Owsupp.dll file is not registered correctly.

    Please check if the SharePoint support componet is installed on your computer follow this step:
    Control Panel > Add or Remove Programs > Microsoft Office 2003 > Change > Add or Remove Features > Next > Choose advanced customization of application > Next > Choose update options for applications and tools > expand Office Tools > Windows SharePoint Services Support.
    For more details, please read this KB. http://support.microsoft.com/kb/833714

    Best regards,
    Emir

    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:09 AM
    Thursday, March 10, 2011 8:24 AM
  • I'm going to split this partly new question into a new thread in the BPOS forum for SharePoint. (SharePoint On Line)

    I suggest that you upgrade to the official version of IE9 that becomes available tonight at 9PM (was it EST or EST?).

    At the moment you must be using a pre-release version of IE9 and that as with all pre-release (mostly betas) versions is not supported in any other forum than a forum specifically for that pre-release product.

    Moderator pre-SP 2010 forums

    Later: Despite many attempts Split didn't work so I going to have to try again later


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    • Edited by Mike Walsh FIN Monday, March 14, 2011 6:57 PM Later: added
    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:08 AM
    Monday, March 14, 2011 6:49 PM

All replies

  • As well as the fairly obvious question that you are using a version of IE as your browser, do you have *any* Office 2007 level applications installed such as Outlook 2007; OneNote 2007; Visio 2007. (I'm aware you wrote Office 2003 but that often means only the standard apps Excel; Word; PowerPoint.). The presence of any 2007-level apps could cause this.
    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Tuesday, March 8, 2011 4:27 PM
  • Yes, the browser in question is IE8. the office question is a good hint, will check out if there was something newer like ppt viewer in a newer version or such installed.
    Tuesday, March 8, 2011 4:38 PM
  • The usual "culprit" in "mixed" client installations is a newer version of Outlook. Your idea of a Viewer is a good one though (and of course while I wrote 2007 an even later Office product mixed with a 2003 Office installation could cause problems).

    The re-run (i.e running setup) of Office 2003 usually clears (temporarily) such problems but not always.

    On another plane, you didn't say which version the Word document is - there are some KB articles for problems with Office 2010  formatted documents for instance.


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters

    Tuesday, March 8, 2011 5:28 PM
  • Hi FZB,

    There are 3 reasons would cause this problem:
    1. Office XP or later not installed on the computer.
    2. SharePoint support component is not installed on the computer.
    3. The Owsupp.dll file is not registered correctly.

    Please check if the SharePoint support componet is installed on your computer follow this step:
    Control Panel > Add or Remove Programs > Microsoft Office 2003 > Change > Add or Remove Features > Next > Choose advanced customization of application > Next > Choose update options for applications and tools > expand Office Tools > Windows SharePoint Services Support.
    For more details, please read this KB. http://support.microsoft.com/kb/833714

    Best regards,
    Emir

    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:09 AM
    Thursday, March 10, 2011 8:24 AM
  • > There are 3 reasons would cause this problem:

    At least your point one doesn't apply because he is using Office 2003 which is greater than Office XP.

    Two is always a possible reason. (and more likely with Office 2003 - where I seem to remember it isn't default - than with Office 2007 and later where I seem to remember it is default)

    Three is usually solved by a run of the Office setup which was suggested earlier.

    Meanwhile I'm waiting for some response from the poster who has been suspiciously quiet ...

     


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    Thursday, March 10, 2011 10:36 AM
  • still around, sorry.

    ill check on the sharepoint support component at the pc, but i guess it is installed, as it worked till last week.

    i havent seen any non office 2003 components, either in add/remove programs nor seen an offciexx folder other then the office11.

    searched the hdd for owssupp.dll, only found the one in program files\microsoft office\office11 and the version 11.0.8164.0 seems to be the same as on other pc's that do work.

    will propably remove office and reinstall it later today and see if that does work.

    thanks for the input so far :)

     

    Thursday, March 10, 2011 10:59 AM
  • I have the same problem, but the underlying cause appears to be different.  When I try to open an Excel document from Sharepoint (BPOS), I get the same message as FZB.  However, I am on a machine that has been on Windows 7 64 bit and Microsoft Office 10 since it was purchased, so there are no older applications.   However, I am using Internet Explorer 9 64-bit, and I wonder if that is the cause of the problem.  Any workaround?

    I am able to open Sharepoint files from Windows Explorer, so this is not a critical error, but it is inconvenient.

    Monday, March 14, 2011 6:11 PM
  • I'm going to split this partly new question into a new thread in the BPOS forum for SharePoint. (SharePoint On Line)

    I suggest that you upgrade to the official version of IE9 that becomes available tonight at 9PM (was it EST or EST?).

    At the moment you must be using a pre-release version of IE9 and that as with all pre-release (mostly betas) versions is not supported in any other forum than a forum specifically for that pre-release product.

    Moderator pre-SP 2010 forums

    Later: Despite many attempts Split didn't work so I going to have to try again later


    SP 2010 "FAQ" (mainly useful links): http://wssv4faq.mindsharp.com/default.aspx
    WSS3/MOSS FAQ (FAQ and Links) http://wssv3faq.mindsharp.com/default.aspx
    Both also have links to extensive book lists and to (free) on-line chapters
    • Edited by Mike Walsh FIN Monday, March 14, 2011 6:57 PM Later: added
    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:08 AM
    Monday, March 14, 2011 6:49 PM
  • Tom,

    There are issues with using 64-bit versions of Office to open data in SharePoint. I am guessing you are using Office 64-bit, so here are some links concerning the issue and the workaround:

    http://knowsharepoint.com/sharepoint-datasheet-view-and-office-2010-64-bit/

    http://support.microsoft.com/kb/2266203

    As you can see, these relate to the datasheet view, but I believe the ActiveX issue will cause the problem with "Edit in...." issue as well.


    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:08 AM
    • Edited by Daniel-GMVP Sunday, March 4, 2012 4:38 AM Fixed url to the knowsharepoint.com site
    Monday, March 14, 2011 8:38 PM
  • Thanks, Mike and dangg.  I installed IE 9 full version this morning, running it as 32 bit on a 64 bit machine, and also switched to Office 32 bit.  Everything appears to work properly now.  I appreciate your help.
    • Marked as answer by Leoyi Sun Wednesday, March 16, 2011 3:08 AM
    Tuesday, March 15, 2011 2:18 PM
  • After trying all of the above, I was finally able to open the dadgum spreadsheet on sharepoint by starting IE8 as administrator.

    To do this:

    Right click on the IE icon in either the start menu or the taskbar

    Select Run As Administrator

    Hope this helps!


    Dave


    • Edited by Gnorman Tuesday, September 18, 2012 4:42 PM clarifiation
    Tuesday, September 18, 2012 12:15 AM