locked
unknown error applying the FILESTREAM settings RRS feed

  • Question

  • I am trying to enable FILESTREAM on a SQL 2012 installation that is supporting a Sharepoint 2013 implementation. When I try to enable FILESTREAM using the SQL Server Configuration Manager I receive the following error:

    There was an unknown error applying the FILESTREAM settings.

    Check the parameters are valid. (0x80041008)

    I have done this succussfully in the past in SQL2008R2/Sharepoin2010 environment but this is my first attempt with SQL2012/Sharepoint2013 and I am not sure how to proceed with troubleshooting.


    davidh


    • Edited by DAH69 Wednesday, October 2, 2013 3:26 PM
    Wednesday, October 2, 2013 3:26 PM

Answers

  • Hello David,

    The following error is reported when you have LSQ 2012  32 bit on a windows 64 bit machine.

    Msg 5593, Level 16, State 1, Line 1

    FILESTREAM feature is not supported on WoW64. The feature is disabled.

    As per the MSDN article: You cannot enable FILESTREAM on a 32-bit version of SQL Server running on a
    64-bit operating system.

    http://msdn.microsoft.com/en-us/library/cc645923.aspx

    • Marked as answer by DAH69 Wednesday, October 2, 2013 5:55 PM
    Wednesday, October 2, 2013 5:11 PM
  • hello David,

    Thanks for sharing the details.

    make sure that "Filestream for t-sql" setting is enabled. To perform this:

    1. Open SQL Server configuration manager.

    2. properties of the SQL 2012 instance

    3. Go to Filestream tab, check the following options

            Enable Filestream for Transact SQL Access

            Enable Filestream for the IO access

    If the above steps, don't help:

    sp_configure 'filestream access level', 2

    reconfigure with override

    • Marked as answer by DAH69 Wednesday, October 2, 2013 5:55 PM
    Wednesday, October 2, 2013 4:13 PM
  • Hello David,

    you can check the version either through SQL errorlo

    g or by using select @@version query

     


    Wednesday, October 2, 2013 5:43 PM

All replies

  • hello David,

    Make sure that the Filestream disk is added as SQL dependency. Add the disk resource to the SQL failover group and make SQL resource  dependant on that disk.

    Also if the issue is only on the passive node, check the registry key and make sure that they are valid:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Microsoft SQL Server\MSSQL11.<instancename>\MSSQLServer\Filestream

    Wednesday, October 2, 2013 3:50 PM
  • Hi Don,

    Thanks for the response. I don't know how do to what you are asking unfortunately. This is a very simple setup at this point, basically an out of the box SQL setup and the same for Sharepoint. One SQL2012 server and on SP2013 front end server, not a cluster, no failovers configured, etc. I am not well versed in SQL obviously. I appreciate your help.


    davidh

    Wednesday, October 2, 2013 4:03 PM
  • hello David,

    Thanks for sharing the details.

    make sure that "Filestream for t-sql" setting is enabled. To perform this:

    1. Open SQL Server configuration manager.

    2. properties of the SQL 2012 instance

    3. Go to Filestream tab, check the following options

            Enable Filestream for Transact SQL Access

            Enable Filestream for the IO access

    If the above steps, don't help:

    sp_configure 'filestream access level', 2

    reconfigure with override

    • Marked as answer by DAH69 Wednesday, October 2, 2013 5:55 PM
    Wednesday, October 2, 2013 4:13 PM
  • Hi Don,

    Thanks again for the reply. it is when I do steps 1-3 that I receive the original error.

    When I run the query sp_configure 'filestream access level', 2 it completes successfully.

    however when I run reconfigure I receive the error below, I am not sure how to run reconfigure with override?

    Msg 5593, Level 16, State 1, Line 1

    FILESTREAM feature is not supported on WoW64. The feature is disabled.


    davidh

    Wednesday, October 2, 2013 4:58 PM
  • Hi Don,

    Sorry to be so dense, I figured it out. Unfortunately it throws an error.

    This is exactly what I have now entered for the query:

    sp_configure 'filestream access level', 2

    reconfigure with override

    This is the results:

    Configuration option 'filestream access level' changed from 2 to 2. Run the RECONFIGURE statement to install.

    Msg 5593, Level 16, State 1, Line 2

    FILESTREAM feature is not supported on WoW64. The feature is disabled.


    davidh

    Wednesday, October 2, 2013 5:10 PM
  • Hello David,

    The following error is reported when you have LSQ 2012  32 bit on a windows 64 bit machine.

    Msg 5593, Level 16, State 1, Line 1

    FILESTREAM feature is not supported on WoW64. The feature is disabled.

    As per the MSDN article: You cannot enable FILESTREAM on a 32-bit version of SQL Server running on a
    64-bit operating system.

    http://msdn.microsoft.com/en-us/library/cc645923.aspx

    • Marked as answer by DAH69 Wednesday, October 2, 2013 5:55 PM
    Wednesday, October 2, 2013 5:11 PM
  • Hi Don,

    It has been a couple of months since I built this machine but I am 99% positive that I installed the 64bit SQL on this machine, I guess not. Is there a way I can check to see if it is 32bit or 64bit before tear all this down and have to rebuild it?

    thanks


    davidh

    Wednesday, October 2, 2013 5:21 PM
  • Hello David,

    you can check the version either through SQL errorlo

    g or by using select @@version query

     


    Wednesday, October 2, 2013 5:43 PM
  • Hi Don,

    Well stink! It is indeed the 32bit version. Thank you very much for your help Don, I have once again learned some things from the forums, it is not a totally wasted day.


    davidh

    Wednesday, October 2, 2013 5:54 PM
  • Hello David,

    I m very glad it helped. Thanks for

    using Microsoft forums.

    Regards,

    Don

    Wednesday, October 2, 2013 6:03 PM
  • Hi, i'm trying to enable FileStream on SQL2012 too. I read all this topic, it's very useful, but it's not my case, I have installed SQL Server 2012 64 bit version on 64 bit OS

    Microsoft SQL Server 2012 (SP1) - 11.0.3128.0 (X64)
        Dec 28 2012 20:23:12
        Copyright (c) Microsoft Corporation
        Enterprise Edition (64-bit) on Windows NT 6.2 <X64> (Build 9200: ) (Hypervisor)

    But when i try to enable FILESTREAM i get unknown error like David, but with another code (0x80070046) or (0x800706d9).

    At the same time i had no problem to enable FileStream at my local machine, the difference between two machines is OS.

    In the good case it's Windows 8 Pro 64 bit

    In bad case it's Windows Server 2005 R2 Enterprise 64 bit

    Have no idea why it doesn't works at Windows Server machine :(

    Hope for some help,

    Eugenia

    Friday, October 3, 2014 1:10 PM
  • Hi Don,

    Well stink! It is indeed the 32bit version. Thank you very much for your help Don, I have once again learned some things from the forums, it is not a totally wasted day.


    davidh


    Same here. At the time I couldn't see the advantage of loading the 64 Bit version. Oh, well.
    Friday, July 24, 2015 9:44 AM