locked
Build 9926 - no WiFi after resume from sleep RRS feed

  • Question

  • I'm running Windows 10 Pro Technical Preview build 9926 and since I installed it two days ago, the WiFi doesn't work after I resume from sleep. I can get it working by disabling and re-enabling in Device Manager but this is a pain and I would like to just have it work after a resume. It was fine in 9841, 9860, and 9879, but not in 9926 for some reason. If it helps, I am also dual booting with Kubuntu 15.04 Vivid Vervet preview and the bootloader is Grub2. From my searching, it seems this is a unique problem so I have asked here.
    Sunday, January 25, 2015 3:43 PM

Answers

  • None of these solutions worked for me. I was able to create a batch file to fix this for me.

    1. Download DevManView (if you're on 64-bit, choose 64-bit, otherwise choose 32-bit) (http://www.nirsoft.net/utils/device_manager_view.html) to allow command-line access to Device Manager. Extract the zip and open devmanview.exe (remember the path where you downloaded it). Find your WiFi device's name and write it down. It will be referred to as $WIFI in this guide.

    2. In your User directory, create a new batch file called "WiFiSLEEP.bat" without quotes. Don't put anything in it yet.

    3. Open Task Scheduler. Right click Task Scheduler Library and create a new folder called "No UAC" without quotations. Click inside the folder and create a new task (not new basic task). Name it "wifisleep" without quotations. Select "Windows 10 Technical Preview" under "Configure For: ". Select "Run whether User is logged on or not" and "Do not store password". Enable "Run with Highest Privileges". Under Actions, select New...>"Start a program". "Under Program/Script", select "Browse..." and find DevManView's .exe executable. Under "Arguments", type '/disable_enable "$WIFI"' without single quotes. So mine looked like this: '/disable_enable "Intel Wireless-N 7260"'. Under the conditions tab, deselect everything except "Stop if the computer ceases to be idle". Close the dialog box by clicking "OK".

    4. On your desktop, create a new shortcut. Its path should be: 'C:\Windows\System32\schtasks.exe /RUN /TN "No UAC\wifisleep"' without single quotes. Name it "wifisleep" without quotes.

    5. Open WiFiSLEEP.bat and paste: "\path\to\wifisleep.lnk" without quotes. So for me: "C:\Users\pythonhax\Desktop\wifisleep.lnk". Close the batch file.

    6. In Task Scheduler, create a new task. Name it "Re-enable WiFi after Sleep" without quotes. In the general tab, select "Windows 10 Technical Preview" as the OS and "Run whether User is logged on or not" and "Do not store password." Under Triggers, select "New...". Select begin the task on an event. Select a basic trigger. The log should be System and the source should be Power-Troubleshooter. The event ID should be 1. Under actions, select New...start a program and navigate to WiFiSLEEP.bat. Finally, under conditions, deselect everything except "Stop if the computer ceases to be idle." Then click OK. Close task scheduler.

    You're done! The batch file will be run on resume from sleep and you'll have WiFi working again. This is more of a kludgy fix but it works until MS or Intel releases a patch to fix this.

    • Marked as answer by pythonhax Sunday, February 8, 2015 10:22 PM
    • Unmarked as answer by pythonhax Sunday, February 8, 2015 10:22 PM
    • Marked as answer by Yolanda ZhuModerator Tuesday, February 10, 2015 2:42 AM
    Sunday, February 8, 2015 4:44 PM

All replies

  • I'm running Windows 10 Pro Technical Preview build 9926 and since I installed it two days ago, the WiFi doesn't work after I resume from sleep. I can get it working by disabling and re-enabling in Device Manager but this is a pain and I would like to just have it work after a resume. It was fine in 9841, 9860, and 9879, but not in 9926 for some reason. If it helps, I am also dual booting with Kubuntu 15.04 Vivid Vervet preview and the bootloader is Grub2. From my searching, it seems this is a unique problem so I have asked here.
    Same problem here. Only just installed the tech preview (Dell 7537 Laptop) but experiencing this exact problem which is an utter pain, especially as the restart seems to take quite a while.
    Sunday, January 25, 2015 9:36 PM
  • One of these may help:

    Go to the Network and Sharing Center > Change adapter settings (in the left pane), right-click or press and hold on the connection you‘re using, click or tap Properties > Networking Tab. Now remove the tick from the IPv6 box. If it makes no difference or causes other problems it is completely reversible by ticking the box.

    Right-click or press and hold Computer (This PC), click or tap Properties > Device Manager (in the left pane). Expand Network Adapters > double-click or double-tap the wireless adapter > Power Management Tab and make sure the check box is cleared against ‘Allow the computer to turn off this device……’.

    Lastly, press the Windows Logo key+X (or right-click off the bottom left corner) and choose Control Panel > Small Icons > Power Options > Change plan settings (for the selected Power Plan) > Change advanced power settings (at the bottom) > Expand Wireless Adapter Settings > Power Saving Mode and check that the values are Maximum Performance otherwise set it to Maximum Performance.


    Why do ninety-nine per cent of politicians give the rest a bad name?

    Monday, January 26, 2015 8:23 AM
  • Even I'm facing same issue in the latest build 9926 ! Lately, I've noticed that Windows 10 new build 9926 has some issue with WiFi internet connection. Internet connection in My Dell laptop is getting disconnected and it’s really annoying. I'm not able to find any solution for this till now :(

    Even if my WiFi is connected, the internet won't work. I never had this issue with previous versions of Windows 10 preview. Also, I’ve confirmed that WiFi is working with other laptop which is running with Windows 8.1 ! 


    More details http://anoopcnair.com/2015/01/26/windows-10-wifi-internet-connection-disconnected/


    Anoop C Nair (My Blog www.AnoopCNair.com) - Twitter @anoopmannur - FaceBook Forum For SCCM


    Monday, January 26, 2015 1:39 PM
  • One of these may help:

    Go to the Network and Sharing Center > Change adapter settings (in the left pane), right-click or press and hold on the connection you‘re using, click or tap Properties > Networking Tab. Now remove the tick from the IPv6 box. If it makes no difference or causes other problems it is completely reversible by ticking the box.

    Right-click or press and hold Computer (This PC), click or tap Properties > Device Manager (in the left pane). Expand Network Adapters > double-click or double-tap the wireless adapter > Power Management Tab and make sure the check box is cleared against ‘Allow the computer to turn off this device……’.

    Lastly, press the Windows Logo key+X (or right-click off the bottom left corner) and choose Control Panel > Small Icons > Power Options > Change plan settings (for the selected Power Plan) > Change advanced power settings (at the bottom) > Expand Wireless Adapter Settings > Power Saving Mode and check that the values are Maximum Performance otherwise set it to Maximum Performance.


    Why do ninety-nine per cent of politicians give the rest a bad name?

    I tried all your steps but it didn't work and I'm facing the same problem. In device manager when the internet has stopped working, it says that "Windows has stopped this device because it has reported problems. (Code 43)". The adapter is an Intel 7260BN and the laptop is a Toshiba Satellite E55t-A5320 (Core i5-4200U @ 1.60 GHz, 12 GB RAM, 500 GB 5400RPM HDD, of which 390 GB is the C: drive.)
    Monday, January 26, 2015 3:06 PM
  • I think I have figured out the reason for this behavior: In the application manifest the driver has declared compatibility for 8.1, so Windows lets the driver see the full kernel version. The driver doesn't like kernel 10.0. Does anyone know if the driver can be updated on Win10TP?
    Monday, January 26, 2015 11:40 PM
  • Also does anyone know of a fix for the kernel issue I mentioned above?
    Monday, January 26, 2015 11:59 PM
  • Same issue here, Intel Wifi. Worked perfectly fine on previous builds but not in 9926. Pressing connect in the networks list will get it connected btw.
    Tuesday, January 27, 2015 5:42 PM
  • What do you mean? I can't even see a list of connections; I have to disable and enable in device manager before it will see connections.
    Tuesday, January 27, 2015 6:11 PM
  • Hi,

    Please ensure that you are running the latest wireless driver from the manufacturer. If issue persists after the latest version, please send an email to arudell at Microsoft dot com w/ subject of Build 9926 - Wireless Issues Forum Thread with the information requested below.

    • Wireless Device Manufacturer & Version number
    • PC Manufacturer
    • Network Trace using PowerShell (running as admin) netsh trace start scenario=WLAN capture=yes / netsh trace stop when reproducing the scenarios of Wi-Fi disconnecting

    Also ensure that you are submitting feedback via the feedback tool built into the OS as this will get these scenarios reported to the PG directly.

    Regards,


    Adam Rudell | Sr Support Engineer | Windows Beta | Microsoft Corporation

    Wednesday, January 28, 2015 7:05 PM
  • Hi ! - I've already provided the feedback and also sent you a mail with network capture.


    Anoop C Nair (My Blog www.AnoopCNair.com) - Twitter @anoopmannur - FaceBook Forum For SCCM

    Thursday, January 29, 2015 2:06 AM
  • pythonhax:

    Thank you for posting this as I do a little testing of the "features I am comfortable evaluating" each night, hope this is more than the typical user might consider, and am also returning to the Insider Forums regularly for issues I can attempt to replicate.  So, I will be putting my Dell laptop to Sleep tonight and see if the Wi-Fi comes back when it wakes up.

    There may be a great deal to Windows that seems "ordinary" or [rather] unimportant, but in my opinion these are the features that [eventually] bite other users in the butt simply because they can.  The wider more diverse audience of users and situations that "can" and "will" break Windows down the road [after its wide release] is a virtual certainty.  I do not mean this to sound glib or insulting to anyone in any way, I actually mean it to be encouraging!

    It is a story [or saga] of what sort of things "need" to be checked, can be evaluated logically, what to check, and how that information is conveyed through the Windows Feedback or Forums that is probably the most challenging part of the entire process!

    My approach centers around a few really simple rules: (learned over years of support employment)

    • 1).  Change only one thing at a time, so the results can be called, "definitive".
    • 2).  Consider making an "Export" of the Registry before installing ANY program.
    • -- .. in order to observe how the Registry has changed in size (Before vs. After) the install.
    • -- Keep a Notepad log or journal with Build #s, the times they were installed and the
    • -- .. things you do under each Build; like a trail of breadcrumbs to lead you back, or at
    • -- ... least give perspective on where you came from.
    • 3).  Export the Registry after each new Build is Released and compare it to the earlier size.

    I have also made some notes on when Disk Cleanup was performed, when Scandisk was performed, and the otherwise seemingly mundane stuff that ALL USERS will be doing eventually.  Because while these may not be vendor-specific or Driver-specific tasks, they also pose a risk of being the thing that "breaks" the system sooner or later.  Batteries fail in the middle of daily use...  Home modems "drop" the connection while Updates are downloading...  People click things by "accident" when they meant to click [Cancel].

    I have also thought to use my favorite Registry Cleaner to "Scan" the Registry for issues and save the results to a series of .TXT [log] files, but NOT to actually "Clean" or "Repair" the issues, so I could later see the types of issues that accumulate over time (over the Builds).  Logically, I guess it would also be Okay to repair them, because then I would only need to look at the "new" issues detected, but that is just another approach to the idea.

    All I am suggesting is asking, 'How less-experienced systems evaluators should be approaching these tasks?' on a holistic level.  We can do it step by step, task by task, program by program and App by App, but there are potentially many things that do NOT need to be checked.  It is not easy and the path is fraught with peril.. "hidden" undocumented features and what not.  This new Operating System is comprised of over 174,000 (or so) individual files!!  That's pretty freaking astounding in my opinion.

    Best wishes to all Insider Preview participants!



    Thursday, January 29, 2015 4:23 AM
  • My issue appears to have been resolved with the latest driver for my Intel 6235 (15.16.0.2).
    Thursday, January 29, 2015 9:18 AM
  • @wagenveld: Great that this worked for you. I was a bit skeptical about installing a new driver on the Tech Preview but if it worked for you, it should work for me.

    @Subroutine42: That seems like great advice to take, I'll definitely use that for troubleshooting purposes.

    @Adam Rudell: Thanks for the support link. I'll try the latest driver first then I'll contact you.

    Thursday, January 29, 2015 12:01 PM
  • Does not seem to work after downloading the latest drivers. Downloading patch KB3035129 right now, I'll try to see if it works after installing that. 
    Thursday, January 29, 2015 4:32 PM
  • KB3035129 did not help the situation, and on closer notice it seems that the newest driver 17.1.1409.1 (November 19, 2014) did not install and I am still stuck on driver 17.1.0.19 (July 21, 2014).
    Thursday, January 29, 2015 4:49 PM
  • From my experience so far, this seems to be more an odd software problem than a hardware problem. After trying all of these solutions and having none of them work (I was having the same problem on my SP3), I was able to get my WiFi to work again by going into 'Manage known networks' in the new Wi-Fi settings tab, and deleting the network that my computer last connected to/was trying to connect to. Once I deleted it, I was able to re-add that WiFi network (and other networks) and it worked again. Hopefully this will work for others as well.
    Wednesday, February 4, 2015 3:47 PM
  • now, It's stable for me. I tried loads of stuff so not sure what fixed the issue. 

    Anoop C Nair (My Blog www.AnoopCNair.com) - Twitter @anoopmannur - FaceBook Forum For SCCM

    Wednesday, February 4, 2015 4:31 PM
  • By the way, are you using some antivirus? Networking drivers from AV vendors may pop out from the stack incorrectly after your PC gets into S0 from S1-3 or S4 power state.

    Well this is the world we live in And these are the hands we're given...

    Wednesday, February 4, 2015 10:12 PM
  • @Exotic Hadron No, nothing but stock Windows Defender

    @JakeWeidman Ok, will try that when I reboot into Windows (right now I'm working in Kubuntu 15.04)

    Hopefully MS releases an update patch to solve this OR Intel makes their latest driver installable on Windows 10

    • Edited by pythonhax Wednesday, February 4, 2015 11:42 PM
    Wednesday, February 4, 2015 11:40 PM
  • same problem here. haven't yet done any of the suggestions (they don't seem to make a difference) but simply wanted to add my voice.
    Thursday, February 5, 2015 8:18 AM
  • I had basically the same issue on HP 2230s. The WiFi did not work after the computer was started.

    The way I fixed the issue:

    1. Go to the "Network and Sharing Center"

    2. Below "Change a new connection or network" select "Set up a new connection or network"

    3. Select "Manually connect to a wireless network" -> Next -> Define the Network name and other values. Select "Start this connection automatically" -> Next


    Thursday, February 5, 2015 4:09 PM
  • I don't know a lot about this, but I tried it all. Finally, I was just messing around and found this worked for me----
    1. Click on the internet connection on bottom right taskbar.
    2. Click on “manage known networks” at the bottom of the list.
    3. Click “Connect to wifi hotspots” to “off”
    4. Click “Send information about wifi connections to help discover nearby wifi” to “ off’,
    I don't know if this is a "real" fix or not, but it works for me.
    • Proposed as answer by dbcito Tuesday, February 10, 2015 10:34 PM
    Saturday, February 7, 2015 2:31 AM
  • None of these solutions worked for me. I was able to create a batch file to fix this for me.

    1. Download DevManView (if you're on 64-bit, choose 64-bit, otherwise choose 32-bit) (http://www.nirsoft.net/utils/device_manager_view.html) to allow command-line access to Device Manager. Extract the zip and open devmanview.exe (remember the path where you downloaded it). Find your WiFi device's name and write it down. It will be referred to as $WIFI in this guide.

    2. In your User directory, create a new batch file called "WiFiSLEEP.bat" without quotes. Don't put anything in it yet.

    3. Open Task Scheduler. Right click Task Scheduler Library and create a new folder called "No UAC" without quotations. Click inside the folder and create a new task (not new basic task). Name it "wifisleep" without quotations. Select "Windows 10 Technical Preview" under "Configure For: ". Select "Run whether User is logged on or not" and "Do not store password". Enable "Run with Highest Privileges". Under Actions, select New...>"Start a program". "Under Program/Script", select "Browse..." and find DevManView's .exe executable. Under "Arguments", type '/disable_enable "$WIFI"' without single quotes. So mine looked like this: '/disable_enable "Intel Wireless-N 7260"'. Under the conditions tab, deselect everything except "Stop if the computer ceases to be idle". Close the dialog box by clicking "OK".

    4. On your desktop, create a new shortcut. Its path should be: 'C:\Windows\System32\schtasks.exe /RUN /TN "No UAC\wifisleep"' without single quotes. Name it "wifisleep" without quotes.

    5. Open WiFiSLEEP.bat and paste: "\path\to\wifisleep.lnk" without quotes. So for me: "C:\Users\pythonhax\Desktop\wifisleep.lnk". Close the batch file.

    6. In Task Scheduler, create a new task. Name it "Re-enable WiFi after Sleep" without quotes. In the general tab, select "Windows 10 Technical Preview" as the OS and "Run whether User is logged on or not" and "Do not store password." Under Triggers, select "New...". Select begin the task on an event. Select a basic trigger. The log should be System and the source should be Power-Troubleshooter. The event ID should be 1. Under actions, select New...start a program and navigate to WiFiSLEEP.bat. Finally, under conditions, deselect everything except "Stop if the computer ceases to be idle." Then click OK. Close task scheduler.

    You're done! The batch file will be run on resume from sleep and you'll have WiFi working again. This is more of a kludgy fix but it works until MS or Intel releases a patch to fix this.

    • Marked as answer by pythonhax Sunday, February 8, 2015 10:22 PM
    • Unmarked as answer by pythonhax Sunday, February 8, 2015 10:22 PM
    • Marked as answer by Yolanda ZhuModerator Tuesday, February 10, 2015 2:42 AM
    Sunday, February 8, 2015 4:44 PM
  • worked for me too. Thanks
    Tuesday, February 10, 2015 10:34 PM
  • You're welcome!

    This really came about only because of my obsession with batch files; I find them much more efficient to run a sequence of commands.

    Wednesday, February 11, 2015 11:55 PM