none
Windows 10 DirectAccess "Group Policy Waited"

    Question

  • We are starting to role out Windows 10 Enterprise to some staff laptops.  We have a single 2012R2 DirectAccess server running with a Single NIC.  

    When I apply the GPO's for DirectAccess to the Windows 10 laptops the boot time increases by a full minute.  All of these laptops are running SSD's.  The laptops are currently in the "Corporate Network".

    I managed to find that Group Policy is causing the additional delay.

    - <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

    - <System>

     <Provider Name="Microsoft-Windows-GroupPolicy" Guid="{AEA1B4FA-97D1-45F2-A64C-4D69FFFD92C9}" />

     <EventID>5332</EventID>

     <Version>0</Version>

     <Level>4</Level>

     <Task>0</Task>

     <Opcode>0</Opcode>

     <Keywords>0x4000000000000000</Keywords>

     <TimeCreated SystemTime="2015-11-19T15:15:57.926369300Z" />

     <EventRecordID>1693</EventRecordID>

     <Correlation />

     <Execution ProcessID="416" ThreadID="1348" />

     <Channel>Microsoft-Windows-GroupPolicy/Operational</Channel>

     <Computer>Removed</Computer>

     <Security UserID="S-1-5-18" />

     </System>

    - <EventData>

     <Data Name="IsPolicyConfigured">false</Data>

     <Data Name="MaxTimeToWait">60000</Data>

     <Data Name="TimeWaitedAtStartup">60016</Data>

     <Data Name="DidWaitTimeout">true</Data>

     </EventData>

     </Event>

    I have not noticed the same event on either Windows 7 or Windows 8.  I cannot find any settings to change the MaxTimeToWait or disable this altogether.  Is this something that can be configurable?  Has anyone else seen this issue?  I used the DirectAccess Server wizard to configure everything and have not manually adjusted the GPO's associated with DA.  If the DA GPO's are not applied to the laptop the boot time is under 20s.

    We do have "Wait for the network" turned on within a GPO.  I tried turning that off but that did not seem to help.  I have also set the "Require use of Fast Startup" GPO setting and that did not resolve the issue. 

    Thank you for your help.

    Friday, November 20, 2015 5:25 PM

Answers