none
Surface Pen Pairing OOBE RRS feed

  • Question

  • Hello Eveyone, im trying to find a way to force OOBE to run after the Task Sequence is finalised.

    I got only on OOBE settings which is pen pairing for surfaces pro 4. If i copy the file while on WinPe next restart will prompt for Pen Pairing (as expected). But i want to have a Zero Touch experience. At the end the task sequence should shut down the computer and next boot (once the end user received the device) it should run oobe for Pen Pairing.

    Any idea how to do that??

    Thanks

    Jose


    MCTS - SCCM 2007 and 2012 MCSA - Windows 8, 10, Server 2012 and Office 365

    Wednesday, September 7, 2016 3:40 AM

Answers

  • Hi,

        Is the reference image you are using a surface pro 4 factory image? If it is, just delete the following files from your image by using DISM then it will not prompt for pen pairing during OOBE:

        •%windir%\system32\oobe\info\default\1033\oobe.xml
        •%windir%\system32\oobe\info\default\1033\PenPairing_en-US.png
        •%windir%\system32\oobe\info\default\1033\PenError_en-US.png
        •%windir%\system32\oobe\info\default\1033\PenSuccess_en-US.png  

    https://technet.microsoft.com/en-us/itpro/surface/customize-the-oobe-for-surface-deployments?f=255&MSPPError=-2147217396

        " im trying to find a way to force OOBE to run after the Task Sequence is finalized."

        I'm afraid not, because a sysprep is required if you want your device doing an OOBE when power on. However, the device should stay in workgroup before the sysprep process run. When the user received the device, they will have to join domain manually.

    Best regards,

    Jimmy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 8, 2016 7:38 AM
    Moderator

All replies

  • Hi,

        Is the reference image you are using a surface pro 4 factory image? If it is, just delete the following files from your image by using DISM then it will not prompt for pen pairing during OOBE:

        •%windir%\system32\oobe\info\default\1033\oobe.xml
        •%windir%\system32\oobe\info\default\1033\PenPairing_en-US.png
        •%windir%\system32\oobe\info\default\1033\PenError_en-US.png
        •%windir%\system32\oobe\info\default\1033\PenSuccess_en-US.png  

    https://technet.microsoft.com/en-us/itpro/surface/customize-the-oobe-for-surface-deployments?f=255&MSPPError=-2147217396

        " im trying to find a way to force OOBE to run after the Task Sequence is finalized."

        I'm afraid not, because a sysprep is required if you want your device doing an OOBE when power on. However, the device should stay in workgroup before the sysprep process run. When the user received the device, they will have to join domain manually.

    Best regards,

    Jimmy


    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, September 8, 2016 7:38 AM
    Moderator
  • Thanks for the info Jimmy.

    The process run smoothly if i run after installing sccm client (first reboot). i was trying to do that after the task sequence to guarantee a Zero touch.

    I managed to force the sysprep /oobe /shutdown at the end of the task sequence. but as you said i get error probably because the computer is domain joined.

    So no success

    i'll try a way to script the pen pairing so first logon the user is prompted to pair the pen.

    Thanks


    MCTS - SCCM 2007 and 2012 MCSA - Windows 8, 10, Server 2012 and Office 365

    Friday, September 9, 2016 2:02 AM