locked
Double click a drive or folder opens the Properties dialog instead of the normal Open behavior RRS feed

  • Question

  • When I double click a drive or folder, the Properties dialog opens instead of the normal Open behavior. If I right click on a drive or folder, the default (hilited) action is "Move or Rename Audio Files".

    How do I restore normal behavior. I don't see any way to change the default open behavior like I could in XP via the Folder Options, File Types dialog.

    Windows 7 RC1 Build 7100
    Monday, August 31, 2009 3:09 AM

Answers

  • Hi,

     

    Thank you for posting.

     

    If the issue did not occur previously, please just try System Restore first.

     

    I suspect this issue may be also related to the mouse settings. Please go to “Control Panel\Hardware and Sound” and click “Mouse” and check your mouse settings; please ensure that the left button is set to “Click” and right button is “Right-click”.

     

    You may also click the Restore Defaults to reset the mouse settings.

     

    If you use some other application to manage the mouse, please also check the settings or just remove it.

     

    Thanks.


    Nicholas Li - MSFT
    • Marked as answer by Nicholas Li Monday, September 7, 2009 2:13 AM
    Wednesday, September 2, 2009 11:02 AM

All replies

  • Interestingly I had the same problem today with a remote folder.
    It disappeared by itself after 15 minutes!?

    Windows 7 RC1 Build 7100
    Monday, August 31, 2009 10:12 PM
  • Hi,

     

    Thank you for posting.

     

    If the issue did not occur previously, please just try System Restore first.

     

    I suspect this issue may be also related to the mouse settings. Please go to “Control Panel\Hardware and Sound” and click “Mouse” and check your mouse settings; please ensure that the left button is set to “Click” and right button is “Right-click”.

     

    You may also click the Restore Defaults to reset the mouse settings.

     

    If you use some other application to manage the mouse, please also check the settings or just remove it.

     

    Thanks.


    Nicholas Li - MSFT
    • Marked as answer by Nicholas Li Monday, September 7, 2009 2:13 AM
    Wednesday, September 2, 2009 11:02 AM
  • Sorry, I'm not receiving notification of replies to my post, so I did not know anyone had responded.

    The problem resolved itself, though I don't know why or how.

    If it happens again, I'll try System Restore though that seems a bit drastic and I would much rather figure out what is causing it.

    Why am I not being notified of responses to my posts? I have the Alert me box checked.

    Also, as I mentioned in my first post, the highlighted default action was Move or Rename Audio Files, not Open as it is now, mouse settings have nothing to do with this problem. I did check anyway and they are correct.
    Tuesday, September 8, 2009 3:10 AM
  • This is the Roxio CD creator software and it's a pain.

    I cleared it by searching for RXDCExtSvr in the registry editor.  Roxio CD Creator registers a context menu handler for *, Folder, and some others depending on the version it seems.  Deleting the handler worked for me.  The key to delete will always have "shellex\ContextMenuHandlers" in the path

    An example of one key is HKEY_CLASSES_ROOT\Folder\shellex\ContextMenuHandlers\RXDCExtSvr
    Monday, October 19, 2009 4:10 PM
  • I don't have Roxio installed so that is not the case for me.
    Monday, October 19, 2009 5:13 PM
  •  

    Check that your ALT key is not stuck down.

     

    In Windows, holding ALT and double-clicking a drive or folder opens its properties.

     

    :)

    Wednesday, July 27, 2011 10:54 AM
  • Maybe this will work for XP as well, or they may have a fix for it.

     

    I had the same problem. The link for this fix is here: http://www.winhelponline.com/blog/file-asso-fixes-for-windows-7/

     

    It took hours to find this and only minutes to execute and fix. I downloaded the three bottom files: "Directory", "Drive" and "Folder". Closed all open programs, ran the files one at a time. No re-start was required.

    Saturday, August 20, 2011 3:11 PM
  • Hi,

    Press ALT button. It may stuck somewhere... 

    I faced same issue in WIN 7 .

    Saturday, February 18, 2012 10:31 AM
  • thank you anand
    Saturday, July 14, 2012 4:27 PM
  • ALT Key is Presses or may be ALT key is HOLDED (may be due to dust or problem in ALT switch)
    Sunday, November 18, 2012 9:28 PM
  • yes, it will disappear after some time..

    Sunday, December 2, 2012 9:20 AM
  • It also happen with me and resolved automatically after 10mins or so,

    I was working with Excel macros just before that, to mention it was big file. I closed that and tried to copy that to another location and this problem started. then, I again opened that file and saved and then this problem gone..

    has anybody faced something smililar to that?

    Thursday, October 31, 2013 12:01 PM
  • lol that's what i call a simple solutions, 
    thank u Kind Sir
    Wednesday, November 27, 2013 6:30 PM
  • Alt key thing worked for me :) I don't know how it got stuck on my laptop but I just pressed on both alt keys so the problem resolved. This is so funny though!
    Wednesday, January 15, 2014 10:24 PM
  • You have a stuck "Alt" key on your keyboard.

    Replace keyboard.

    "Alt + Double left click" equals same as "right click --> R (properties)".

    Sunday, February 2, 2014 11:51 PM
  • I had a similar issue now. Every action was being alternated by the mice (right-click, left-click, selection tool, drag and drop, etc...) and even some shortcut keys on the keyboard.
    ALT key was not active and I did try to hit it a few times, then activated and deactivated it with the OnScreenKeyboard - no help.

    But a simple reboot resolved the issue for me.

    It might have been a system update side issue, I don't know. But the reboot did do the job.


    • Edited by WhiteQueen Wednesday, August 13, 2014 4:29 PM
    Wednesday, August 13, 2014 4:28 PM
  • Thank you, thank you, thank you for posting this.  I'd already tried rebooting twice, and System Restore.

    Apparently ALT key on either the primary or add-on keyboard was stuck.  Clicking each of the four ALT keys a a few times resolved this, and saved my bacon today!


    Barbara Crane

    • Proposed as answer by ntb13 Wednesday, April 15, 2015 3:09 PM
    Tuesday, December 2, 2014 10:30 PM
  • Thanks man! You're a life saver =)
    Friday, May 22, 2015 2:40 AM
  • This fixed it. Thanks.
    Tuesday, September 22, 2015 1:14 PM
  • It is very simple.

    Start--Run and type in: regsvr32 /i shell32,click OK. and reboot the system.

    Works on Win7, Win XP.

    Thursday, December 24, 2015 6:15 PM
  • Thanks.
    It was the ALT key
    Tuesday, March 1, 2016 5:34 PM
  • Same problem on Win7.

    It was the CTRL key in my case.

    Wednesday, March 9, 2016 3:24 AM
  • Haha that was it for me somehow. Thnx! 
    Tuesday, May 10, 2016 12:00 PM
  • Noice
    Thursday, December 29, 2016 6:52 PM
  • Hi,

    Sticky Keys might have been turned on.

    Hitting two keys at a time will turn off sticky keys.

    Friday, January 6, 2017 5:07 AM
  • Hi,

     

    Thank you for posting.

     

    If the issue did not occur previously, please just try System Restore first.

     

    I suspect this issue may be also related to the mouse settings. Please go to “Control Panel\Hardware and Sound” and click “Mouse” and check your mouse settings; please ensure that the left button is set to “Click” and right button is “Right-click”.

     

    You may also click the Restore Defaults to reset the mouse settings.

     

    If you use some other application to manage the mouse, please also check the settings or just remove it.

     

    Thanks.


    Nicholas Li - MSFT


    Holy cow, Batman: somebody reports a problem with mouse behaviour and you recommend a system restore as the remedy? Little heavy-handed, don't you think? Especially when tapping the ALT key once or twice usually fixes this issue, as per MarkDempsey's post.

    Just to report though that this issue is still live in more recent versions of Windows, such as Windows 10 and Windows Server 2012. It's not particularly regular but I do seem to run into it more often when using remote desktop.

    Thanks,

    Bart


    • Edited by Bart Read1 Friday, January 6, 2017 3:47 PM
    Friday, January 6, 2017 3:47 PM
  • Worked for me. Alt key did not look stuck, but probably was.

    Obviously RESTORE wouldn’t’ve helped

    Thanks
    Friday, April 21, 2017 3:49 PM
  • I also had this, and for some reason, when I tried typing in Chrome's omnibar it would open the settings. I fixed it by spamming the alt and alt-gr keys a couple times, so I suspect the computer got stuck in 'alt-down' mode, however that may have happened.

    Saturday, May 20, 2017 7:40 AM
  • Thousand Thank for you!!!!!!  What a silly error - ALT was stuck down  :) :) :)

    Friday, June 2, 2017 9:44 PM
  • yeah I was going to say the same thing.  What a useless answer!

    BTW: Alt key worked for me!  Oh wait, maybe I should do a system restore just to be sure.

    Sunday, July 9, 2017 5:44 PM
  • That was it for me. Thank you!!!
    Thursday, August 2, 2018 6:05 PM
  • Thanks bro ! This solved my problem. The Alt key was pressed unnoticeably
    Thursday, September 13, 2018 6:51 PM
  • it s helpful
    Friday, December 7, 2018 9:52 AM
  • Awesome! The ALT key was indeed stuck down...I read your suggestion & simply clicked on both alt keys & I suppose they got 'un-stuck' and the mouse began to work fine. Thanks for your advice!!
    Wednesday, November 20, 2019 4:01 PM
  • Wow,it worked for me.Now it maybe repaired itself or it was becouse of alt stuck.First time happening for me and hope not more(I pressed both alt buttons,not at the same time,multiple times).
    Friday, April 24, 2020 6:31 PM
  • Thank you so much for this it was the problem down to a "T" My alt key was stuck and as soon as i fixed it everything was normal... Is there setting somewhere to turn of alt click function???
    Wednesday, May 13, 2020 8:46 PM