locked
Annoying! Alt-Tab fades out all other windows! RRS feed

  • Question

  • I guess you did this to improve, however I find it very annoying. When I switch between windows using Alt-Tab I would like to still see my current application like before. How do I disable the fadeout when pressing alt-tab?

    Also, when alt-tabbing between apps, the app-list (or what it could be called) is not always on top! So it sometimes get behind the application windows, thus it's impossible to navigate to the application I want to switch to!
    I've uploaded a screenshot of this annoyance: http://i28.tinypic.com/2a6mbyg.jpg
    The screenshot shows how a notepad document completely overlays the alt-tab menu, making it impossible to view all current open applications.
    • Edited by HAL07 Monday, August 24, 2009 8:04 AM
    Friday, August 21, 2009 6:27 AM

Answers

All replies

  • Start | Control Panel | System | Advanced System Settings | Advanced | Performance Settings | Uncheck "Enable Aero Peek"
    Thursday, August 27, 2009 4:05 AM
  • Thursday, August 27, 2009 4:16 AM
  • thank you very much. however strange that it's not located in the Personalization menu in control panel.
    Friday, August 28, 2009 2:23 PM
  • The Peek preview is supposed to show up BEHIND the Alt-Tab app-list.

    I think this is a serious bug in Windows 7 with Alt-Tab and Aero Peek that the app-list falls behind the preview window.

    Some people have said if they reboot, they can get the correct behavior for a while before it starts happening again...
    Wednesday, September 23, 2009 8:32 AM
  • I concur... WHAT AN ANNOYANCE!!!!!   I work with more than a dozen windows opened at all times (have to, becasue of the apps I use), and this feature makes it really difficult to find windows whan I have to switch.  The solution proposed of "Uncheck 'Enable Aero Peek'" does nto work for me.   Whoever designed this behavior only tested with a couple of windows opened.  PLEASE MS, GET RID OF THIS  or provide an effective way of turning it off.
    Friday, October 30, 2009 2:44 PM
  • So disabling Aero Peek is marked as an answer when it removes Desktop peeking on the lower right? Doubtful mod practice...

    Btw, the same annoying behaviour is shown when you hover taskbar preview tabs.


    EDIT: even when you switch between maximized/fullscreen apps, the desktop shortly shows through using alt+tab. Good job annoying users, Microsoft.
    Friday, October 30, 2009 9:12 PM
  • So disabling Aero Peek is marked as an answer when it removes Desktop peeking on the lower right? Doubtful mod practice...

    Btw, the same annoying behaviour is shown when you hover taskbar preview tabs.


    EDIT: even when you switch between maximized/fullscreen apps, the desktop shortly shows through using alt+tab. Good job annoying users, Microsoft.

    It seems the two are inter-dependent (the annoying alt-tab behavior and lower right desktop peek).

    Note unchecking "Enable Aero Peek" does not disable Aero Peek.  I still have taskbar button hover peek and the Win-tab window selector.  Maybe these are controlled by "enable desktop composition".
    Saturday, October 31, 2009 1:34 AM